Firmware Downgrade with R4i Gold Pro

Discussion in 'NDS - Flashcarts and Accessories' started by Chargi, Nov 10, 2013.

  1. Chargi
    OP

    Chargi Newbie

    Newcomer
    3
    0
    Sep 13, 2009
    Australia
    Hello!

    I've been using my R4i Gold in Spring 2013 already, without problems.
    (This one: http://www.r4i-gold.com/en/product/)
    Now it didn't work anymore... so I started trying out new Wood Version and so on... games didn't load , so I thought maybe I have to upgrade the firmware (after trying new sd card etc.)

    Long story short: I have to downgrade the Cart, because it doesn't seem to be the proper "new" 2013 version.

    Now it runs on v6.02 and I can't downgrade it.
    When I start the old Firmware Installer, it says:
    "The current version is higher than the upgrade version.Don't need to upgrade!"

    How can I downgrade? Only with another cart which runs an old version?
    When I look at the clear text code in the *.nds it states "The current version is higher than the upgrade version. Are you sure upgrade firmware?" - but it doesn't pop up when I run the installer. Does it maybe hang up on loading?

    (Tried with the yellow Wood 1.60 and 1.62)
    (Tried different microSD cards)
    (Tried different formats)

    I appreciate your help.
     
  2. Xexyz

    Xexyz GBATemp's™ Official Xexyz

    Member
    1,386
    443
    Jul 29, 2013
    United States
    沖縄県
    Wood R4 doesn't work on R4i Gold Pro because it used hacked wood. Which is a clone of the R4i Gold 3DS (r4ids.cn). R4iDSN (r4dsn.cn) and R4i Gold 3DS (R4ids.cn) and the original R4 only support official Wood R4.
     
  3. Chargi
    OP

    Chargi Newbie

    Newcomer
    3
    0
    Sep 13, 2009
    Australia
    I know, I've already got a working Wood. I want to downgrade the firmware, not the kernel.

    Any chances?
     
  4. Another World

    Another World Emulate the Planet!

    Former Staff
    10,498
    1,673
    Jan 3, 2008
    Colombia
    From Where???
    the firmware or bootloader is used to trick the dsi/3ds into booting the cart. they are backwards compatible. your updated bootloader will work on dsi 1.4.1-1.4.5, for example. i'm confused why you feel you want to downgrade it or how that is going to help you? did you get a bootloader to install for a different flash kit? what do you mean by "it doesn't seem to be the proper "new" 2013 version"?

    -another world
     
  5. Chargi
    OP

    Chargi Newbie

    Newcomer
    3
    0
    Sep 13, 2009
    Australia
    I'm running it on a normal DS.

    I read there are 2 versions for the r4i gold pro Clone out there (2013 and not really 2013).

    When I upgraded the firmware to the listed 6.0 on their site, I took the proper Wood for it on the site and it loaded up, but when I load a game, the screen ends up being white.
    So I want to revert the firmware upgrade to the old version, but the Firmware Upgrader doesn't let me.
     
  6. Another World

    Another World Emulate the Planet!

    Former Staff
    10,498
    1,673
    Jan 3, 2008
    Colombia
    From Where???
    if the cart boots and you can run wood, then your problem isn't with the bootloader. if the bootloader was bad, corrupted, etc, you would not even be able to boot into the kernel.

    did you try reformatting your msd card with the panasonic sd formatter? always put on a clean copy of their hacked-up wood for clones and not a previously backed-up copy, as the back-up could have corrupted files.

    you may also want to check into retrogamefan's updates, as he may support your clone.

    -another world
     
  7. perrochiba

    perrochiba Newbie

    Newcomer
    8
    2
    Jan 25, 2015
    United States
    any solution?