Fire Emblem: The Sacred Stones cartridge won't save.

Discussion in 'GBA - Console and Game Discussions, Help and Tips' started by Slytris, Mar 24, 2016.

  1. Slytris
    OP

    Slytris Newbie

    Newcomer
    1
    0
    Mar 24, 2016
    United States
    Hi everyone,

    I have an interesting problem.

    I just bought a used copy of FE Sacred Stones from my local store, I had this game stolen from me about 10 years ago when it came out and I've missed it a ton.

    When I loaded it into my DS and started up a new game, instead of creating a save file, the tile flipped over and still said "New Game". I played through the 1st chapter and then tried saving only to have it refuse to save again. Tried putting it in a GBA SP with the same results, so it's definitely the cartridge.

    My first instinct was to check for a dead battery. This happened with my old copy of Pokemon Red and I was able to replace the battery no problem. I've also replaced the CR2032 batteries in other consoles like my Saturn, Dreamcast, and PS2.

    So apparently Sacred Stones uses EEPROM/Flash memory? I was under the impression that all GBA games used SDRAM batteries like the one in my copy of Megaman Battle Network, which are replacable.

    This copy of FESS isn't a bootleg, either.

    Anyone have any ideas as to how to go about fixing a dead EEPROM/save function? Any help would be much appreciated.
    12887484_1072035106153394_1273074446_o.jpg