Gaming Final Fantasy IV Popstation?

Okami Wolfen

Well-Known Member
OP
Member
Joined
Jul 10, 2009
Messages
257
Trophies
0
Age
31
Location
Ohio
XP
109
Country
United States
I played through Final Fantasy V and VI on my PSP just recently, and I've been wanting to play Final Fantasy IV. The load times for the Anthology games weren't as bad as people made it out to be, likely because I was playing from a memory stick instead of a disk. They were still there, but I got through it. Final Fantasy IV, however, has the worst load times out of the three. And when I go into a town or battle, the music always seems to take forever to start playing. I'm running on a PSP 3000 with GEN-C firmware. I've tried it on Popstation 3.71 and 3.72. Both give me the same problem with the music. I read that version 3.40 solves the music problem, but when I try to load 3.40 my PSP freezes and turns off.

((Yes, yes, I know I could play the SNES version on my PSP. But I really want to see the differences in translation between Final Fantasy II US and the J2E fan translation.))
 

Jamstruth

Secondary Feline Anthropomorph
Member
Joined
Apr 23, 2009
Messages
3,462
Trophies
0
Age
29
Location
North East Scotland
XP
669
Country
Just for info a Popstation is this
1389812.jpg

A crappy PSP rip-off LED game.
I had this sudden image of someone trying to make an RPG for something like that *s[censored]*

I'm afraid I don't know much about POPS loading the FF:Anthology. The compatibility list I have lists 3.51 as a good one to try. To reduce loading times try turning the disc load speed to fast if not already there (in which case turn to normal as sometimes Fast can actually slow down the game)
 

Okami Wolfen

Well-Known Member
OP
Member
Joined
Jul 10, 2009
Messages
257
Trophies
0
Age
31
Location
Ohio
XP
109
Country
United States
I read that Popstation is the built in PS1 emulator for PSP. Popsloader is what lets you use older versions of the emulator that were launched with older PSP firmwares.

I'm beginning to wonder if it's a problem on my end. do you know where I can get a new install of popsloader:?
 

xist

ΚΑΤΑ ΤΟΝ ΔΑΙΜΟΝΑ ΕΑΥΤΟΥ
Member
Joined
Jul 14, 2008
Messages
5,859
Trophies
0
XP
973
Country
Do you actually have the 3.40 pops prx's in your Popsloader compenents in seplugins?

And pops is the emulator, popstation is the command line tool for converting images to eboots and popsloader is the plugin that lets you use different versions of pops to maximise PSX game compatibility.
 

Apex

Well-Known Member
Member
Joined
Sep 4, 2006
Messages
387
Trophies
0
Age
33
Location
茨城県
XP
1,038
Country
Pops loader compatibility can be a pain to mess with, but there's a multi-loader pack somewhere that let's you select a popsloader version before you start the game. (And to reselect you hold down the R button when entering the game.) Google'l tell you right where it's at.

BUT, if I may make a suggestion, you could always go with the GBSp Kai (or whatever it's called.) the GBA emulator for PSP, it has pretty much 100% compatibility with all games, and the Version of FFIV for it is the advance version, which has more stuff to do in it, like a secret bonus dungeon. Not to mention the file size of the GBA version is probably 1/25th of the PSX version.
 

prowler

Sony
Member
Joined
Jul 14, 2009
Messages
9,475
Trophies
0
Location
Ragol
XP
3,294
Country
Zimbabwe
Apex said:
BUT, if I may make a suggestion, you could always go with the GBSp Kai (or whatever it's called.) the GBA emulator for PSP, it has pretty much 100% compatibility with all games, and the Version of FFIV for it is the advance version, which has more stuff to do in it, like a secret bonus dungeon. Not to mention the file size of the GBA version is probably 1/25th of the PSX version.QUOTE(Okami Wolfen @ Oct 23 2010, 03:18 PM) ((Yes, yes, I know I could play the SNES version on my PSP. But I really want to see the differences in translation between Final Fantasy II US and the J2E fan translation.))
 

Jamstruth

Secondary Feline Anthropomorph
Member
Joined
Apr 23, 2009
Messages
3,462
Trophies
0
Age
29
Location
North East Scotland
XP
669
Country
The GBA version will have the proper translated version rather than the nerfed SNES version.

And for the OP, I just watch far too much of Ashens. GEN is known for having a lower PSX compatibility than M33. The accounts I read from my compatibility list were tested on 3.80 M33
 

Okami Wolfen

Well-Known Member
OP
Member
Joined
Jul 10, 2009
Messages
257
Trophies
0
Age
31
Location
Ohio
XP
109
Country
United States
QUOTE said:
The GBA version will have the proper translated version rather than the nerfed SNES version.Yes, but the sound quality and ATB glitches deter me from it.

QUOTEDo you actually have the 3.40 pops prx's in your Popsloader components in seplugins?
I have libpspvmc340.prx, pafmini340.prx, pops340.prx, and popsman340.prx inside my seplugins/popsloader folder.

EDIT: Installed CFW 3.70, and the problem is still there. The PS1 logo shows up, but then nothing happens. This occurs with both 3.40 and 3.51 pops.

EDIT2: Tried Vagrant Story with 3.52 pops, and the same thing happened again. PS1 logo showed up, then the SquareSoft logo. After that, black screen.
 

You may also like...

General chit-chat
Help Users
  • No one is chatting at the moment.
    KenniesNewName @ KenniesNewName: Don't forget to like them +1