EZ-IV DS ROM Dumping (And Finding DLDI Information)

Discussion in 'EZ-Flash' started by SpookyAction, Apr 23, 2017.

  1. SpookyAction
    OP

    SpookyAction Newbie

    Newcomer
    2
    0
    Apr 23, 2017
    I'm trying to dump all of my DS carts, and am running into a problem. When I use the NDS Backup Tool (Slot2) and try to create the ROM, it displays the error message "Data transfer failed. Please do over again." From what I have been able to find so far, it seems like this may be related to DLDI, as it has to read/write from/to the flash cart. The slot 1 cartridge that I am using to load the tool is a DSTwo Plus, which is supposed to automatically patch software when it runs, but I'm not sure what to do about the EZ-IV in slot 2. Does the .bin for this cart need to be patched, or is that only for software running from slot 1?

    I would just try it to see what happens, except that the page linked for all of the DLDI stuff (http://chishm.drunkencoders.com/DLDI/) appears to be down, so I guess the second part of this is whether there is a new place to find all of the DLDI stuff.
     
  2. migles

    migles Mei the sexiest bae

    Member
    GBAtemp Patron
    migles is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    6,970
    4,697
    Sep 19, 2013
    Saint Kitts and Nevis
    my dad works for nintendo.
    you need to apply the dldi patch (which you probably already dead)
    and lock out the dldi so the dstwo doesn't patch it with his own...
    i ran into that problem, but i don't remember about that message..
    however here, probably this will fix it: https://www.chishm.com/DLDI/index.html
    scroll down into patching tools you will find No auto-patch GUI (link to the download https://www.chishm.com/DLDI/downloads/dldi-noap-gui.zip )
    use the no-patch, to lock the dldi area of the nds backup tool
     
  3. SpookyAction
    OP

    SpookyAction Newbie

    Newcomer
    2
    0
    Apr 23, 2017
    Thank you so much for the updated links! I misunderstood how the patching was supposed to be done for the tool on the slot 1 card; I thought that it was to be patched with the slot 1 card's DLDI, and the tool on the slot 2 card patched with the slot 2 DLDI, but it seems like both are supposed to be patched with the slot 2 DLDI (and auto-patch disabled), as that's where the program is actually running maybe? Anyway, it's sitting at FAT Initialization now, and I don't know if it's frozen or if it's just going to take a while with such a large SD card, but I feel like now I at least have the information to try to figure out things.

    Also, I updated the links on the DLDI page of the wiki in case someone else is trying to find it. I hope that's ok.