Does Sky3DS forces updates?

Discussion in '3DS - Console, Accessories and Hardware' started by WhyKlef, Mar 1, 2015.

  1. WhyKlef
    OP

    WhyKlef Advanced Member

    Newcomer
    50
    5
    Apr 19, 2006
    Canada
    I have my Gateway 3DS. I'm getting tired of waiting for their support so I'm thinking of grabbing a Sky3DS but I do not want to update to 9.5 (or whatever is latest firmware)

    I'm interested in playing some older titles. Having not picked up my 3DS or 3DSXL in quite some time, I can catch up so to speak. Will I be forced to update to 9.5 if I use my Sky3DS to play titles like say Bravely Default on my New 3DS?

    If not, I would assume it would only depend on the update of the rom I inject yes?

    And last, would there be any way for me to grab a save played from a Gateway cartridge and use it while playing with the Sky3DS one?

    Thanks in advance y'all!
     
  2. xile6

    xile6 GBAtemp Maniac

    Member
    1,194
    305
    Jan 15, 2006
    United States
    I'm awaiting my sky3ds so I can't fully answer everything but here goes.

    The games are what they are. So if they didn't need an update on the original cart then they won't need a system update on aky3ds.
    So your be fine with bravely default.

    And most have said the saves transfer isn't working correctly but I don't have hands on with that
     
  3. dandymanz

    dandymanz GBAtemp Regular

    Member
    179
    92
    Dec 5, 2014
    Senegal
    Sky3ds won't force you to update to 9.5. You can play it on whatever firmware version that your N3DS is on.I would guess its on 8.1 or 9.0
    However, if you want to connect to the eShop to update certain games. Like MH4 or POR/PAS, then because of the eShop, you will need to update to 9.5
    Basically, if you don't play games online and keep things offline. Nothing is required.

    Oh ya, i don't think you can transfer saves from Gateway to Sky3ds. But i'm not 100% sure.