Dislodged RF shield on 2DS causing issues

Discussion in '3DS - Console, Accessories and Hardware' started by BL4Z3D247, Dec 13, 2016.

  1. BL4Z3D247
    OP

    BL4Z3D247 GBAtemp Stoner

    Member
    1,699
    417
    Oct 22, 2008
    United States
    I'm so high, I don't even know!
    Hi all! Been a hell of a long time since I've visited this place. Hope all is well for everyone! Anyways, I recently acquired a 2DS and it had something loose inside, so I opened it up. I found the RF shield or what some refer to as a heat shield or heat sink had come dislodged from the motherboard so I got the soldering iron out and soldered it back into place. Now the solder wasn't really sticking to the pads even after a little cleaning up and applying flux. After I soldered it as best as I could I put some electrical tape over the RF shield as so it wouldn't move if I placed it down too hard to lightly dropped it. It worked for some time and the only quirk was I couldn't boot the 2DS while plugged in charging. But now I can't have it booted and plugged in or else it freezes and after a full charge it won't boot into the home menu screen at all unless I do a 9.2.0 crt transfer. I can access payloads when I can get them to launch, sometimes takes multiple attempts which leads me to believe the RF shield is more than just that.

    My questions are:
    1. Does this sheild also act as a way to complete a circuit relevant to charging while booted or trying to be booted? It seemed to boot fine without the shield but would glitch the screens out and freeze when plugged in to the charger when running.

    2. If the answer to the question above is even possibly then can I just jumper the contacts in series to bypass this charging debacle I'm having?

    3. And lastly but not least, how do I get the solder to stick to these damn contacts?! It's driving me insane! I've already tried bumping up the heat on my soldering station, no go. I've removed all old solder and applied new solder, no go.

    I think that about covers it. Any help or ideas, past experiences with this problems or hopefully fixes would be much appreciated. =]

    Here's a video of it in action:
     
    Last edited by BL4Z3D247, Dec 13, 2016