Can't play WADs on my SD Card

Discussion in 'Wii - Emulation and Homebrew' started by Flashed, Jan 21, 2017.

  1. Flashed
    OP

    Flashed GBAtemp Regular

    Member
    217
    62
    Feb 3, 2016
    Madrid
    Well... during my project of restoring the Wii I have tried installing some VC/WiiWare Wads on my console. First I installed some like Tetris Party, Arkanoid, 101in1 and some other VC games and they worked all OK.
    But today I have tried to install about 10-15 other WADs, all correspond with my region (at least I think...). So always the thing to do is Install the WAD with Wii Mod Lite and the transfer to SD. So, after installing all WADs, Surpsrise! All games I had on my SD stopped working with the message 'This channel cannot be launched on this Wii console'.

    My Wii is on 4.3E and IOS80 is patched

    Thanks for your help
     


  2. Flashed
    OP

    Flashed GBAtemp Regular

    Member
    217
    62
    Feb 3, 2016
    Madrid
    up!
     
  3. GreyWolf

    GreyWolf GBAtemp Psycho!

    Member
    3,862
    738
    Mar 2, 2015
    United States
    Running games copied to SD requires they either have a valid ticket or the system IOS be patched to restore the signing bug.
     
  4. Flashed
    OP

    Flashed GBAtemp Regular

    Member
    217
    62
    Feb 3, 2016
    Madrid
    Yes my IOS80 is patched but the error still there...
     
  5. Lacius

    Lacius GBAtemp Guru

    Member
    5,634
    2,122
    May 11, 2008
    United States
    There's no reason to patch IOS80 with regard to installed WAD titles.

    Edit: To be clear, IOS80 should be patched, but not for this reason.
     
  6. Flashed
    OP

    Flashed GBAtemp Regular

    Member
    217
    62
    Feb 3, 2016
    Madrid
    Aall right so there is no way to get WADs running on SD?
     
  7. Lacius

    Lacius GBAtemp Guru

    Member
    5,634
    2,122
    May 11, 2008
    United States
    That's not what I said. I don't know why your WAD installations aren't working. Did you try downloading them from another source?
     
  8. Flashed
    OP

    Flashed GBAtemp Regular

    Member
    217
    62
    Feb 3, 2016
    Madrid
    Yes, but the thing is that I install about 5-6 WADs and they all work OK, the problem is installing the rest. All of them stops working with that error message
     
  9. GreyWolf

    GreyWolf GBAtemp Psycho!

    Member
    3,862
    738
    Mar 2, 2015
    United States
    I'm pretty sure the Trucha bug is required for the SM to copy them from the SD content.bin and run them. Just installing them to NAND works without the signing bug.
     
    Lacius likes this.
  10. Lacius

    Lacius GBAtemp Guru

    Member
    5,634
    2,122
    May 11, 2008
    United States
    It's been so many years since I've installed a WAD file on my Wii, that I completely forgot. OP, can you run a sysCheck so we can verify your system menu IOS is patched?
    https://gbatemp.net/threads/posting-a-system-check.300279/
     
  11. Flashed
    OP

    Flashed GBAtemp Regular

    Member
    217
    62
    Feb 3, 2016
    Madrid
    Here it's

    — Posts automatically merged - Please don't double post! —

    Sorry. This is the correct one
     

    Attached Files:

  12. Lacius

    Lacius GBAtemp Guru

    Member
    5,634
    2,122
    May 11, 2008
    United States
    Follow the instructions in the guide so I don't have to strain my eyes.
     
  13. Flashed
    OP

    Flashed GBAtemp Regular

    Member
    217
    62
    Feb 3, 2016
    Madrid
    What guide?
     
  14. Lacius

    Lacius GBAtemp Guru

    Member
    5,634
    2,122
    May 11, 2008
    United States
  15. Flashed
    OP

    Flashed GBAtemp Regular

    Member
    217
    62
    Feb 3, 2016
    Madrid
    Ah right sorry, here it's:
    Warning: Spoilers inside!
     
  16. GreyWolf

    GreyWolf GBAtemp Psycho!

    Member
    3,862
    738
    Mar 2, 2015
    United States
    I'm thinking maybe the IOS the game is running under has to be patched, too. It's been a long time since I ran anything from the SD menu and I've replaced all my patched system IOSes with stock ones since emunand/neek became a viable alternative.

    If I remember correctly I used WiiPower's Trucha Bug Restorer homebrew app.
     
  17. Jack Daniels

    Jack Daniels GBAtemp Fan

    Member
    420
    119
    Jun 6, 2016
    Netherlands
    South-Holland
    you'll need a patched ios 36/37/38 or so, or you can go for ios 236 (non pirate edition)... i'd recommand reinstalling your cioses too since they might not be signed...
     
  18. Flashed
    OP

    Flashed GBAtemp Regular

    Member
    217
    62
    Feb 3, 2016
    Madrid
    I have patched IOS 36 37 38 and same error
     
  19. Jack Daniels

    Jack Daniels GBAtemp Fan

    Member
    420
    119
    Jun 6, 2016
    Netherlands
    South-Holland
    what patch did you do, cause i doubt you got the right patches? you'll need to install your wad's with those patched ioses selected... i hoped you'd go for ios236 since that one can't be mistaken, there's only one version for wii... note: do not use a vwii wad file!!!
     
  20. Lacius

    Lacius GBAtemp Guru

    Member
    5,634
    2,122
    May 11, 2008
    United States
    No, the IOS the game runs under does not need to be patched. In fact, I would advise against patching unnecessary system IOS files.