Cant Install Ninjhax 1 Today For Some Reason

Discussion in '3DS - Homebrew Development and Emulators' started by smallmedicap, Nov 1, 2015.

  1. smallmedicap
    OP

    smallmedicap Member

    Newcomer
    45
    10
    Nov 1, 2015
    United States
    Short Version: Trying to do a new Ninjhax 1 install on an old 3DS, I run it, it gets to 40% and then it loads the internet browser and freezes.


    OK I'm on an old 3DS. I updated it to 8.1.0-10U using the game LEGO Ninjago Shadow of Ronin. I use Cubic Ninja to install Ninjahx 1 (http://smealum.net/ninjhax/)

    I have installed Ninjhax 1 on many 3DSs before so I am pretty sure I am doing nothing wrong. I have even installed Ninjahx 1 on this specific 3DS before and it worked fine! Back then it was on version 6. something, I have since updated this 3DS to 8.1 as I said above.

    Unfortunately I do not have another 3DS to test if it is something on my end or if smealums payloads are down or something.

    I note that on his page (http://smealum.net/ninjhax/) one of the Q&As says this:


    But I know I am definitely using the correct QR code! So it must be something else. I realize smealum is probably a busy person so instead of trying to email him like it says I am trying here first. I type in 8.1.0-10U exactly. I have tried it dozens of times to make sure. I even went so far as to try with the QR code backups from that reddit site.

    I've tried completely factory resetting the 3DS and reformatting the SD card. Nothing works.

    I do always clear the Cubic Ninja save. (Like I said, I have installed on several 3DSs before, and I am doing the exact same steps I always do.)

    Normally when ninjhax runs on a 3DS I see it go from 20% to 40% then to 100% then the HBC loads. (I believe after 40% is when it downloads the payload from smealums site.)

    But on this 3DS, since yesterday, as soon as it gets to 40% the internet browswer pops up and the 3DS freezes.

    I'm going to be away for a few hours so I hope I didn't leave out any info. (I have a feeling that the first response is going to be "smealums payloads are offline".)

    The only other thing I can think of is it has something to do with me using that game to update to 8.1.0-10U. But that doesn't really make sense.

    Thanks ahead of time for any help.
     


  2. GBAFail

    GBAFail Smell my finger.

    Member
    491
    193
    Oct 26, 2015
    United States
    Uranus
    Why not use 2.X? It has kernel access now if you're below 9.3.
     
  3. smallmedicap
    OP

    smallmedicap Member

    Newcomer
    45
    10
    Nov 1, 2015
    United States
    I might have to do that if Ninjhax 1 is abandoned. Does it support everything Ninjhax 1 does? I'm not up to date I guess because I thought it did not at first.

    I tend to stick to what works, and Ninjhax 1 works great for my needs. Up until yesterday.

    Either way I thought if something was broken on his end he might want to know about it. And if something is broken on my end it would be cool to figure out what it is.

    I wonder if sometime anyone can test a Ninjhax 1 install which would let me know if it is on my end or not?
     
  4. GBAFail

    GBAFail Smell my finger.

    Member
    491
    193
    Oct 26, 2015
    United States
    Uranus
    Basically everything has been ported to 2.x by now. Just download the latest version of all your homebrew. If you update to 9.0 - 9.2 you can even boot into CFW automatically.
     
  5. duwen

    duwen Old Man Yoshi

    Member
    1,165
    649
    Sep 6, 2013
    United States
    Bullet Hell
    I had the same issue the last time I tried to install ninjhax 1.1 (admittedly, it was before 2.5 was released).
    I eventually got it to work by deleting the save on CN and rescanning the QR - it took 4 or 5 attempts before it got past 70% and eventually installed.
     
  6. zoogie

    zoogie simple pimp tool

    Member
    6,237
    7,897
    Nov 30, 2014
    United States
    "The only other thing I can think of is it has something to do with me using that game to update to 8.1.0-10U. But that doesn't really make sense."
    That's exactly it. Ninjhax 1 cannot run on 5.0.0+ if your nver is -10U or less.
    Smea never mentions that, but it's true.

    You're stuck with no ninjhax unless you can update the browser or the entire firmware to 9.0-9.2.
    (Or downgrade w/ GW)
     
    Last edited by zoogie, Nov 1, 2015
  7. smallmedicap
    OP

    smallmedicap Member

    Newcomer
    45
    10
    Nov 1, 2015
    United States

    Well I guess that explains it. I wonder why he even allows those options in the selector if it doesn't work. I know he doesn't allow other browser versions to be selected for that reason. It's still odd that LEGO Ninjago updated my browser version, because I know I put Ninjhax 1 on this 3DS before and it was 5.X or higher...

    So is there any way to update just the browser?

    As far as updating to 9.2 do I just need to get a copy of Smash Bros or something?

    — Posts automatically merged - Please don't double post! —

    Yes but mine goes to the browser at 40, not 70. So I think this is a different error.
     
    Last edited by smallmedicap, Nov 1, 2015
  8. zoogie

    zoogie simple pimp tool

    Member
    6,237
    7,897
    Nov 30, 2014
    United States
    Use rxtools to inject FBI over Health and Safety app. Then get the 9.2 upgrade pack from the iso site and use rxtools (in DEV MODE ONLY) to install the update with the sysupater app.

    You can also downgrade to 4x with gateway (it's safe) and install FBI normally with ninjhax, then upgrade with the 9.2 cia with minipasta and the sysupater app. I think this is a little safer than the above method although a little longer.

    You can use a smash cart but only one version, AXCE152 -> AXCE352 (back of cart serial), has 9.2. So it's a $ risk if you can't see the back of the cart and it's expensive (although lowest-risk in terms of 3ds bricking).
     
    Last edited by zoogie, Nov 1, 2015
    klear likes this.
  9. smallmedicap
    OP

    smallmedicap Member

    Newcomer
    45
    10
    Nov 1, 2015
    United States
    OK thank you for the info.

    So if I do get the correct version of Smash Bros that will fix the browser version # problem as well? In other words, that will let me use old Ninjhax 1 again, or will I have to use Ninjhax 2.X?
     
  10. GBAFail

    GBAFail Smell my finger.

    Member
    491
    193
    Oct 26, 2015
    United States
    Uranus
    Just update to 9.0 - 9.2 and use hax 2.X. There is no reason you should still be using 1.1b.
     
  11. smallmedicap
    OP

    smallmedicap Member

    Newcomer
    45
    10
    Nov 1, 2015
    United States

    OK so 2.X does absolutely everything that 1 did? Like running Pasta to install and run unsigned cias, etc?
     
  12. GBAFail

    GBAFail Smell my finger.

    Member
    491
    193
    Oct 26, 2015
    United States
    Uranus
    Yes. You can even boot right into pasta.
     
  13. zoogie

    zoogie simple pimp tool

    Member
    6,237
    7,897
    Nov 30, 2014
    United States
    Yes, it has the same powers as 1.1b.
     
  14. smallmedicap
    OP

    smallmedicap Member

    Newcomer
    45
    10
    Nov 1, 2015
    United States
    OK cool, so as long as 2.X doesn't have a problem with my browser version (or is that just a Ninjhax 1 thing?) I should be good as long as I get the correct Smash Bros.

    Thank you all for all of the help.
     
  15. GBAFail

    GBAFail Smell my finger.

    Member
    491
    193
    Oct 26, 2015
    United States
    Uranus
    That's just a NH 1 thing.
     
  16. smallmedicap
    OP

    smallmedicap Member

    Newcomer
    45
    10
    Nov 1, 2015
    United States

    Okay. I'm a bit confused about that. (I'll probably figure this out on my own but I decided I might as well post an update here.)

    I found the correct Smash today. I'm updated to 9.2. I am running Ninjhax 2.5 Homebrew loads fine.

    First thing I try to do is run FBInstaller in homebrew... it doesn't work. I google that and the first thing I see is this:

    https://www.reddit.com/r/3dshacks/comments/3dqoq9/fbi_on_ninjhax_20/


    Now is that just old news that only applied to 2.0?? (And therefore I just need to update my FBInstaller or something.) Or is that how it works with 2.5 as well? (Which wouldn't sound like "it has the same powers as 1.1b" to me. :))

    Thanks ahead of time for any info.
     
  17. zoogie

    zoogie simple pimp tool

    Member
    6,237
    7,897
    Nov 30, 2014
    United States
    That quoted part is completely 100% false.

    FBI installer won't work unless sigs are patched, i.e. running a cfw.
    try cakes, rxtools, minipasta etc.
     
  18. smallmedicap
    OP

    smallmedicap Member

    Newcomer
    45
    10
    Nov 1, 2015
    United States

    First of all zoogie, thank you very much for your quick response and help.

    That must be my problem.

    After updating to Ninjhax 2.5 I noticed Pasta would not load. So I downloaded "PASTA CFW for ninjhax 2" from the last page of the Pasta thread here

    So is that not a valid cfw I take it?

    Thank you for the suggestions, I have found (your? :)) minipasta in this thread:

    https://gbatemp.net/threads/need-hax-2-x-pasta-loader.400752/

    I am trying that now.
     
  19. cracker

    cracker Nyah!

    Member
    3,143
    411
    Aug 24, 2005
    United States
    It might be that the browser cache just has to be cleared prior to scanning/loading.
     
  20. smallmedicap
    OP

    smallmedicap Member

    Newcomer
    45
    10
    Nov 1, 2015
    United States
    Perhaps, because it is doing the exact same thing in minipasta as well.

    Here is what I am doing exactly.

    Turn on 3ds. Load CubicNinja. Load Homebrew channel. Run cfw (PASTA CFW for ninjhax 2 or, now, minipasta). That loads 3ds menu. Load CubicNinja. Load Homebrew channel. Run FBInstaller. It changes a couple colors then freezes on yellow.

    Perhaps I just need a newer version of FBInstaller... where could I find that? (I'm not sure what version of FBI I have. I cannot find the version # in it on my other 3DS which works...)


    ETA: I just found the FBI thread (I coulden't find it a minute ago because I was literally searching for FBIinstaller instead of FBI and I getting no results...) I'll make sure I have the newest version.
     
    Last edited by smallmedicap, Nov 8, 2015