Homebrew game Can't compile the DS library I want to use for my project

HappyPond

New Member
OP
Newbie
Joined
Nov 19, 2022
Messages
2
Trophies
0
Age
27
XP
36
Country
France
Hi guys,

I wanted to start a hobby project involving some C/C++ programming, which I did not have the occasion to use since my school days, and I am getting quite rusty...
I decided to go for a childhood dream of mine: developing a game for the Nintendo DS.

I wanted to find a library that is user friendly, well documented and that allows me to do local multiplayer (Nifi ? Is that the name ?).
I think I found my dream lib: dsgmLib. It has tones of very cool examples, including one using Nifi. Awesome. Problem: it was not updated in 8 years, and I can't get it to compile.

It relies on DevkitPro and DevkitARM, but it does not compile with the latest versions. The GitHub page has an open issue where one of the guys says he managed to compile it on an older version of DevkitARM, but it seems the guys behind Devikpro are not very keen to provide older versions of the tool. Therefore, I am coming here to try and get answers:
  • Is there another DS library that could replace that one ? Pure libnds dev looks out of my reach, at least at first. I think I need something more high level than that. I tried NFLib, but I did not see anything regarding Nifi and I couldn't get the ROMs to play on a real DS through an R4 card.
  • Is there a way to get an older version of DevkitPro ? It sounds like the easiest solution, and since I would keep everything for myself anyways I don't think it would harm anyone if I used an older version. That being said, the guy going by the name of WinterMute makes very solid points on why they do not provide older versions of DevkitPro, so maybe this is not the best solution either...
  • Could someone help me out to fix the lib so that I could get started ? I honestly don't know how hard it could be. I've looked it up for quite some time, but my C/C++, compilers and Makefiles knowledge is really, really, REALLY rusty. I keep rediscovering stuff that I completely forgot about. I am trying to get further, but I've been stuck on a compiling error saying "multiple definition of `DSGM_invalidObjectInstance'" for a long time now and I don't know what else to try to fix it.
Thanks in advance for your help, and I'll keep this thread updated if I make any progress in the future !
 

godreborn

Welcome to the Machine
Member
Joined
Oct 10, 2009
Messages
38,467
Trophies
3
XP
29,215
Country
United States
that's what sucks about devkitpro is that they rely on updating, they will not help with older builds. even if commands or files are no longer us, deprecated I think is the term, updating isn't necessarily better, unlike a lot of other things.
Post automatically merged:

btw, I tried to compile what I think you were, and I ran into several dependency errors. I got libnds installed, but it was either that or the thing you were trying to compile--it would not compile due to missing filesystem.h , which I have no idea what that belongs to. I even tried googling it.
 
Last edited by godreborn,

NotImpLife

Active Member
Newcomer
Joined
Mar 9, 2021
Messages
42
Trophies
0
Website
github.com
XP
489
Country
Romania
  • Like
Reactions: godreborn

godreborn

Welcome to the Machine
Member
Joined
Oct 10, 2009
Messages
38,467
Trophies
3
XP
29,215
Country
United States
  • Like
Reactions: NotImpLife

Deleted member 591971

Well-Known Member
Member
Joined
Apr 10, 2022
Messages
216
Trophies
0
XP
922
Hi guys,

I wanted to start a hobby project involving some C/C++ programming, which I did not have the occasion to use since my school days, and I am getting quite rusty...
I decided to go for a childhood dream of mine: developing a game for the Nintendo DS.

I wanted to find a library that is user friendly, well documented and that allows me to do local multiplayer (Nifi ? Is that the name ?).
I think I found my dream lib: dsgmLib. It has tones of very cool examples, including one using Nifi. Awesome. Problem: it was not updated in 8 years, and I can't get it to compile.

It relies on DevkitPro and DevkitARM, but it does not compile with the latest versions. The GitHub page has an open issue where one of the guys says he managed to compile it on an older version of DevkitARM, but it seems the guys behind Devikpro are not very keen to provide older versions of the tool. Therefore, I am coming here to try and get answers:
  • Is there another DS library that could replace that one ? Pure libnds dev looks out of my reach, at least at first. I think I need something more high level than that. I tried NFLib, but I did not see anything regarding Nifi and I couldn't get the ROMs to play on a real DS through an R4 card.
  • Is there a way to get an older version of DevkitPro ? It sounds like the easiest solution, and since I would keep everything for myself anyways I don't think it would harm anyone if I used an older version. That being said, the guy going by the name of WinterMute makes very solid points on why they do not provide older versions of DevkitPro, so maybe this is not the best solution either...
  • Could someone help me out to fix the lib so that I could get started ? I honestly don't know how hard it could be. I've looked it up for quite some time, but my C/C++, compilers and Makefiles knowledge is really, really, REALLY rusty. I keep rediscovering stuff that I completely forgot about. I am trying to get further, but I've been stuck on a compiling error saying "multiple definition of `DSGM_invalidObjectInstance'" for a long time now and I don't know what else to try to fix it.
Thanks in advance for your help, and I'll keep this thread updated if I make any progress in the future !
"Some guy got it working on older devkitARM"
Yup, thats me, you can get it from the dsgm setup things, that's exactly what i did (https://github.com/DigitalDesignDude/DS-Game-Maker-5-Setup download devkitarm and setup the enviroment variables), you can also download this https://wii.leseratte10.de/devkitPro/devkitARM/r32 (2010)/ (this page contains a hell ton of archives) but you have to set it up by yourself.

if you have issued with this good luck. Older devkiARM is not supported by anybody so you should be using NFlib or libNDS, if you want nifi then i think nflib supports it and also there is a nifi lib.
 

Site & Scene News

Popular threads in this forum

General chit-chat
Help Users
    SylverReZ @ SylverReZ: @Psionic Roshambo, LOL +2