Can not Update Luma (11.3)

Discussion in '3DS - Homebrew Development and Emulators' started by Sm4shy, May 16, 2017.

  1. Sm4shy
    OP

    Sm4shy Newbie

    Newcomer
    4
    0
    May 16, 2017
    Gambia, The
    The title actually says it all

    I'm on 11.3 and have rednand cfw with a9lh.

    I have the problem that when I will update Luma with the Luma Updater (1.4.2) i'm still on the same version.

    The Luma Updater displays 'Update complete' but after the reboot I'm still on '6.6-1eb18c17'.


    I tried to update Luma manually, and I only had to update arm9loaderhax.bin (corrected me if I'm wrong). But Luma is still on the same version.

    So what I am doing wrong.


    Thanks for any help
     

    Attached Files:

  2. Dionicio3

    Dionicio3 Some Cool Skiddo

    Member
    3,148
    4,745
    Feb 26, 2017
    United States
    Hollister, CA
    First of all, the bold is kind of annoying, second, have you updated the arm9loaderhax.bin in the NAND?
     
  3. Sm4shy
    OP

    Sm4shy Newbie

    Newcomer
    4
    0
    May 16, 2017
    Gambia, The
    Do you mean with NAND the SysNAND?
     
  4. DjoeN

    DjoeN Captain Haddock!

    Member
    5,169
    1,486
    Oct 21, 2005
    Belgium
    Somewhere in this potatoland!
    I know you replaced it manually, but try this:

    Search your SD for any arm9loaderhax.bin
    Remove them ALL
    rename your luma folder to something else
    rename luma stuff under \3ds folder to something else
    copy arm9loaderhax.bin to the root of your SD
    Hold SELECT while booting (you should be in luma config menu
    check version
     
  5. Sm4shy
    OP

    Sm4shy Newbie

    Newcomer
    4
    0
    May 16, 2017
    Gambia, The
    - I deleted arm9loaderhax.bin (root)
    - I renamed the luma folder
    - (Which files in the 3ds folder do you mean with luma stuff)
    - I copied the newest arm9loaderhax.bin (7.0.5) to the root
    - I started luma config menu and I'm still on 6.6-1eb18c17


    I have added an image of the 3ds folder.
     

    Attached Files:

  6. Ominous66521

    Ominous66521 GBAtemp Maniac

    Member
    1,086
    246
    Feb 7, 2016
    United States
    It's probably a bug with rednand or something.Check the 3dsx you are using to launch luma through the hbl/ctrbootmanager and make shure it's the latest one.
     
  7. Quantumcat

    Quantumcat Dead and alive

    Member
    11,060
    5,928
    Nov 23, 2014
    Australia
    Canberra, Australia
    Maybe the SD is failing and it is using the arm9loaderhax.bin on the CTR-NAND. OP, did you update the one on the CTR-NAND also?
     
  8. Sm4shy
    OP

    Sm4shy Newbie

    Newcomer
    4
    0
    May 16, 2017
    Gambia, The
    That was the problem, i didn't know that i have to update the arm9loaderhax.bin in the CTR-NAND also.

    Now Luma is on 7.0.5, but the chainloader no longer works.