Black Screen on HBC and Hanging Hackmii Install After Trying to Run Dop-Mii On vWii

Discussion in 'Wii U - Hacking & Backup Loaders' started by the8bithack, Jul 5, 2014.

  1. the8bithack
    OP

    the8bithack Newbie

    Newcomer
    3
    0
    Jul 5, 2014
    United States
    Okay, MAYBE someone can help me, I'm trying to fix this without doing any damage more permanent than has already been done. So, I have a vWii that has been running homebrew and usb loaders seamlessly for a while. However, I switched usb loaders recently, wanted to switch to USB Loader GX. This worked great! (Awesome loader) So I went to get the forwarder wad and loaded up dop-mii to install it. Oops. I don't think I gave Dop-Mii permission to patch IOS36, I think I selected a few other IOSes to try to install the forwarder wad with, no dice. Then I returned out of Dop-Mii to try MMM instead, to be greeted with blackness on the HBC. A few more retries, nothing. So I deleted my HBC and loaded up smashstack to load up hackmii again, and it freezes on the scam screen.

    Here is the installer.log from that:

    Code:
    HackMii v1.2 installer starting up
    PVR = 00087200
    running under IOS 58 rev 0x1920
    238 titles are installed
    Found IOS 251: revision: 0x5212*
    Found IOS 250: revision: 0x5212*
    Found IOS 249: revision: 0x5212*
    Found IOS 0: revision: 0x0*
    Found IOS 9: revision: 0x50a.
    Found IOS 62: revision: 0x191e.
    Found IOS 59: revision: 0x2421.
    Found IOS 58: revision: 0x1920.
    Found IOS 57: revision: 0x181f.
    Found IOS 56: revision: 0x171e.
    Found IOS 55: revision: 0x171f.
    Found IOS 53: revision: 0x171f.
    Found IOS 48: revision: 0x111c.
    Found IOS 46: revision: 0xf17.
    Found IOS 45: revision: 0xf17.
    Found IOS 43: revision: 0xf17.
    Found IOS 41: revision: 0xf17.
    Found IOS 38: revision: 0x111c.
    Found IOS 37: revision: 0x171f.
    Found IOS 36: revision: 0xf18.
    Found IOS 35: revision: 0xf18.
    Found IOS 34: revision: 0xf18.
    Found IOS 33: revision: 0xf18.
    Found IOS 31: revision: 0xf18.
    Found IOS 28: revision: 0x80f.
    Found IOS 22: revision: 0x60e.
    Found IOS 21: revision: 0x50f.
    Found IOS 17: revision: 0x508.
    Found IOS 15: revision: 0x508.
    Found IOS 14: revision: 0x508.
    Found IOS 13: revision: 0x508.
    Found IOS 12: revision: 0x30e.
    Found IOS 2: revision: 0x221.
    Found IOS 80: revision: 0x1c20*
    launching IOS 58 for the installer...
     
    IOS launched...
     
    IOS versions: Installer: 58, HBC: 0
    starting preparations
    I have a patched IOS80, and that has never given me problems. I tried running syscheck but I couldn't find a boot.elf of the HD edition of syscheck either and 1.6.2 freezes at "initializing FAT file system". So does anything look out of order here? I don't want to do MORE damage trying to fix this. I was able to load up MMM via smashstack but really wasn't sure where to start. Any thoughts?
     
  2. gunner007

    gunner007 GBAtemp Advanced Maniac

    Member
    1,506
    368
    Dec 31, 2013
    United States
    Unfortunately the log doesn't help much since it was probably done earlier.

    Really shouldn't be using DOPMii on a WiiU.

    My guess is DOPMii has patched more than just IOS36.

    In fact, isn't DOPMii for Wii only? I'd fear that not only did it patch IOS, but replaced them with wii versions.

    Hanging at the scam screen is usually a sign of bad IOS. If SysCheck is hanging, something makes me think IOS58 is botched pretty badly.

    My only guess is extract the IOS from NAND dump and pack them into WADS and use yAWMM-EN to install them from smashstack. You can probably use your CIOS to load them.
     
  3. the8bithack
    OP

    the8bithack Newbie

    Newcomer
    3
    0
    Jul 5, 2014
    United States
    Yeah, honestly I do so few wad installs these days that I guess I had it left over on my SD card from my wii and forgot which app I was supposed to use. That makes sense. So figuring out what it did should be quite a bear. Teach me to leave that shit on my SD card. :)
     
  4. gunner007

    gunner007 GBAtemp Advanced Maniac

    Member
    1,506
    368
    Dec 31, 2013
    United States
    Yea, it's gonna be a bit of a nightmare depending on if and how many IOS it patched. I would start though with 58 and 36. Extract them from your VWII NAND dump and pack them as WAD.

    Load up YAWMMM-EN via smash stack, and when it asks for IOS to load from, choose 249-251 (assuming you install d2x CIOS) and try to install 58 and 36 over top. If that's successful, then try running HBC installer again. If that works, then run SysCheck HDE and see what other damage was done.
     
  5. the8bithack
    OP

    the8bithack Newbie

    Newcomer
    3
    0
    Jul 5, 2014
    United States
    Got it. Thanks for the quick and friendly advice. :)