Backing up Xenoblade Chronicles X using ddd question

Discussion in 'Wii U - Hacking & Backup Loaders' started by hsdubb19, May 19, 2016.

  1. hsdubb19
    OP

    hsdubb19 GBAtemp Regular

    Member
    140
    12
    Apr 6, 2012
    United States
    I backed up the game and the folder is 29.3 GB

    I also downloaded the 10GB free DLC that makes the game load faster from the disc.
    Can I delete the 10GB content since it is backed up or should I keep it?
     
  2. bt04

    bt04 Member

    Newcomer
    18
    3
    Oct 27, 2015
    United States
    No, you don't need the DLC. It is the same as the data on the game disc.

    https://gbatemp.net/posts/5839923
    — Posts automatically merged - Please don't double post! —

    A related question. I dumped Xenoblade X 2 times using ddd and the content folder was 9 files and 4.4GB both times. The wiki says it should be 20.2 GB and the OP says 29.3GB
    http://wiki.gbatemp.net/wiki/Loadiine_compatibility_list#X

    I used this command on the PC
    Code:
    titledumper.exe /vol/content "Xenoblade Chronicles X [AX5E01]"
    Do I need to download a patch for the game before dumping it?
     
  3. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,559
    8,911
    Oct 27, 2002
    France
    Engine room, learning
    the game has both an update and DLCs.
    like you quoted, the DLC are not needed as they are only speed packs, files are identical to the disc files. so don't count the 10GB duplicated files (29GB->19GB)
    the DLC are not exactly 10GB, so if your game is around 20GB that's the good size.

    The update doesn't add new files, it only fixes some text's menus. nothing very important, no bug fixes or additional data. the update shouldn't add any size to the dump size.
    You shouldn't get only 9 files, there are more :

    EUR v0 (without update)
    vol/code/ 16.7 Mo (17 615 768 octets)
    vol/content/ 19.1 Go (20 613 078 840 octets), 22 254 Files, 305 folders
    vol/meta/ 10.6 Mo (11 181 552 octets)

    The update replaces :
    /vol/code/spacetravel.rpx 16.7MB -> 16.7MB
    /vol/content/bdat.cpk 51.2MB->51.2MB
    that's all. no size change.
     
  4. bt04

    bt04 Member

    Newcomer
    18
    3
    Oct 27, 2015
    United States
    Thanks, I must have a scratch on the disc. I've tried about 10 times and titledumper keeps hanging on the same file. Cleaning the disc hasn't helped.
    Code:
    Open file: Xenoblade Chronicles X [AX5E01]/vol/content/movie/xs12180100_us.usm
    ^Cad file 96528 kb loaded with 992.892 kb/ss
    Do you know the size of /vol/content/movie/xs12180100_us.usm in bytes? I will create an empty file of the same size so that titledumper will skip it an move on to the next file.
    I've also tried TCPGecko and got a core dump on the Read FSA tab.