Gaming A question about the PSP 3000 and the PSPgo

ChrisMims

Banned!
OP
Banned
Joined
Mar 14, 2009
Messages
206
Trophies
0
XP
63
Country
United States
How do you play downloaded games on the PSP 3000? I need to know soon, because I'm wondering if I should buy a 3000, or a PSPgo. Is it only a matter of time before you can play downloaded UMDs on the PSPgo?

Thanks
-ChrisMims


EDIT 1: Do you put the CSO on the PSP 3000 to play it? Is that just the data from the UMDs?
EDIT 2: I didn't mean to post this twice!
 

Livin in a box

Livin' in a cardboard box
Member
Joined
Jul 18, 2008
Messages
1,794
Trophies
0
Location
Purgatory
XP
582
Country
1000 is the launch and has a smaller screen, less RAM but it can be hacked easily. The 2000 series is a little more hazy; there are the early ones, like I've got, that are fully hackable in every way- you can even create Pandora batteries from within the firmware. But the later versions, that have a different motherboard, cannot be properly hacked and same goes for the 3000 series. The PSPgo cannot be hacked at all yet.
 

taken

Well-Known Member
Member
Joined
Dec 23, 2008
Messages
520
Trophies
0
Location
United Kingdom
XP
121
Country
On a psp 3000 to run custom firmware. your firmware got to be 5.03 sony firmware.

Then you can run chickHen R2 the either gen a or 3.60 enabler.
I hope that answers your question.
 

Livin in a box

Livin' in a cardboard box
Member
Joined
Jul 18, 2008
Messages
1,794
Trophies
0
Location
Purgatory
XP
582
Country
Well, I just remembered....

If you get a PSP on 5.03 or lower, then you may be able to chickHEN and one of the GEN firmwares- I think it's 5.0GEN-A. However, you won't be able to play any of the newer games or anything.
 

taken

Well-Known Member
Member
Joined
Dec 23, 2008
Messages
520
Trophies
0
Location
United Kingdom
XP
121
Country
Livin in a box said:
Well, I just remembered....

If you get a PSP on 5.03 or lower, then you may be able to chickHEN and one of the GEN firmwares- I think it's 5.0GEN-A. However, you won't be able to play any of the newer games or anything.

You can play the newer games when you use the game-decrypter-by-yoshihiro-v4 then use the umdgen4 to build the eboot.bin.

Yes GEN A and 5.00m33-6.
 

ChrisMims

Banned!
OP
Banned
Joined
Mar 14, 2009
Messages
206
Trophies
0
XP
63
Country
United States
taken said:
Livin in a box said:
Well, I just remembered....

If you get a PSP on 5.03 or lower, then you may be able to chickHEN and one of the GEN firmwares- I think it's 5.0GEN-A. However, you won't be able to play any of the newer games or anything.

You can play the newer games when you use the game-decrypter-by-yoshihiro-v4 then use the umdgen4 to build the eboot.bin.

Yes GEN A and 5.00m33-6.
Thanks to both of you
smile.gif
 

stab244

Well-Known Member
Member
Joined
Jun 1, 2008
Messages
662
Trophies
1
XP
333
Country
United States
ChrisMims said:
So no free games on the 3000 or Go, yet?
You're just asking for people to flame you for encouraging piracy aren't you...

Posts merged

Just so I don't make another topic, can the PSP that comes with the PSP Rockband Bundle be hacked with chickHen? And can I downgrade the firmware if I'm on a firmware higher than 5.03? I know you can downgrade firmware on the iPhone and iPT, but not so sure about PSP.
 

triassic911

Burst Mode
Member
Joined
May 9, 2007
Messages
2,747
Trophies
1
Age
32
Location
NYC, USA
Website
google.com
XP
844
Country
United States
stab244 said:
ChrisMims said:
So no free games on the 3000 or Go, yet?
You're just asking for people to flame you for encouraging piracy aren't you...

Posts merged

Just so I don't make another topic, can the PSP that comes with the PSP Rockband Bundle be hacked with chickHen? And can I downgrade the firmware if I'm on a firmware higher than 5.03? I know you can downgrade firmware on the iPhone and iPT, but not so sure about PSP.
No one is going to flame him. We all encourage piracy, just not directly.

As for the psp in the rockband bundle, it is a psp-3000 and it can be hacked with chickhen but I don't know if the newest bundles have fw higher than 5.03. You can't downgrade official firmware on the psp-3000.
 

Spartan117H3

Well-Known Member
Member
Joined
Feb 23, 2009
Messages
209
Trophies
0
Location
Maryland
XP
63
Country
United States
Slim models TA-088v3 models can not be hacked. PSP 2000 with lower than v3 can be hacked.
Usually, the PSP bundles keep a lower firmware/hardware which is why people reccomend people who want a 2000 to get a bundle so that they don't get a v3 mobo.

For the PSP 3000:
I'm not quite sure about the PSP Rockband bundle but I'm pretty sure you'd be safe with the Ratchet and Clank bundle because that's what I got.
 

ChrisMims

Banned!
OP
Banned
Joined
Mar 14, 2009
Messages
206
Trophies
0
XP
63
Country
United States
Is there any difference in the size of the slim, or is it just a name? Also is the one with the better backlight only the 3000?
 

stab244

Well-Known Member
Member
Joined
Jun 1, 2008
Messages
662
Trophies
1
XP
333
Country
United States
Oh okay then. I hope they have it then. Maybe I'll just buy the Phat one of my friend instead. PSP Phat that's already prehacked.
 

Site & Scene News

Popular threads in this forum

General chit-chat
Help Users
    Xdqwerty @ Xdqwerty: @Psionic Roshambo, wut