4GB SDHC card won't work after upgrading from 3.2U to 4.1U

Discussion in 'Wii - Hacking' started by IlluminiX, Oct 23, 2009.

  1. IlluminiX
    OP

    Member IlluminiX GBAtemp Regular

    Joined:
    Feb 3, 2009
    Messages:
    204
    Country:
    United States
    I had no problems on 3.2U but decided to make use of my Kingston 4Gb SDHC Class 4 card and upgrade to 4.1U. I had in the past installed IOS 60 and 61 (with the Tona's shop installer) and just to be sure I had a patched 60 wad installed before I used Wan's 4.1 updater. Everything seems fine and content appears on my non-SDHC 2Gb Kingston card in the SD menu, but when I tried my 4Gb card, it says: "The device inserted in the SD card slot cannot be used." Just so it's clear, the 4Gb card works fine in the HBC and on my computer - so the card itself shouldn't be the issue.

    I googled this issue and haven't found too much, but I tried reformatting the 4Gb card both with XP and Panasonic's formatter, and found out that people have had issues with this since a recent IOS 61/Shop update. My IOS61 is patched and I tried to download an unpatched one with Dop-IOS but it still is reported as Patched with Signcheck. For some reason IOS60 reports as unpatched yet I can still run "content" on my non-SDHC from the SD menu. Signcheck and the HBC both report that I am running of IOS36 which I thought would change once I got to 4.1U but I could be wrong (don't completely get the whole thing).

    My question is: how can I safely either get rid of IOS61 altogether if that truly is the issue with the SDHC or how can I safely unpatch it and "patch" IOS 60? I do have both Bootmii in Boot2 and Preloader so I suppose I can always go back. I just am hoping to get this SDHC card working and I don't have any other ones to test.

    SignCheck 0.3 aka /dev/nintystuff build report
    Wii region Usa
    Wii unique device id 67861517

    IOS number "Trucha bug" "Flash access" "Boot2 access" "Usb2.0 IOS tree"

    IOS254 (ver 3088) Enabled Disabled Disabled Disabled
    IOS250 (ver 65535) Enabled Disabled Disabled Enabled
    IOS249 (ver 14) Enabled Disabled Disabled Enabled
    IOS222 (ver 1) Enabled Enabled Disabled Enabled
    IOS61 (ver 5405) Enabled Disabled Disabled Disabled
    IOS60 (ver 6174) Disabled Disabled Disabled Disabled
    IOS55 (ver 5149) Enabled Disabled Disabled Disabled
    IOS53 (ver 5149) Enabled Disabled Disabled Disabled
    IOS38 (ver 3610) Enabled Disabled Disabled Disabled
    IOS37 (ver 3612) Enabled Disabled Disabled Disabled
    IOS36 (ver 1042) Enabled Enabled Disabled Disabled
    IOS35 (ver 1040) Enabled Enabled Disabled Disabled
    IOS34 (ver 1039) Enabled Enabled Disabled Disabled
    IOS33 (ver 1040) Enabled Enabled Disabled Disabled
    IOS31 (ver 1040) Enabled Enabled Disabled Disabled
    IOS30 (ver 1040) Enabled Enabled Disabled Disabled
    IOS28 (ver 1288) Enabled Enabled Disabled Disabled
    IOS22 (ver 772) Enabled Enabled Disabled Disabled
    IOS20 (ver 12) Enabled Enabled Disabled Disabled
    IOS17 (ver 512) Enabled Enabled Disabled Disabled
    IOS14 (ver 257) Enabled Enabled Disabled Disabled
    IOS13 (ver 10) Enabled Enabled Disabled Disabled
    IOS12 (ver 6) Enabled Enabled Disabled Disabled
     
  2. DarkMatterCore

    Member DarkMatterCore I like turtles.

    Joined:
    May 30, 2009
    Messages:
    886
    Location:
    Cabimas, Zulia, Venezuela.
    Country:
    Venezuela
    signCheck v0.3 and 0.3b have a lot of bugs (at least for me). Try sysCheck v1.1. BTW, the IOS used by the HBC won't never change unless you reinstall the channel with the HackMii Installer after a system modification.
     
  3. IlluminiX
    OP

    Member IlluminiX GBAtemp Regular

    Joined:
    Feb 3, 2009
    Messages:
    204
    Country:
    United States
    Thanks for the reply - I will check it out. I did read after I posted that Signcheck will say IOS60 isn't patched if you installed Preloader like I did (b/c of the ES patch)- so I think Signcheck is fine there. Like I said, wad channels seem to load from the SD menu on my 2Gb SD card, so I imagine that means IOS60 has to be Trucha patched fine. The one thing I do not get is why Signcheck says my IOS61 is TP when I said "No" in the Dop-IOS (and I tried WiiSCU) installation. I'll see what Syscheck reports...
     
  4. IlluminiX
    OP

    Member IlluminiX GBAtemp Regular

    Joined:
    Feb 3, 2009
    Messages:
    204
    Country:
    United States
    Sorry to double post - but I wanted to let everyone who may have this problem or were thinking about what the issue could be know that I figured it out. I tried reinstalling IOS61, patching it, not patching it, and then reinstalled the 4.1U Menu wad - and poof the 4Gb SD card worked! Then I figured it was either the custom menu theme I had (Family Guy!) or Preloader.

    I then reinstalled Preloader and changed some settings and sure enough, the SD card failed to work again... Then I went back to Preloader and saw that in Settings, my System Menu IOS was set to 30 so I changed it to 60. I had actually done that (change to 60) after first upgrading and installing Preloader but my Sys Menu failed to load so I went back to the default and it loaded fine. I just assumed that since Preloader on the main screen says IOS 60, that everything was fine - but I guess I had to change settings to 60 manually. I am surprised that everything else seemed to work with Preloader's setting as 30. So that's that then - wasn't the card, wasn't an IOS problem - it was Preloader! Hope that helps someone else with the same predicament... or maybe I'm the only dumb-dumb.
     

Share This Page