Hardware 2 Switches - Touch screen issues and 2162-0002 problem.

ChronoTrig

Well-Known Member
OP
Member
Joined
Jun 21, 2020
Messages
143
Trophies
0
XP
393
Country
United States
Patched V1 SX Core (with a broken touch screen since I zombied this motherboard into a dropped device) - never activated SX Core License.
Touch screen doesn't work. Has aftermarket LCD screen + OEM V2 Digitizer (which may or not be working due to possibly mangled ribbon cable on arrival).

I wanted to see if it was the game card causing the reason for the Patched V1 touch screen not working, since I already replaced the digitizer 2x, 1st was aftermarket digitizer-- it only worked in a couple corners and that was it... and then an OEM V2 Digitizer which I can't see if it works at all since I'm stuck in the 3 menus on the SX OS Menu which touching them didn't work (joycons didn't work either on the menus), when before with the 1st aftermarket digitizer and another mobo I was in the traditional Nintendo switch menu where I could click the corners and it'd show some sign of working (that was previous to zombifying the sx core mobo into this broken Switch)

What am I looking at troubleshooting (how?) / replacing on the Patched V1 SX Core?

Thanks again for any help.

Edit: I originally had 2 switches having issues, now only 1 Switch with an issue, I fixed the other which had the 2162-0002 error and no touch (I had to remove the game card (original to the system), start the switch, it cleared the error, then reinstalled the game card, touch all came back and no error; it worked, so I removed all the added words for it.
 
Last edited by ChronoTrig,

ChronoTrig

Well-Known Member
OP
Member
Joined
Jun 21, 2020
Messages
143
Trophies
0
XP
393
Country
United States
Ok, edited post. I now only have the issue with the patched V1 SX Core with no touch capability. How do I go about testing the touch screen to see if it works if the ribbon cable looks a bit mangled or to see if it's a game card issue?

Thanks
 

ChronoTrig

Well-Known Member
OP
Member
Joined
Jun 21, 2020
Messages
143
Trophies
0
XP
393
Country
United States
Did some more testing. The V1 Patched SX Core game card works (tested in another working switch), but I've concluded the digitizer does not. I believe it was due to the digitizer arriving with the ribbon cable a bit mangled.
 
Last edited by ChronoTrig,

ChronoTrig

Well-Known Member
OP
Member
Joined
Jun 21, 2020
Messages
143
Trophies
0
XP
393
Country
United States
I bought another LCD/screen OEM assembly (receiving in a couple days) so I just have to swap the mobo/gamecard over..
I will be taking pictures of the ribbon to post on here for yea/nay on if it is the reason for not working on the current one I have.

I have a feeling the OEM switch digitizer is shot because of the ribbon and everything else is working.
I didn't want to keep futzing around with trying to put different digitizers on and spending more to try and figure out what works and what doesn't since I'm not a designated shop where I'll recoup $$$. I didn't realize how much I was spending and how fast it was adding up to try and fix the Switch until I looked back at it.
 
Last edited by ChronoTrig,
General chit-chat
Help Users
    Veho @ Veho: As if cats gave a shit (ha!) about sand. The only reason sand is used in cat toilets is that...