Wood R4 on M3i Zero

Discussion in 'M3 Adapter' started by Pedro250, Sep 13, 2010.

  1. Pedro250
    OP

    Pedro250 Member

    Newcomer
    40
    0
    Sep 12, 2009
    Hi,
    Is there possible to load Wood RPG on M3i Zero?
    In this topic THIS TOPIC is showed how to use R4i RTS on M3i Zero.
    If R4i RTS can load Wood R4, the method used to load R4i RTS on M3i Zero could also be used to load Wood R4 on M3i Zero, but i don't know how to do it.
    If anyone can help me, thanks in advance
     
  2. tk_saturn

    tk_saturn GBAtemp Psycho!

    Member
    3,327
    14
    Jan 26, 2010
    It's not possible and no R4i can use Wood R4.
     
  3. Lilith Valentine

    Lilith Valentine GBATemp's Wolfdog™ Cuddle lesbian

    Member
    19,771
    20,567
    Sep 13, 2009
    Antarctica
    Between insane and insecure
    Hey, my topic [​IMG]
    Still the reason the R4i RTS can run on the M3 Real/M3i Zero, is because it has an exploit similar to the one iTouch had because it is an M3 Product.
    And no clone of the R4 can run R4 Wood.
    But there is something called WAIO, which can run on it, but it doesn't have cheats and it needs some work to get it done. As well it's not really R4 Wood, as it does not use the WoodRPG engine to load games, you need to load it through another engine.
    In other works, no you can't load the official R4 Wood on ANY other cards, other than R4 and R4 1.1 from shoptemp.
     
  4. Clookster

    Clookster Your Clookster

    Banned
    710
    0
    Aug 20, 2009
    Swaziland
    Suisse Romande
    YSMenu?

    Srry, but we need to do something soon... Those who only have an M3/M3i are a bit in trouble atm.
     
  5. Lilith Valentine

    Lilith Valentine GBATemp's Wolfdog™ Cuddle lesbian

    Member
    19,771
    20,567
    Sep 13, 2009
    Antarctica
    Between insane and insecure
    Well with out and SDK or anything for the M3, there isn't much we can do. All M3 users can do is just sit and wait for the M3 Team to wake up again. Otherwise just don't update or buy another better card.
     
  6. Clookster

    Clookster Your Clookster

    Banned
    710
    0
    Aug 20, 2009
    Swaziland
    Suisse Romande
    OMG.

    Xenon++ made some cryptic files, and nobody understands what he's doing there, I guess.

    It can't be that impossible to run some YSMenu.nds. OK, I'll ask Xenon++ myself tomorrow.
     
  7. CrimzonEyed

    CrimzonEyed GBAtemp Addict

    Member
    2,494
    313
    Sep 3, 2007
    If it was possible for other flashcarts than R.P.G and R4 to use wood theire would be realeses like Wood m3 or somthing. either way if it was possible you would have easily found it by google [​IMG]
     
  8. jurassicplayer

    jurassicplayer Completionist Themer

    Member
    4,355
    505
    Mar 7, 2009
    United States
    Pantsuland
    I don't usually have any problems understanding most of what Xenon++ says...Supposedly it's possible to use YSMenu on the M3, but I've never done it before (I don't have an M3 to test it on).
     
  9. Xenon++

    Xenon++ Taiju Yamada

    Member
    1,394
    2
    Dec 17, 2009
    DS Env Maker can patch r4patch.dat to get it work on M3. You just have to patch less than 100 bytes...
     
  10. Clookster

    Clookster Your Clookster

    Banned
    710
    0
    Aug 20, 2009
    Swaziland
    Suisse Romande
    Oh. [​IMG]

    Thanks for your reply, Xenon.

    Acually I get the following error message with your batch file:

    [​IMG]

    "Type or namespacename "Process" not found"
     
  11. Xenon++

    Xenon++ Taiju Yamada

    Member
    1,394
    2
    Dec 17, 2009
    Really? Could you open libdsem.cs then replace "Process" with "System.Diagnostics.Process" then execute compiler.bat?
     
  12. Clookster

    Clookster Your Clookster

    Banned
    710
    0
    Aug 20, 2009
    Swaziland
    Suisse Romande
    After replacing Process with System.Disgnosis.Prosess in libdesem.cs and executing compiler.bat

    -A black window appeared for a second
    -A new folder "core" appeared in DSEMstub with update.dsem.

    Nothing more. :/

    After that, I tried update.bat and the same error appeared as in the screenshot.

    I always have to replace Microsoft.NET\Framework\v3.5 to get it working at all. No idea if that has anything to do with it.
     
  13. Xenon++

    Xenon++ Taiju Yamada

    Member
    1,394
    2
    Dec 17, 2009
    Then you should have menu.exe.

    >After that, I tried update.bat and the same error appeared as in the screenshot.
    Of course libdsem.cs is overwritten again...

    >I always have to replace Microsoft.NET\Framework\v3.5 to get it working at all. No idea if that has anything to do with it.
    Very sorry but you replace what with what? You mean .net 3.5 isn't working but 4.0 works?
    Well I should make the path configurable...

    I remembered some people said the same thing... Possibly Vista users requires .net 4.0, bad...
     
  14. Clookster

    Clookster Your Clookster

    Banned
    710
    0
    Aug 20, 2009
    Swaziland
    Suisse Romande
    No, it works with v3.5, but not with 4 (Vista)

    I'll try it again in a few hours with menu.exe. Thanks a lot so far, Xenon!