WiiMC - EXCEPTION (DSI) OCCURRED - WHEN PLUGGING IN 2.5TB USB DRIVE

Discussion in 'Wii - Hacking' started by crwys, Aug 22, 2011.

  1. crwys
    OP

    Member crwys GBAtemp Maniac

    Joined:
    Jun 26, 2008
    Messages:
    1,146
    Country:
    United States
    WiiMC has always worked great but with a new 2.5tb drive I bought it just crashes WiiMC whenever it is plugged in.
    Whenever I run the USB test it crashes too.
    My 500GB drive works just fine, its just this drive.
    I am using the latest WiiMC, I have IOS58 installed, I have ciosxd2x installed. I know this doesnt matter but usbloadergx works with my drive.
    My 2.5tb drive uses 4kb clusters and it is using MBR.
    I hope I provided enough information. Thanks.
    Is there any way to fix this?

    http://imageshack.us/f/641/201108191656312341.jpg/
     
  2. Aijelsop

    Newcomer Aijelsop Question Asker

    Joined:
    Sep 11, 2010
    Messages:
    1,000
    Country:
    United States
  3. crwys
    OP

    Member crwys GBAtemp Maniac

    Joined:
    Jun 26, 2008
    Messages:
    1,146
    Country:
    United States
  4. obcd

    Member obcd GBAtemp Advanced Maniac

    Joined:
    Apr 5, 2011
    Messages:
    1,594
    Country:
    Belgium
    USB Loader GX uses a Cios with it's own ehci code.
    WiiMC uses ios58 (I think) with the nintendo ehci code.
    So it's not because one works, that the other is guaranteed to work as well.

    If you switch the HBC to usb, is it capable of seeing the homebrew on your usb drive apps folder?
    The reason I am asking is simply because HBC should use IOS58 as well.
     
  5. crwys
    OP

    Member crwys GBAtemp Maniac

    Joined:
    Jun 26, 2008
    Messages:
    1,146
    Country:
    United States
    Yea I know I was just saying that my drive does work with the Wii but most homebrew applications will result in code dump when trying to initialize my drive. I know that HBC and WiiMC use IOS58 thats why I am asking if there is a fix for this?
     
  6. tueidj

    Member tueidj I R Expert

    Joined:
    Jan 8, 2009
    Messages:
    2,569
    Country:
  7. crwys
    OP

    Member crwys GBAtemp Maniac

    Joined:
    Jun 26, 2008
    Messages:
    1,146
    Country:
    United States
    Hi tueidj, I recompiled WiiMC with the lateste libntfs, like you said, and I am still getting the same code dump.
     
  8. crwys
    OP

    Member crwys GBAtemp Maniac

    Joined:
    Jun 26, 2008
    Messages:
    1,146
    Country:
    United States
    Edit:
    I reported it as an issue at the bug tracker over at WiiMC.
    Tantric pointed me to it being a problem with libext2fs.
    So I reported the problem over at libntfs and libex2fs at their bug trackers.
    Hopefully this is fixed soon.
     

Share This Page