Which flash cart should I use on DSi with 1.4 firmware?

Discussion in 'NDS - Flashcarts and Accessories' started by ltsukida, Oct 27, 2009.

  1. ltsukida
    OP

    ltsukida Member

    Newcomer
    13
    0
    Oct 27, 2009
    United States
    Hello, guys,

    I just got my new DSi which has 1.4 firmware installed already. I am choosing a flash cart for my machine. Unfortunately I do not know anyway that has a DS/DSi that can upgrade my cart for me. Do you guys know if there is any flash cart that can directly use on 1.4 DSi after purchase as a new unit?

    Thanks a lot!!!
     
  2. Ireland 1

    Ireland 1 GBAtemp Advanced Fan

    Member
    666
    6
    Sep 21, 2008
    Go for an AceKard2i
     
  3. CannonFoddr

    CannonFoddr Regular GBATemp Lurker

    Member
    4,119
    72
    Sep 23, 2006
    Sitting by computer
    Why just the acekard2i - why not the M3i Zero, Supercard DSONEi or any of the other 'upgradable' flashcards
    On the next update - the AK2i will most probably still need another DS or DSLite to be used to upgrade it - while those designed from the start to be upgradable will be easier to do
     
  4. ltsukida
    OP

    ltsukida Member

    Newcomer
    13
    0
    Oct 27, 2009
    United States
    But I heard that you need to have a NDL to upgrade the flash cart first , especially AK2i, to use on the new 1.4 firmware. But I dont have a NDL, either of my friends do.
     
  5. House Spider

    House Spider In the GBAtemp attic.

    Banned
    1,282
    0
    Apr 25, 2009
    Dundalk
    M3i Zero vs Supercard DSONEi for me. If you have a DSLite/DSPhat then you could choose Acekard2i.
     
  6. Ireland 1

    Ireland 1 GBAtemp Advanced Fan

    Member
    666
    6
    Sep 21, 2008
    Because AceKard = AKAIO and AKAIO = Wii connectivity.
     
  7. ltsukida
    OP

    ltsukida Member

    Newcomer
    13
    0
    Oct 27, 2009
    United States
    For M3i and DSONEi, do I need a DSLite/DS (which I do not have) to upgrade the card first?
     
  8. House Spider

    House Spider In the GBAtemp attic.

    Banned
    1,282
    0
    Apr 25, 2009
    Dundalk
    Nope they come with cables to update their core with a PC.
     
  9. ltsukida
    OP

    ltsukida Member

    Newcomer
    13
    0
    Oct 27, 2009
    United States
    Thanks, I will check it out.
     
  10. jacely

    jacely Member

    Newcomer
    33
    0
    Oct 23, 2009
    United States
    I find Gamezway.com has lots of cards support v1.4,the store news tells.
     
  11. Whipple

    Whipple GBAtemp Regular

    Member
    122
    1
    Jul 24, 2009
    United States
    AKAIO was the deciding factor for me. Flexibility and compatibility coupled with stability made my choice for me.

    When selecting a flashcart ask yourself these questions:

    What do you intend to do?
    What software / firmware allows you to do what you want?
    What hardware runs that software?

    The answer to the final question should be the deciding factor in your choice.
     
  12. ltsukida
    OP

    ltsukida Member

    Newcomer
    13
    0
    Oct 27, 2009
    United States
    I SAID in my post that the problem is "I do not have a DS lite to upgrade my AK2i card first, which can not be used on DSi with 1.4 firmware installed"!!!!!! That is why I finally choose supercard DSONEi, which do not need an extra DS lite.
     
  13. omgpwn666

    omgpwn666 Guy gamer and proud!

    Member
    2,547
    306
    Jun 14, 2008
    United States
    Florida
  14. Joe88

    Joe88 [λ]

    Member
    11,672
    2,953
    Jan 6, 2008
    United States
    NYC
    that wont matter because once nintendo releases another update blocking carts he will be screwed
     
  15. omgpwn666

    omgpwn666 Guy gamer and proud!

    Member
    2,547
    306
    Jun 14, 2008
    United States
    Florida
    Your right. He doesn't have the option to choose not to update,it will make him apparently. [​IMG]
     
  16. kimo

    kimo Banned

    Banned
    12
    0
    Oct 13, 2009
    United States
    There are so many cards support the 1.4 firmware.

    But you'd better choose a good one for you.

    I think acekard 2i, Super card is good

    I found 0shippingzone.com has a lot of cards support 1.4 firmware.

    Here is the Zero Shipping Zone
     
  17. ltsukida
    OP

    ltsukida Member

    Newcomer
    13
    0
    Oct 27, 2009
    United States
    Ok, man, you dont understand the problem, because you have a DS with a firmware less than 1.4. You upgrade your card first, then you upgrade your system. That is how AK2i support the 1.4 system. If got your machine with 1.4 firmware installed already, then you NEED TO HAVE A DS WITH LOWER VERSION TO UPGRADE THE AK2I CARD FIRST BEFORE YOU USE ON THE YOUR DSI. Therefore, if you do not have an old machine, DSONEi is your ONLY CHOISE!!! UNDERSTAND?
     
  18. omgpwn666

    omgpwn666 Guy gamer and proud!

    Member
    2,547
    306
    Jun 14, 2008
    United States
    Florida
    I said buy one that supports 1.4 already. You can at gamebygame.com
     
  19. ether2802

    ether2802 we have the techno...!!

    Former Staff
    4,350
    5
    Oct 14, 2007
    Mexico
    Pto. Vallarta
    He can get a 1.4 ready, Acekard2i and when a new updates comes, he just need to upgrade the card first before he updates the DSi, still I will go with a M3i Zero if you have the money, or if you just want to play roms and not messing around with apps and tools, then just buy the cheapest upgradable flashcard you find....!!
     
  20. omgpwn666

    omgpwn666 Guy gamer and proud!

    Member
    2,547
    306
    Jun 14, 2008
    United States
    Florida
    Acekard popularity jumped since the new Akaio,Wii connectivity is awesome,and its cheap as hell flash cart. But ether2802 is totally right,depends what you want to do