What Card should I get?

Discussion in 'NDS - Flashcarts and Accessories' started by sander55, Oct 29, 2009.

Oct 29, 2009

What Card should I get? by sander55 at 2:46 PM (879 Views / 0 Likes) 6 replies

  1. sander55
    OP

    Newcomer sander55 Member

    Joined:
    Dec 6, 2008
    Messages:
    10
    Country:
    United States
    I just got a DSi for my daughter and have been looking at the flash carts. I am torn between the M3i, DSonei, and the AceKard 2i. The card must be easy to use as she is 12 and I have her do all the game install (loading) herself. She will be using it mainly for game play of course. Any suggestions would be nice
    Thanks!
     
  2. rockstar99

    Member rockstar99 Hi

    Joined:
    Dec 3, 2008
    Messages:
    7,375
    Location:
    Toronto
    Country:
    Canada
    acekard 2i
     
  3. injected11

    Member injected11 Crescent Freshâ„¢

    Joined:
    Jul 17, 2009
    Messages:
    1,776
    Country:
    United States
    Check the firmware of the DSi. If it is 1.3 (or lower), any will work well, just make sure you update the bootloader of the flash cart before updating the firmware of the DSi. If the firmware is 1.4, I would recommend the M3i Zero, because it can update the bootloader without running in a DSi. The Acekard can't update the bootloader without running in the DSi, and if the firmware is 1.4, the Acekard will already be blocked and unable to load up to do said bootloader update to bypass 1.4.
     
  4. sander55
    OP

    Newcomer sander55 Member

    Joined:
    Dec 6, 2008
    Messages:
    10
    Country:
    United States
    Some great input Thanks everyone
     
  5. scrtmstr

    Member scrtmstr GBAtemp Advanced Fan

    Joined:
    Aug 20, 2009
    Messages:
    839
    Location:
    the Netherregions!
    Country:
    Netherlands
    Since your daughter will be using it, i recommend acekard 2i, because she can just drag and drop every game she wants very easaly into a games folder or something and browse thru it with ease. Just make sure, that your dsi isn't on 1.4, otherwise you'll need to update it first before you can use it. Some webshops do that these days for a smal amount of money. You can also do it yourself, but then you need a dslite or dsi under 1.3 firmware.
     
  6. gk.7

    Member gk.7 GBAtemp Regular

    Joined:
    Nov 6, 2008
    Messages:
    181
    Country:
    Mexico
    ACEKARD 2i

    It's cheap. it will do just what you want, and it's very easy to use.
     
  7. sander55
    OP

    Newcomer sander55 Member

    Joined:
    Dec 6, 2008
    Messages:
    10
    Country:
    United States
    Thanks again for all the info. Didn't know about the firmware issue till you guys said something gonna check it out.
     

Share This Page