Hacking weird japanese message after updating Omega Ruby.

Silver-Tiger

Active Member
OP
Newcomer
Joined
Nov 20, 2014
Messages
43
Trophies
0
Age
123
XP
53
Country
Gambia, The
hi guys,

after booting into classic mode using this guide I got this strange message:

anybody knows what this means? And how I can play omega ruby again? I downloaded the update straight from the eshop. I also tried installing it via cia, both no luck. Deleting the update and reinstalling didn't help either.
 

Attachments

  • IMG_20150205_141934.jpg
    IMG_20150205_141934.jpg
    632.5 KB · Views: 718

plasma

GBAtemp's Artificial Lifeform
Member
Joined
May 15, 2009
Messages
1,622
Trophies
1
Age
25
Location
I have no fucking idea.
XP
2,105
Country
United Kingdom
hi guys,

after booting into classic mode using this guide I got this strange message:

anybody knows what this means? And how I can play omega ruby again? I downloaded the update straight from the eshop. I also tried installing it via cia, both no luck. Deleting the update and reinstalling didn't help either.

If i am correct, it is saying your save file is corrupt
 

DavidKang

Well-Known Member
Member
Joined
Jun 23, 2012
Messages
138
Trophies
0
Location
Seoul
XP
748
Country
hi guys,

after booting into classic mode using this guide I got this strange message:

anybody knows what this means? And how I can play omega ruby again? I downloaded the update straight from the eshop. I also tried installing it via cia, both no luck. Deleting the update and reinstalling didn't help either.


The save is corrupted. If you played your game above 6.x before on sysnand and you downgraded, even if you have the latest emunand it will be corrupt. It's because of the different save encryption since 6.x I believe? To fix this you should go back to above 6.x if you had made a back up or update with a game.
 

Silver-Tiger

Active Member
OP
Newcomer
Joined
Nov 20, 2014
Messages
43
Trophies
0
Age
123
XP
53
Country
Gambia, The
The save is corrupted. If you played your game above 6.x before on sysnand and you downgraded, even if you have the latest emunand it will be corrupt. It's because of the different save encryption since 6.x I believe? To fix this you should go back to above 6.x if you had made a back up or update with a game.

I have 2DS, too, and on this one, the save works just fine.
 

Silver-Tiger

Active Member
OP
Newcomer
Joined
Nov 20, 2014
Messages
43
Trophies
0
Age
123
XP
53
Country
Gambia, The
If you are on sysNAND 4.5 and EmuNAND higher than that, and load a game using the 6.x encryption, then Classic mode will load it using the 4.x keys, which results in save file deletion

So how is classic mode useful if you can't play games higher than 6.x encryption?
 

DavidKang

Well-Known Member
Member
Joined
Jun 23, 2012
Messages
138
Trophies
0
Location
Seoul
XP
748
Country
So how is classic mode useful if you can't play games higher than 6.x encryption?


You can still play, but you have to delete your save if you played on it above 6.x before. On the first time, yes, you can play. And Games that don't need 6.x or higher will not get corrupted.
 

kamesenin888

Well-Known Member
Member
Joined
Oct 20, 2007
Messages
1,432
Trophies
1
XP
2,046
Country
hi guys,

after booting into classic mode using this guide I got this strange message:

anybody knows what this means? And how I can play omega ruby again? I downloaded the update straight from the eshop. I also tried installing it via cia, both no luck. Deleting the update and reinstalling didn't help either.
Dude use savedatafiler to backup the save before deleting it then start a new game and inject the main file from the save you backuped and you will be fine if using a 3dz with cia this doesn't work
 

mvmiranda

Well-Known Member
Member
Joined
Oct 29, 2013
Messages
1,448
Trophies
0
Age
41
Location
Brazil, Sao Paulo
Website
www.gamemod.com.br
XP
1,497
Country
Brazil
hi guys,

after booting into classic mode using this guide I got this strange message:

anybody knows what this means? And how I can play omega ruby again? I downloaded the update straight from the eshop. I also tried installing it via cia, both no luck. Deleting the update and reinstalling didn't help either.

Ok!
Classic mode uses your sysNAND keys to load games.
This means if your sysNAND is bellow 7.X, your original cart has a save created in an 7.X firmware, your classic mode (even if it's 9.4 and it was "based" on a sysNAND 7.X) will not be able to load this save.

source: myself!
I did a hell of a job updating my 4.5 console to 7.2 using this Pokemon OR, creating a brand new emuNAND based on 7.2, extracting XORPADs and FAT16, decrypting my FAT16, finding all of the saves, encrypting it again, injecting new FAT16 to my emuNAND, injecting emuNAND to SD Card and reverting my sysNAND to 4.5. All of this to have a "brand new 7.x based emuNAND in 9.4 with all of my saves" thinking I could play my Pokemon on classic mode while having an "easy way" of entering emuNAND (using the DS profile exploit) but in the end I discovered that your emuNAND does not matter but your sysNAND.

So, unless you update your sysNAND to 7.X, you will not be able to load this cart in your classic mode.

Cheers!
 

MrJason005

√2
Member
Joined
Nov 26, 2014
Messages
2,521
Trophies
0
Location
Κάπου
XP
1,596
Country
Greece
Ok!
Classic mode uses your sysNAND keys to load games.
This means if your sysNAND is bellow 7.X, your original cart has a save created in an 7.X firmware, your classic mode (even if it's 9.4 and it was "based" on a sysNAND 7.X) will not be able to load this save.

source: myself!
I did a hell of a job updating my 4.5 console to 7.2 using this Pokemon OR, creating a brand new emuNAND based on 7.2, extracting XORPADs and FAT16, decrypting my FAT16, finding all of the saves, encrypting it again, injecting new FAT16 to my emuNAND, injecting emuNAND to SD Card and reverting my sysNAND to 4.5. All of this to have a "brand new 7.x based emuNAND in 9.4 with all of my saves" thinking I could play my Pokemon on classic mode while having an "easy way" of entering emuNAND (using the DS profile exploit) but in the end I discovered that your emuNAND does not matter but your sysNAND.

So, unless you update your sysNAND to 7.X, you will not be able to load this cart in your classic mode.

Cheers!
but, on gateway ultra, when i load classic mode, it has a black theme (i seperated my nands, sysnand has red theme, emunand has black theme)
so, classic mode uses emunand?
 

mvmiranda

Well-Known Member
Member
Joined
Oct 29, 2013
Messages
1,448
Trophies
0
Age
41
Location
Brazil, Sao Paulo
Website
www.gamemod.com.br
XP
1,497
Country
Brazil
but, on gateway ultra, when i load classic mode, it has a black theme (i seperated my nands, sysnand has red theme, emunand has black theme)
so, classic mode uses emunand?

It doesn't matter...
My sysNAND and emuNAND are separated as well.

I'm talking about keys to decrypt saves ;)
 

You may also like...

General chit-chat
Help Users
  • No one is chatting at the moment.
    Veho @ Veho: https://www.youtube.com/watch?v=1zsbXosf5FM