vWii sysem files are corrupted....

Discussion in 'Wii U - Hacking & Backup Loaders' started by panmusic, Aug 23, 2013.

  1. panmusic
    OP

    panmusic GBAtemp Advanced Fan

    Member
    833
    34
    Sep 11, 2009
    Greece
    I have a softmodded Wii U with HBC,cIOS etc in Wii mode.
    I had never a problem until the day I tried Wii Fit Plus.After that day,when I try to boot vWii,the message displayed says that the system files are corrupted.

    I searched the internet and tried every method to resolve the issue.

    - I deleted the Wii Fit Plus save file both from system memory and SD card.

    - I deleted some SD card saves that MIGHT be corrupted.

    - I tried to boot vWii without the SD card inserted.

    - There were some rumours that if you let the system on for a whole night in "The system files are corrupted" screen,Nintendo does an online check and the system downloads the missing/corrupted files again.

    Unfortunately,NOTHING works.

    So,no NAND backup restore option for vWii yet and no Format option either (at least for vWii only,I do not want to format my Wii U too) , so what can I do?

    Is there any viable solution please?
     


  2. rdurbin

    rdurbin GBAtemp Fan

    Member
    473
    41
    Sep 13, 2006
    United States
    US
    you can try this, may not work but may be worth a shot. when starting up wii mode hold + and - on wii remote and when black health screen pops up it should stick you in maintenance mode. Try to check the channels menu in system menu, see if there any corrupted ones, they may show as a "?". if they are you can try deleting them and than reboot and see if that helps.
     
  3. DinohScene

    DinohScene Capture the Dino

    Member
    GBAtemp Patron
    DinohScene is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    16,056
    12,573
    Oct 11, 2011
    Antarctica
    В небо
    Doesn't the vWii update itself after a system update like the DS mode does on the 3DS?

    Otherwise, I wouldn't know.
    I guess you're bummed out on it.
     
  4. panmusic
    OP

    panmusic GBAtemp Advanced Fan

    Member
    833
    34
    Sep 11, 2009
    Greece
    rdurbin

    I forgot to tell you that I am using the maintenance mode to access the Wii menu.I checked every save and every channel for both system memory and SD card and there seems that nothing is corrupted.
    The only "other" saves are the ones for HBC and Wiiflow.
     
  5. jammybudga777

    jammybudga777 GBAtemp Advanced Maniac

    Member
    1,673
    561
    Aug 23, 2013
    i would say that this is either to do with lack ov ios's installed. i could be completely wrong and also im wondering if its because it would normally want you to replace the DOL file for this type of game (motionplus)
     
  6. panmusic
    OP

    panmusic GBAtemp Advanced Fan

    Member
    833
    34
    Sep 11, 2009
    Greece
    I updated Wii U to 4.0 and now it is almost impossible to boot normally vWii without using the maintenance mode.

    Can anyone help me ?
     
  7. 9thSage

    9thSage GBAtemp Fan

    Member
    421
    122
    Aug 8, 2008
    United States
    What did you install exactly? I rather doubt Wii Fit Plus had anything to do with it by itself, chances are it was just co-incidence that you tried it just before you started having problems.
     
  8. jammybudga777

    jammybudga777 GBAtemp Advanced Maniac

    Member
    1,673
    561
    Aug 23, 2013

    i dont no exactly what the issue is. but thought ide let you guys no that with "supermonkey ball banna blitz" it did cause my original wii system files to get ruined. this was goin back about 2 and half years ago i could only ashume it was a compatability issue due to my ios's i had at the time (the game would load but when i quit it would say system files are buggered) im guessin you may have the same issues but really this shouldnt be occuring due to how updated d2x ios's are now
     
  9. panmusic
    OP

    panmusic GBAtemp Advanced Fan

    Member
    833
    34
    Sep 11, 2009
    Greece
    I have followed religiously all the necessary steps to softmod my Wii U.

    For the last 7 months I had not experienced any problem at all.

    The "system files are corrupted" problem started as soon as my girlfriend asked me to live with me and to start exercising with Wii Fit Plus and her Balance Board using my Wii U.

    I copied hers save file to an SD card and copied it to my vWii. And this was the begining to my problems.

    Of course,the save file was not recognizable as Wii Fit Plus uses the Miis that are stored to Wii's nand.

    I googled the problem and I have to say that this is a common bug that many people have experienced in the past using Wii Fit from their Wiis.

    Unfortunately,none has found a definite solution and I think that I may be the first one that has a semi-brick using vWii with this bug.

    I tried to delete Wii Fit Plus save from both vWii's nand and SD card.I tried to boot vWii without having SD card attached.

    NOTHING WORKS.:hateit:

    I assume that Wii Fit Plus uses some specific IOS that has been corrupted.But which IOS? And most importantly,how can I restore it (assuming my bold theory is correct)?
     
  10. 9thSage

    9thSage GBAtemp Fan

    Member
    421
    122
    Aug 8, 2008
    United States
    All I can tell you is that I use WiiFit Plus on my WiiU (both from the disc and USB Loader) and have no problems. Since you're talking about cIOS and what not, I presume you're trying to use a USB Loader? It shouldn't matter then what IOS it used to use, it's now using whatever cIOS you installed. You could try installing d2x with a different base I guess. What are you using?
     
  11. panmusic
    OP

    panmusic GBAtemp Advanced Fan

    Member
    833
    34
    Sep 11, 2009
    Greece
    I am using the latest d2x version and for bases I followed the instructions of this forum tutorial (sorry but I do not remember right now).

    If you google this bug,you can find a lot of people that have the same issue.

    Actually,I realized that this bug is known for years.

    But,as it seems,the community has not managed to find a solution yet.
     
  12. jammybudga777

    jammybudga777 GBAtemp Advanced Maniac

    Member
    1,673
    561
    Aug 23, 2013

    1 this should tell you to never do a save or game transfer. 2 check and see if you installed alt 53 or alt 52 i think they where the only optional 2 you can try to install on vwii
     
  13. panmusic
    OP

    panmusic GBAtemp Advanced Fan

    Member
    833
    34
    Sep 11, 2009
    Greece
    I installed alt 53 with IOS 249 (56),IOS 250 (57) and IOS 251 (58).

    I do not know if this is related.

    The Wii Fit plus bug is known for years and there are people who experienced this bug without modding or softmodding their Wiis.

    P.s I have work to do and I am going to be away for the next hours.
     
  14. jammybudga777

    jammybudga777 GBAtemp Advanced Maniac

    Member
    1,673
    561
    Aug 23, 2013


    ok. ill do some research but its not looking good for you to be honest dude
     
    panmusic likes this.
  15. w!!

    w!! GBAtemp Regular

    Member
    202
    5
    Apr 24, 2009
    United States
    I don't have a Wii U, but does the vwii have a "format wii system memory" option in the settings like the normal wii? Maybe do that and then re-mod it, or try to do a Wii system update. Though, I'm not sure either of these will work.
     
  16. jammybudga777

    jammybudga777 GBAtemp Advanced Maniac

    Member
    1,673
    561
    Aug 23, 2013

    you cant format the vwii system..... its stupid i no but you cant :( and the only other things i can think of is if you have access to (multi mod manager)
    try having a look at what you could re-install (do not uninstall anything) but i will look up online later for possible ways around but like i said before it doesnt look promising just yet.
     
    panmusic likes this.
  17. panmusic
    OP

    panmusic GBAtemp Advanced Fan

    Member
    833
    34
    Sep 11, 2009
    Greece
    @jamm

    Any help will be greatly appreciated!

    Thanks in advance!
     
  18. panmusic
    OP

    panmusic GBAtemp Advanced Fan

    Member
    833
    34
    Sep 11, 2009
    Greece
    Sorry for the double post but I made a VERY interesting discovery.

    The "System files are corrupted" screen appears the first time I boot vWii ONLY.

    (By using the quick vWii method by holding B button in Wii U's start up screen , or by selecting the Wii channel.)

    I manage to boot vWii by using the maintenance mode and after that I load a Channel (any one).When I exit the Channel, System Menu loads 100% perfectly all the time.

    The only exception is when I try to return to System Menu from HBC. Hmm...

    Anyway,this means that the problem is there only the first time the console boots vWii.

    I hope that this may be useful...
     
  19. panmusic
    OP

    panmusic GBAtemp Advanced Fan

    Member
    833
    34
    Sep 11, 2009
    Greece
    Almost 2 months later and I have the same problem. Wii system files are corrupted.:unsure:

    Can anybody help me please?


    This is my Syscheck.I thought this may be useful for people who know vWii stuff.
     

    Attached Files:

  20. JoostinOnline

    JoostinOnline Certified Crash Test Dummy

    Member
    10,970
    3,755
    Apr 2, 2011
    United States
    The Twilight Zone
    This is odd:
    Code:
    IOS1768489209[56] (rev 21010, Info: d2x-v10beta53-alt-vWii): Trucha Bug, NAND Access
    IOS1768489210[57] (rev 21010, Info: d2x-v10beta53-alt-vWii): Trucha Bug, NAND Access
    IOS1768489211[58] (rev 21010, Info: d2x-v10beta53-alt-vWii): Trucha Bug, NAND Access
    Someone else contacted me with the same results for their d2x cIOS's. I know it's not a problem with my code because it happened in older versions of SysCheck as well.