vWii has a completely random date and time.

Discussion in 'Wii U - Hacking & Backup Loaders' started by panmusic, May 21, 2014.

  1. panmusic
    OP

    panmusic GBAtemp Advanced Fan

    Member
    833
    34
    Sep 11, 2009
    Greece
    Well,here is my problem.
    When I enter at vWii from Wii U menu the menu message sais that "Wii System files are corrupted".I had created another thread some months back with details about the cause of the problem ( http://gbatemp.net/threads/vwii-sysem-files-are-corrupted.353457/) most likely the infamous Wii Fit Plus bug and even I provided a System check file for some nice people who tried very hard to help me ( greetings Maxternal and especially JoostinOnline!)

    Unfortunately,there is no solution till today and the only way to enter vWii is via the maintenance mode trick.

    But today I tried to play some Wii games and upon saving I noticed something very weird. The save's date and time are completely off. For example my latest save appears to be created at 10/08/2001.

    I know that vWii's date and time can easily be fixed by addressing Wii U menu settings. I am absolutely sure and I have double-checked that Wii U displays the correct date and time while vWii NOT.

    I suppose this is the cause of the semi-brick because this causes a lot of problems at vWii's message board.

    So,is it possible to correct vWii's date and time and -if my assumptions are correct - solve the semi-brick problem once and for all?
     


  2. julialy

    julialy Homebrewer

    Member
    1,665
    577
    Nov 26, 2012
    United States
    United States
    Replace the battery?
     
  3. panmusic
    OP

    panmusic GBAtemp Advanced Fan

    Member
    833
    34
    Sep 11, 2009
    Greece
    What battery? Can you explain?
     
  4. julialy

    julialy Homebrewer

    Member
    1,665
    577
    Nov 26, 2012
    United States
    United States
    Is the clock on the Wii U side resetting? or just vWii?
     
  5. panmusic
    OP

    panmusic GBAtemp Advanced Fan

    Member
    833
    34
    Sep 11, 2009
    Greece
    Just vWii.

    Wii U 's clock works perfectly...
     
  6. thefunkygibbon

    thefunkygibbon Advanced Member

    Newcomer
    57
    0
    Mar 31, 2008
  7. panmusic
    OP

    panmusic GBAtemp Advanced Fan

    Member
    833
    34
    Sep 11, 2009
    Greece
    I just tried it but Settings Editor Gui does not let us change date and time...
     
  8. panmusic
    OP

    panmusic GBAtemp Advanced Fan

    Member
    833
    34
    Sep 11, 2009
    Greece
    Bump as the problem is currently unsolved and I hope that more kind people will read my problem and will try to help...
     
  9. JoostinOnline

    JoostinOnline Certified Crash Test Dummy

    Member
    10,970
    3,755
    Apr 2, 2011
    United States
    The Twilight Zone
    Use InspectMii to check the counter bias. Next run SysCheck and see the date at the bottom of the report.
     
  10. panmusic
    OP

    panmusic GBAtemp Advanced Fan

    Member
    833
    34
    Sep 11, 2009
    Greece
    I just completed both.

    Inspect Mii Counter Bias = 403204202 (112001:10:02) (This is funny because if I remember correctly,November of 2001 is the date of my weird saves!)

    And here I upload my SysCheck.

    I hope I provided some help...
     

    Attached Files:

  11. Bug_Checker_

    Bug_Checker_ GBAtemp Advanced Fan

    Member
    950
    444
    Jun 10, 2006
    United States

    WoW This should be posted for all to see:
    Warning: Spoilers inside!

    How did you patch IOS512 and IOS513?

    Also,
    v2.2.1
    • Fixed the pesky bug that sometimes caused the slot number of a vWii cIOS to be way off. Thanks to asper for a good deal of testing.
    v2.2.0
     
  12. panmusic
    OP

    panmusic GBAtemp Advanced Fan

    Member
    833
    34
    Sep 11, 2009
    Greece
    OK I am using an old version of SysCheck.

    I am going to find the new one and upload again!
     
  13. JoostinOnline

    JoostinOnline Certified Crash Test Dummy

    Member
    10,970
    3,755
    Apr 2, 2011
    United States
    The Twilight Zone
    You don't, I'll have to look into that.

    Anyway, the OP's date is correct.
     
  14. panmusic
    OP

    panmusic GBAtemp Advanced Fan

    Member
    833
    34
    Sep 11, 2009
    Greece
    Hm...I noticed that too...But what about counter bias?Is it normal?

    Here is my newest Syscheck with v2.21!
     

    Attached Files:

  15. JoostinOnline

    JoostinOnline Certified Crash Test Dummy

    Member
    10,970
    3,755
    Apr 2, 2011
    United States
    The Twilight Zone
    Well you ran an old version of InspectMii too, but that's not important. Your Counter Bias is fine. Where are you getting this date for your saves?
     
  16. panmusic
    OP

    panmusic GBAtemp Advanced Fan

    Member
    833
    34
    Sep 11, 2009
    Greece
    Well,almost every game I use and make a save file that displays a date/time has this glitch.

    I am using Wiiflow and the last games I tested are Reginleiv and Zack and Wikey.But there are many more.Practically everything that creates a save with a date/time.

    As we are back to square one, it seems that the root of the problem is the known Wii Fit Plus bug.

    I have googled it countless times and as far as I know NOONE has found a solution yet. I hope that my problem may be the beginning of a viable solution from the community...

    I am willing to provide you whatever information/help you wish...
     
  17. JoostinOnline

    JoostinOnline Certified Crash Test Dummy

    Member
    10,970
    3,755
    Apr 2, 2011
    United States
    The Twilight Zone
    Well use a real disc.
     
  18. panmusic
    OP

    panmusic GBAtemp Advanced Fan

    Member
    833
    34
    Sep 11, 2009
    Greece
    I just used a real disc and I can confirm that after I saves the game,the date and time were displayed correctly. So,this may be a Wiiflow problem

    Upon researching further,I found that Wii Fit Plus uses IOS 53. So, I think that Wii Fit Plus is somewhat related to a corrupted IOS 53.

    If I reinstall IOS 53 for vWii perhaps the problem will be solved. What do you think? Am I completelly off or not?
     
  19. JoostinOnline

    JoostinOnline Certified Crash Test Dummy

    Member
    10,970
    3,755
    Apr 2, 2011
    United States
    The Twilight Zone
    Maybe. Pack the wad from the original NAND backup you hopefully made, then install it. DO NOT TRY TO INSTALL AN IOS FROM NUS.
     
  20. panmusic
    OP

    panmusic GBAtemp Advanced Fan

    Member
    833
    34
    Sep 11, 2009
    Greece
    Well, my semi brick problem occured almost a year ago,so I found no reason at all to make a NAND back up because the back up would contain corrupted files.

    So,I must seek another option...:sad:

    I think that the only solution at the moment is to find a clean IOS 53 for vWii. And I don't have the slightest idea if t is safe to reinstall a vWii IOS from another vWii.

    I am completely in the dark. If somehow I find a vWii's IOS 53 and try to install it,is it safe?