USB Loader GX stuck at 'Initialize USB device'

Discussion in 'Wii - Backup Loaders' started by RobinMeade, Apr 26, 2019.

  1. RobinMeade
    OP

    RobinMeade Member

    Newcomer
    1
    Apr 26, 2019
    Zimbabwe
    I've been reading on this issue for several days now, I finally gave up and had to sign up in hopes for more personalized answer.

    I've got Toshiba 1TB USB 3.0 HDD I've used this guide |link-> gbatemp.net/threads/how-to-softmod-a-wii-and-play-backup-wii-gamecube-and-wiiware-games.360687/ <-link| to softmod it. It worked with the included loader with said hard drive without any issues except for some games. That is when I realized it was an outdated guide. Found new one with ModMii, which updated everything, including USB Loader GX.

    Now the HDD gets stuck on initializing USB drive. I have other HDD and it initializes just fine on the very same Wii, without any sort of modifications! When I don't plug in the drive in question and it reaches the countdown timer and I plug in then, then it works fine.
    Found a thread where it says to change argument in meta.XML and replace ios 250 with 58, I did that and it went further (I think it flashes cios 250 or 249) and then it gets stuck again this time with new message "Reinitializing devices" I don't know what to do at this point!

    EDIT: can't post hyperlinks yet just add the usual ht__s
     
    Last edited by RobinMeade, Apr 26, 2019
  2. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    22
    Oct 27, 2002
    France
    Engine room, learning
    Toshiba drive have lot of issues.
    you can consider it as "not compatible".

    get another one, for example a Western Digital.
     
  3. RobinMeade
    OP

    RobinMeade Member

    Newcomer
    1
    Apr 26, 2019
    Zimbabwe
    Is that the issue? Even though it works with an older version of USB Loader GX and also when I unplug it and plug it back in?
     
  4. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    22
    Oct 27, 2002
    France
    Engine room, learning
    ah, I thought you said other drives worked, and that this one didn't even after using IOS58 (badly).

    Try using IOS58 correctly :
    unplug the drive
    go to the loader's settings > Loader's IOS : replace 249 with 58.
    exit the loader
    connect the drive and try again.

    It might work while you are inside the loader, but might not work at Wii game launch (which reloads to 249 to get the USB redirection support).


    Few users reported Toshiba is not working, and they bought another drive's brand instead, which worked.
    if old loader work, use an old one. the important is the game works, not really the loader's features.
    try another loader too if the non working games are fixed with updating the loader (but updating the loader shouldn't affect the game compatibility, updates are mostly visual or added patches for nintendont).
     
    Last edited by Cyan, Apr 26, 2019
  5. RobinMeade
    OP

    RobinMeade Member

    Newcomer
    1
    Apr 26, 2019
    Zimbabwe
    Thank you for your time and replies.
    I read about replacing ios 249 for 58 in loader, but I couldn't figure out what loader, I thought I access those features through HBC or something, didn't occur to me that they were talking about USB Loader GX, I have never accessed it without a hard drive before. I assumed if USB drive is not plugged in it doesn't go anywhere or returns to Wii Menu and all the menus are for loading games only, not loading hard drive that is already working (this is 1st one that didn't), I don't know why it never occurred to me to try!

    Regarding older version that worked I assume I won't be able to use WiiWare and GC through USB Loader GX? Kind of wanted all in one solution. What about Fat32 partitions? I forgot to mention it was formatted for WBFS when it was working.

    EDIT: Can't win I guess. I set the loader to IOS58 and it indeed loaded, but then it refuses to load games. Any other solutions?
     
    Last edited by RobinMeade, Apr 26, 2019
  6. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    22
    Oct 27, 2002
    France
    Engine room, learning
    I guess toshiba drives have the same issue than Flashdrives.
    they work only with IOS58 if not using WBFS.

    but f you want emuNAND support, you'll need FAT32 which breaks the compatibility with cIOS.
    at least, it works with gamecube (it uses IOS58 in the loader and in nintendont too)

    a solution would be to partition your drive.
    make a FAT32 partition first, and WBFS second.
    put wii games on WBFS, put gamecube and emuNAND on first.
    set the loader's IOS to 58 to init the drive and list all its content while inside the loader. set Wii game's IOS to 249 (or 250? the slot where you have base57 installed) for Wii games which will use WBFS partition.

    Gamecube will work, as it's located on first partition and will continue to use IOS58.
    Wii games will work with your toshiba drive as they are on a WBFS partition.
    only EmuNAND will not work, as it'll require cIOS with a FAT32 partition, sorry. I guess it's Toshiba's fault. same advice than flashcart users : don't use that device.
    2/3 working setup, it's better than 1/3 ;)

    I'm not 100% sure it'll work fine, as it'll have to still see and skip the first FAT32 partition, but to me it should work with this setup :)
    let me know !
     
    Last edited by Cyan, Apr 27, 2019
  7. RobinMeade
    OP

    RobinMeade Member

    Newcomer
    1
    Apr 26, 2019
    Zimbabwe
    Thanks for all the replies, I just gave up messing with it. It's not for me but for family member, I told them to just get different brand. Can't waste any more time on this.
     
Loading...