USB Loader GX (Pluggin mod) need help showing ROMS

Discussion in 'Wii - Backup Loaders' started by earithramir, Aug 23, 2018.

  1. earithramir
    OP

    earithramir Member

    Newcomer
    1
    Aug 16, 2018
    Netherlands
    Hi,

    I've succesfully set-up and configured all the wii and gamecube games.
    The roms worked fine in wiiFlow but do not show up as games in USB Loader GX.
    I've copied them to both USB disk (Harddrive FAT32) and SD.
    When i click the Plugin Mode button a list of all emulators is shown. But when i click snesx9x no games are shown.
    I've edited the snesx9x ini to match the roms path: usb1:/snesx9x/roms
    Changes made in the ini are readable by USB Loader GX, i renamed it to Nintendo SNES and now it shows Nintendo SNES instead of snesx9x
    The games are stored both on sd card and USB drive. Both media on the same path: /snesx9x/roms
    Also tried copying the games to [name of game]/game.sfc
    The extension is listed in the ini.
    I tried updating the settings from sd:/config/plugins to usb1:/config/plugins (the config folder is present both on SD and HDD.
    The plugins folder is a duplicate from my working wiiFlow installation.
    Please advice, would really love to have the emulator roms shown in USB Loader GX as i prefer that over WiiFlow.

    Thanks in advance!


    edit:
    SOLVED!
    finally got it working by doing the following:
    1) use modmii to update/ fix the softmod. (reinstalling cios and updating them in the process)
    2) removed wiiFlow and downloaded the new master pack (downloaded from official site: https://sites.google.com/site/wiiflowiki4/#TOC-Downloads)
    (offcourse i've backupped my SD and used the covers and favorites from this backup) (but deleted the original wiiflow folder entirly from SD)
    3) configured and setup WiiFlow and tested all the games ( i only have a couple of roms, the roms i used to own, thus this wasn't much of an effort.)
    4) reloaded USB Loader GX with the mod and changed the paths to the correct paths, as mentioned above.
    As for the images:
    i needed to edit the [loader].ini files
    and move the coverfolder=root:/config/images 1 line up (directly apending the magic=[number] line) like so:
    [PLUGIN]
    displayname= - Nintendo Entertainment System (NES)
    magic=46434555coverfolder=root:/config/images/2D
    dolfile=fceugx-mod12.dol
    romdir=fceugx/roms
    filetypes=.nes|.fds|.nsf|.unf|.nez|.unif|.zip|.7z
    consolecoverid=nintendo
    covercolor=ff0000
    bannersound=nes.ogg
    arguments={device}:/{path}|{name}|{loader}

    The filenames:
    ROM: usb1:/fceugx/roms/some file name.nes
    IMAGE: sb1:/config/images/2D/some file name.nes.png​
     
    Last edited by earithramir, Oct 16, 2018
  2. GreyWolf

    GreyWolf GBAtemp Guru

    Member
    8
    Mar 2, 2015
    United States
    I assume you're using the modified USB Loader GX that supports Wiiflow plugins? Set them up exactly the way they should be for Wiiflow. Note that it's a mod and only supported by the author of the modded version. (@Badablek)

    USB Loader GX does not support Wii disc titles on SD.
     
  3. earithramir
    OP

    earithramir Member

    Newcomer
    1
    Aug 16, 2018
    Netherlands
    Hi thanks for you response.
    I am indeed using the modded version with support for plugins.
    And loading wii-games (wbfs) and gamecube-games (iso) from USB hard drive works just fine.
    The plugin shows all the emulators but the game list stays empty.
    Hoping to fix this.
    Could offcourse create a virtual console wad for every game but that feels too bloaded
     
  4. fledge68

    fledge68 GBAtemp Maniac

    Member
    8
    Jan 30, 2012
    United States
    its been a while since i messed with my plugins mod of usbloader gx. but lets try some things

    first i believe romdir= should be the rom dir path without the sd:/ or usb1:/
    second i believe you need to go into usbloader gx settings and under loader settings - scroll all the way down to find default plugins partition. and set it to usb or sd.
     
  5. earithramir
    OP

    earithramir Member

    Newcomer
    1
    Aug 16, 2018
    Netherlands
    I'll try,
    thanks in advance..
     
  6. earithramir
    OP

    earithramir Member

    Newcomer
    1
    Aug 16, 2018
    Netherlands
    Are there any requirements on the filenames of the roms?
    My roms are named e.g. 1991 - SNES - Legend of Zelda, The - A Link to the Past.smc
     
  7. earithramir
    OP

    earithramir Member

    Newcomer
    1
    Aug 16, 2018
    Netherlands
    Thank u for taking the time to help me out! really appreciated!
    Still no luck..
    Here's what i've done:

    games are both on SB and USB (and on both media same paths)
    The config directory is also cloned to USB drive.

    in settings Tried "Plugins Default Partition" on both usb1 and sd..
    under custom paths, tried "Plugins Files Path" on usb1:/config/plugins and sd:/config/plugins (again the config folders on usb and sd are identical)

    in the emulator ini file (/config/plugins/[emulator].ini the extensions are whitelisted, separated by | and e.g. romspath=snesx9x/roms
    The SD card and USB harddrive are both formatted in Fat32 with 32kb clusters.

    tried duplicating one of the roms to 1991 - SNES - Legend of Zelda, The - A Link to the Past.smc -> 1991_-_SNES_-_Legend_of_Zelda_The_-_A_Link_to_the_Past.smc
    The game runs when running it through retroarch directly either on usb or sd..

    — Posts automatically merged - Please don't double post! —

    Example of a emulator ini

    [PLUGIN]
    magic=534e4553
    coverColor=01a300
    coverFolder=snes9xgx
    fileTypes=.smc|.fig|.sfc|.swc|.zip|.7z
    romDir=snes9xgx/roms
    dolFile=snes9xgx-mod11.dol
    bannerSound=snes.ogg
    displayname=-Nintendo SNES
    consoleCoverID=nintendo
    arguments={device}:/{path}/|{name}|{loader}

     
  8. fledge68

    fledge68 GBAtemp Maniac

    Member
    8
    Jan 30, 2012
    United States
    so are your snes9xgx roms in sd:/snes9xgx/roms folder?
    are you using subfolders in sd:/snes9xgx/roms? like the ones you mentioned in the first post you said - Also tried copying the games to [name of game]/game.sfc
    i ask because you shouldn't have any subfolder for each rom. the rom needs to be directly in romsdir like this - sd:/snes9xgx/roms/Legend of Zelda, The - A Link to the Past.smc

    also make sure you don't have any hidden extension after the .smc
     
  9. earithramir
    OP

    earithramir Member

    Newcomer
    1
    Aug 16, 2018
    Netherlands
    Hi,

    At the moment i'm not using subfolders.
    The structure is like:
    sd:/snes9xgx/rom/*.smc
    There is is no extension other then smc or sfc
     
  10. fledge68

    fledge68 GBAtemp Maniac

    Member
    8
    Jan 30, 2012
    United States
    Then i have no idea why it doesnt work for you.
    If it works for wiiflow then all you had to do was set the plugins path in usbloader gx to point to the wiiflow plugins folder.
     
  11. earithramir
    OP

    earithramir Member

    Newcomer
    1
    Aug 16, 2018
    Netherlands
    Well, thanks anyway! Appriciat the effort ! I'll just create myself some forward channels. Maybe I'll find a solution in time.. Have a great day!
     
  12. FancyNintendoGamer567

    FancyNintendoGamer567 GBAtemp Advanced Fan

    Member
    4
    Feb 13, 2017
    United States
    @earithramir You made your own fowarder channels? Cool, I would like to check those out sometime.
     
  13. earithramir
    OP

    earithramir Member

    Newcomer
    1
    Aug 16, 2018
    Netherlands
    Nothing fancy, just Mario Party / Kart and Legend of Zelda roms, forwarders that use emulator and the rom to boot.
    First i need to mod the wii some more, currently configuring a emuNand...
    These channels cost memory...
    When i'm finished with them i'll share them.
    The N64 forwarders still give u an extra step.. after "clicking" them it opens the amulator with the rom loaded but u still need to click play rom or something like that...
     
  14. GartimusPrime

    GartimusPrime GBAtemp Regular

    Member
    1
    Jul 3, 2011
    United States
    Ellsworth, Maine
    I also ran into the same issue. Plugins work in wiiflow lite. In USB Loader GX Mod i have changed the path to the wiiflow/plugin folder, which show up in the list. I pick FCEUGX and nothing shows up for roms but they do in wiiflow lite. Would be an awesome feature but I cant seem to figure out what I am doing wrong.
     
  15. fledge68

    fledge68 GBAtemp Maniac

    Member
    8
    Jan 30, 2012
    United States
    are your roms on SD or USB?
     
  16. GartimusPrime

    GartimusPrime GBAtemp Regular

    Member
    1
    Jul 3, 2011
    United States
    Ellsworth, Maine
    Usb, does that not work?
     
  17. fledge68

    fledge68 GBAtemp Maniac

    Member
    8
    Jan 30, 2012
    United States
    are your wiiflow/plugins folder on SD or USB?

    check this post out - https://gbatemp.net/threads/usb-loader-gx.149922/page-1131#post-6653220

    you have set the path to your wiiflow/plugins folder but you may also need to set the plugins default partition. this partition setting tells the plugins if your games are on SD or USB.
     
  18. earithramir
    OP

    earithramir Member

    Newcomer
    1
    Aug 16, 2018
    Netherlands
    Hi i finally got it working by doing the following:
    1) use modmii to update/ fix the softmod. (reinstalling cios and updating them in the process)
    2) removed wiiFlow and downloaded the new master pack (downloaded from official site: https://sites.google.com/site/wiiflowiki4/#TOC-Downloads)
    (offcourse i've backupped my SD and used the covers and favorites from this backup) (but deleted the original wiiflow folder entirly from SD)
    3) configured and setup WiiFlow and tested all the games ( i only have a couple of roms, the roms i used to own, thus this wasn't much of an effort.)
    4) reloaded USB Loader GX with the mod and changed the paths to the correct paths, as mentioned above.

    Now i have a fully functional USB Loader GX with the ROMS and WiiFlow as a backup.
    If u need a more detailed report on how i reset/updated the softmod let me know.

    As for the images:
    i needed to edit the [loader].ini files
    and move the coverfolder=root:/config/images 1 line up (directly apending the magic=[number] line) like so:
    [PLUGIN]
    displayname= - Nintendo Entertainment System (NES)
    magic=46434555coverfolder=root:/config/images/2D
    dolfile=fceugx-mod12.dol
    romdir=fceugx/roms
    filetypes=.nes|.fds|.nsf|.unf|.nez|.unif|.zip|.7z
    consolecoverid=nintendo
    covercolor=ff0000
    bannersound=nes.ogg
    arguments={device}:/{path}|{name}|{loader}


    The filenames:
    ROM: usb1:/fceugx/roms/some file name.nes
    IMAGE: sb1:/config/images/2D/some file name.nes.png


    The only things i need to get working is:
    1) getting back from ROM (snes/nes/gameboy) to usb loader, this makes my Wii freeze, but when starting the ROM through wiiFlow and stopping the game by going back to loader (wiiFlow), it works fine.


    edit:
    By the way:
    My USB loader is installed on SD.
    Its cache, images, isos and emulation roms are on my usb1:/
    This is working perfect, many many THANKS!
     
    Last edited by earithramir, Oct 16, 2018
  19. spinoman

    spinoman Member

    Newcomer
    1
    May 5, 2014
    Italy
    hi, i also have some problems:
    i can play games and return to loader, but no luck with the covers.
    according to original istructions from fledge68 i made a folder of 2d covers and put it in /config/images/2D folder in sd, and another one of 3d covers in /config/images/.
    the covers are from mastershoes collection post and was renamed.

    so this is my setup:

    sd/config/plugins/vbagx.ini - content:
    [PLUGIN]
    displayname=Nintendo Gameboy Advance
    magic=56424158
    coverfolder=gbacovers
    dolfile=vbagx-mod13.dol
    romdir=roms
    filetypes=.gba|.zip|.7z
    arguments={device}:/{path}|{name}|{loader}

    sd/roms/Advance Wars.zip
    sd/config/images/2D/gbacovers/Advance Wars.zip.png
    sd/config/images/gbacovers/Advance Wars.zip.png

    what am i doing wrong? any help appreciated, thank you guys.
     
  20. fledge68

    fledge68 GBAtemp Maniac

    Member
    8
    Jan 30, 2012
    United States
    i had an older version of usbloadergx which made a config folder on the root of my sd card.
    i believe now the config or images folder is located in the apps/usbloadergx folder.
    you need to use the same images folder that all your other covers are in. so if there's one in apps/usbloadergx with all your wii covers thats where you need to be putting your gbacovers.
     
    earithramir likes this.
Loading...