Upgraded system menu to 4.3, StartPatch hacks stopped working

Discussion in 'Wii - Hacking' started by Knocks, Feb 10, 2015.

  1. Knocks
    OP

    Knocks GBAtemp Advanced Fan

    Member
    559
    0
    Jun 12, 2006
    I upgraded my system menu from 4.1 to 4.3, and all the StartPatch hacks disappeared (disable health warning, move disc channel, etc).

    I tried running a new version of StartPatch 4.3.1 that supports the new menu, but it refuses to run and gives the message ES_Identify: Error -1029

    I have reinstalled cIOS249 d2x v10beta 52, but that didn't help. Any ideas?
     


  2. crwys

    crwys GBAtemp Maniac

    Member
    1,146
    307
    Jun 26, 2008
    United States

    Are you trying to run StartPatch on the vWii or the Wii? ( vWii is the Wii U)
    I don't think start patch runs on vWii.

    Also this program is pretty obsolete and whatever you are trying to use it for, there are much better alternatives.
     
  3. JVC2

    JVC2 Advanced Member

    Newcomer
    81
    45
    Nov 19, 2014
    Ecuador
    1.Wrong place to ask pal.
    2.get priiloader,does the same but better in my opinion.
     
    Xenon Hacks and Kelton2 like this.
  4. Knocks
    OP

    Knocks GBAtemp Advanced Fan

    Member
    559
    0
    Jun 12, 2006
    Sorry for posting in the wrong section. Please move this thread to the Wii Hacking forum.

    Why is StartPatch obsolete? It was updated when the last Wii system menu came out, which is 4.3.1.

    I don't know of any other app that will accomplish the same thing without depending on an external drive (SD or USB). I want the hacks to continue to work even without an SD card in the slot, and StartPatch is the only app that modifies the NAND to enable these hacks.
     
  5. Knocks
    OP

    Knocks GBAtemp Advanced Fan

    Member
    559
    0
    Jun 12, 2006
    I'm pretty sure Priiloader relies on the hacks.ini file, which resides on the SD.
     
  6. JVC2

    JVC2 Advanced Member

    Newcomer
    81
    45
    Nov 19, 2014
    Ecuador
    I believe only to enable the hacks,you only need the SD card later to remodify them.
    This is why priiloader "loads" before the wii menu itself,to enable such hacks in a permanent way.
    also i cannct confirm since i dont have my wii anymore but im sure this works without the SD card later on.

    EDIT:
    Also,please redirect this question since this part is only for Wii U Hacking,im sure you have checked it out before posting.
     
  7. crwys

    crwys GBAtemp Maniac

    Member
    1,146
    307
    Jun 26, 2008
    United States

    You need an sd card / usb drive to use the homebrew channel anyways. Startpatch was always a bad idea because it permanently modifies the nand. Priiloader is more stable/updated with more hacks. It's also a good brick protection next to bootmii
     
    JVC2 likes this.
  8. JVC2

    JVC2 Advanced Member

    Newcomer
    81
    45
    Nov 19, 2014
    Ecuador
    crwys does priiloader still need the SD card to perform the hacks?
    Still nonetheless,it is the best one to use IMHO,and why not have an SD card always inside the Wii considering its inexpensive?
     
  9. crwys

    crwys GBAtemp Maniac

    Member
    1,146
    307
    Jun 26, 2008
    United States
    I currently don't have a Wii to test this but if I remember correctly the hacks.ini is copied to the nand after the first run. So no it shouldn't need the sd card after the first run. The OP can easily check
     
  10. Knocks
    OP

    Knocks GBAtemp Advanced Fan

    Member
    559
    0
    Jun 12, 2006
    I didn't ask if it was a good idea to use StartPatch or whether you liked it. I asked for help with a specific error message the app was giving me. If you are not a StartPatch user or have a problem with modifying your nand, then you don't need to comment and derail the thread. I've used StartPatch for over 5 years and it serves my needs perfectly, and tons of other people out there are happily using it.

    JVC2 there are many reasons why someone may not have an SD card in the slot at any given time.
     
  11. JVC2

    JVC2 Advanced Member

    Newcomer
    81
    45
    Nov 19, 2014
    Ecuador
    Knocks crwys was just saying what works better,usually if something else doesnt work,people suggest alternatives.
    Personally i wouldnt say there is an excuse to not have an SD card unless it is literally broken without repair or you dont want to use one.
     
  12. crwys

    crwys GBAtemp Maniac

    Member
    1,146
    307
    Jun 26, 2008
    United States
    Well hopefully one of those people will come along. Because so far every person in this thread has suggested you use priiloader
    Btw if you own a Wii, you can own a 5$ sd card

    I guess ill try and help you. You can:
    Downgrade back to 4.1 and try again
    Make sure you have all stubs removed
    Install an older cios in a different slot, try 38 (not the d2x versions)

    The problem with this however is you don't get the newest cios with it's improvements. Which is why I told you to use priiloader
     
    JVC2 likes this.
  13. Knocks
    OP

    Knocks GBAtemp Advanced Fan

    Member
    559
    0
    Jun 12, 2006
    When something doesn't work, people troubleshoot it with the help of fellow users, which is the very purpose of this thread. Otherwise we would keep switching programs without ever trying to fix anything. You guys remind me of Apple evangelists who suggest switching to a Mac every time someone posts about an error message in Windows. I'm using what I'm using. It's a great program, and it's not obsolete by any means. If you don't like that, just stay away from this thread.


    Thanks for another helpful suggestion. If you actually took the time to read before replying, then you would learn that this has nothing to do with owning an SD card, but having an SD card in the slot. In any scenario, since you don't seem to have any knowledge of the error message in the original post, you're not really helping, but thanks anyway.
     
  14. JVC2

    JVC2 Advanced Member

    Newcomer
    81
    45
    Nov 19, 2014
    Ecuador
    For the sake of being helpful im guessing you have visited this thread:
    https://gbatemp.net/threads/startpatch-for-4-3u-for-ntsc-u-usa-wii-only.242625/

    Id suggest asking for help there than in a wrong thread where people know that priiloader is the best way to load.

    Good luck with that since it hasnt been updated in 5 years.

    Ask for the closing/moving of this thread or I will ask to do so.
     
    crwys likes this.
  15. crwys

    crwys GBAtemp Maniac

    Member
    1,146
    307
    Jun 26, 2008
    United States

    I don't think you are comprehending what everyone has been telling you.

    The program requires a cios.
    The program is so old that it doesn't support the newest cios you have installed.
    So you have to use a older cios.

    I read your post and "having an sd card in the slot" is very vague. So either you don't own an sd card or your sd card slot is broken. And if it is that is kinda important to share. If it's not then go buy a sd card.
     
    JVC2 likes this.
  16. SickPuppy

    SickPuppy New Member

    Member
    1,789
    451
    Jul 29, 2009
    United States
  17. JVC2

    JVC2 Advanced Member

    Newcomer
    81
    45
    Nov 19, 2014
    Ecuador
  18. crwys

    crwys GBAtemp Maniac

    Member
    1,146
    307
    Jun 26, 2008
    United States
  19. Knocks
    OP

    Knocks GBAtemp Advanced Fan

    Member
    559
    0
    Jun 12, 2006
    Wow, how about you people just go the hell away? I have already asked for this thread to be moved to the Wii Hacking section. Why are you still commenting here?
     
  20. JVC2

    JVC2 Advanced Member

    Newcomer
    81
    45
    Nov 19, 2014
    Ecuador
    Because you are still blatent to the fact that crwys has presented to you.
    Good luck if you resolve it without that advice.