[Tutorial] How to get Ironhax back

Discussion in '3DS - Homebrew Development and Emulators' started by MsMidnight, Dec 28, 2015.

  1. TamDanny

    TamDanny GBATemp 3DS Fanatic

    Member
    4
    Aug 20, 2015
    Mexico
    Just wondering...if I already have Ironhax with Ironfall 1.1, is it recommended to get the 1.0 version, or is there really any difference to it?
     
  2. DjoeN

    DjoeN Captain Haddock!

    Member
    10
    Oct 21, 2005
    Belgium
    Somewhere in this potatoland!
    Some things to add to make it more noob friendly:

    [EDIT]
    Moved to OP!
     
    Last edited by DjoeN, Dec 29, 2015
    Minnow, Morrissex and [Truth] like this.
  3. hobbledehoy899

    hobbledehoy899 GBAtemp Addict

    Member
    9
    Nov 13, 2015
    Antarctica
    The new Ironhax icon doesn't appear.
     
    Last edited by hobbledehoy899, Dec 28, 2015
  4. cynosura

    cynosura GBAtemp Regular

    Member
    2
    Jun 7, 2015
    France
    Bed
    Any way to make it work on 9.9 ?
     
  5. DjoeN

    DjoeN Captain Haddock!

    Member
    10
    Oct 21, 2005
    Belgium
    Somewhere in this potatoland!
    There's no new ironhax icon, the icon is just the same as the old one, if you installed the new starter pack from smea's page, it's good to go

    And i don't think you can redownload old IronHax on a 9.2 system :/ cause there's no way to spoof eShop and i don't think the eShop old version downloader does spoofing. Pitty, cause i just have a system with 9.2 but no ironfall (yes i know i can use HBL launcher cia in emunand, still it would be cool to launch hbl from start instead from emunand)
     
    Last edited by DjoeN, Dec 28, 2015
  6. regnad

    regnad Button Masher

    Member
    9
    May 19, 2008
    Install Menuhax, boot up the 3DS pressing L, and it should work then.
     
    Carnelian likes this.
  7. ZedMania

    ZedMania Advanced Member

    Newcomer
    1
    Oct 27, 2015
    Stupid question incoming: Do we still need to download the otherapp payloads/ropbin to get homebrew?
     
  8. SomeGamer

    SomeGamer GBAtemp Guru

    Member
    13
    Dec 19, 2014
    Antarctica
    No.
     
    ZedMania likes this.
  9. Clydefrosch

    Clydefrosch GBAtemp Guru

    Member
    12
    Jan 2, 2009
    Germany
    sigh... so to use this and get the very comfortable ironhax, i have to update to 10.3.
    but to keep the small chance to downgrade to 9.2 with snshax, i'll have to stay on 10.1.

    oh well...
     
  10. nanika

    nanika 文鎮じゃダメ!まぁ、こんな文字小さしすぎてどうせ読めないっしょ。

    Member
    2
    Apr 22, 2008
    United States
    You say:
    but has Ironfall ever been available without an NNID in America/Europe?

    Does this allow downloading of Ironfall without an NNID despite Nintendo requiring one?
     
  11. MsMidnight
    OP

    MsMidnight part time fe modder

    Member
    7
    Oct 12, 2015
    kys
    If your system ver isn't 28 you can't do it as you'd need to update because the Nintendo network checks for the Ver, and if yours isn't linked to one it doesn't go to you
     
  12. Clydefrosch

    Clydefrosch GBAtemp Guru

    Member
    12
    Jan 2, 2009
    Germany
    i dont believe it does. that old downloader still requires recent firmware (doesnt work on 10.1) and logs into nnid
     
    nanika likes this.
  13. MsMidnight
    OP

    MsMidnight part time fe modder

    Member
    7
    Oct 12, 2015
    kys
    My friend doesn't know how to extract files:creep:
     
    Last edited by MsMidnight, Dec 28, 2015
  14. CHICAGO-lollie

    CHICAGO-lollie Member

    Newcomer
    1
    Aug 18, 2015
    Can someone confirm if this is still working in EUR regions? I was able to use Browserhax earlier this morning without any issues, but now it only flashes through yellow and grey screens before eventually getting kicked back to the home menu with a generic error. Along with that, it seems that I can only download the latest version of IronFall, despite using the old-version-download eshop link through HBL. I've tried deleting and redownloading IronFall, but the Ironhax installer returns this error.

    http://i.imgur.com/LUackxT.png

    It's not a major issue for me, I'm on 10.3.0-28E with Ninjhax and Menuhax. I was just hoping to install another Homebrew Launcher entry point. (you can never have too many!)


    edit: I made the mistake of only picking out what I thought I needed from the new Starter kit, a clean install of the full Starter kit solved my IronFall eshop issues. See Ammako's post (#51) on Page 3.
    Also made sure to delete the webkithax_tmp.bin, which had been left on the SD card at some point. This was the cause of my Browserhax issues.
     
    Last edited by CHICAGO-lollie, Dec 28, 2015
  15. DjoeN

    DjoeN Captain Haddock!

    Member
    10
    Oct 21, 2005
    Belgium
    Somewhere in this potatoland!
    Did you download ironfall through the eshop old version downloader in the HBL?
    or did you just install ironfall from regulat eshop? (seems that way)
     
  16. CHICAGO-lollie

    CHICAGO-lollie Member

    Newcomer
    1
    Aug 18, 2015
    I used the eshop old version downloader in the HBL, both times.
     
  17. Clydefrosch

    Clydefrosch GBAtemp Guru

    Member
    12
    Jan 2, 2009
    Germany
    trying to download ironfall for my brother but it keeps breaking up :/
     
  18. MyShiLingStar

    MyShiLingStar Newbie

    Newcomer
    1
    Dec 28, 2015
    Hong Kong
    Unfortunately, the japan version of ironfall cost ¥1500 JPY.
    I guess its no luck for jp console.

    I think you might want to put it up there as well.
     
  19. Nyannurs

    Nyannurs GBAtemp Fan

    Member
    5
    Aug 30, 2014
    Germany
    praise based @ihaveamac who walked me through this mess <3<3<3<3
     
  20. Mnecraft368

    Mnecraft368 I hate my name.

    Member
    8
    Aug 8, 2015
    United Kingdom
    Did all this buuut, When i install ironhax it says..
     
Quick Reply
Draft saved Draft deleted
Loading...