[Tools] AmiiBomb

Discussion in 'Switch - Hacking & Homebrew' started by Ac_K, Apr 17, 2017.

  1. Skedar

    Skedar Newbie

    Newcomer
    4
    0
    Dec 16, 2012
    United States
    Glast Heim
    Hey guys, need to be NFC Cards ?

    Ntags 215 adhesive stickers dont work?

    100pcs-NFC-Ntag215-ISO14443A-NFC-Stickers-Tag-All-NFC-Phone-Available-NFC-Adhesive-Labels

    This product works too right?

    Because i think this is a better (and cheap) way to me...
     
  2. lacrima08

    lacrima08 Newbie

    Newcomer
    9
    0
    May 28, 2009
    France
    Hi,

    I tested with new NTAG, I could flash to these tags with Amiibomb, and dump successfully.

    But if I want to read it on N3DS, I've got a message saying that's is not an amiibo.

    Any ideas ?

    Thanks
     
    Last edited by lacrima08, Sep 22, 2017
  3. nitrostemp

    nitrostemp GBAtemp Maniac

    Member
    1,413
    101
    Mar 15, 2009
    These are what i use:

    https://www.aliexpress.com/store/pr...32315909847.html?spm=2114.12010612.0.0.nV3ZJH

    make sure you have "write lock bytes" on and that you dont put the tag on there until it says to.
     
  4. Digital_0xFF

    Digital_0xFF Advanced Member

    Newcomer
    76
    34
    Oct 7, 2017
    Austria
    For anyone who possesses a hacked 3ds see Thenaya do avoid the need of buying new hardware for amiibo stuff ;)
     
  5. DjoeN

    DjoeN Captain Haddock!

    Member
    5,218
    1,514
    Oct 21, 2005
    Belgium
    Somewhere in this potatoland!
    Wel my new NFC sticker arrived (instead of cards) and those work perfect on Amiibomb with Adruino Uno :)

    Now i only need to find someting nice to attach the stickers to :)
     
  6. Thedanklol

    Thedanklol Newbie

    Newcomer
    GBAtemp Patron
    Thedanklol is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    9
    1
    Aug 26, 2017
    United States
    It won't read my NFC215 paper
     
  7. redion1992

    redion1992 Member

    Newcomer
    20
    0
    Dec 18, 2011
    Seems to be somewhat broken on Win10 Fall Creator's Update. No list of .bins shows up. Yes, the folders are correctly set. Any help @Ac_K ?

    [​IMG]

    Still works if I run it as an administrator, but that's kind of a workaround.
     
    Last edited by redion1992, Dec 24, 2017
  8. Greg956

    Greg956 Advanced Member

    Newcomer
    70
    17
    Dec 18, 2017
    Russia
    I believe that it is possible to use phone on Android to write NFC tags, right? The other process is the same, find .bin and use them with program on Android.
     
  9. Gwynplaine

    Gwynplaine Newbie

    Newcomer
    1
    0
    Feb 3, 2018
    United States
    TL;DR: Having trouble writing with the Arduino Uno and RFID255 Board? Switch RST/9 to RST/5. Double check it is all working before writing via the Addicore RFID library and example using Arduino IDE. If you are getting time out errors or such on 0.3, try 0.2. Don't touch the tag to the writer before Amiibomb has said to remove it and place it back on (for me this happens right after hitting 'Create Amiibo' or whatever it says) as this can burn a tag and make it useless.

    Okay forgive me if this was posted somewhere else in here or elsewhere - I couldn't find it.

    I finally got all my stuff in from AliExpress (Paid 1.61 for the Uno, Wires and NFC Board). After purchasing a Soldering Iron and Solder (Own 3, couldn't find 1) I sat down to get to it!

    Well Amiibomb just sat there going 'Waiting for NTAG' and saying 'Not Connected'.

    Okay so I try doing it via Arduino IDE - Error in Communication.

    Check all my solder work twice, swapped out different jumper wires, still nothing.

    Given up at this point honestly, did a bunch of random troubleshoot type things and just didn't get anywhere. Went scrolling through this whole thread and countless others to no avail. I finally laid down for bed, opened up the AliExpress app and looked at the reviews for each piece. Only a few bad reviews and I figured I was one of the unlucky few to get a bad board.

    Someone said they had trouble with the RFID board something about I2C (don't ask me). I set out thinking it may be a program to tell me which pins are working or such (in a sense the Arduino sketch was just that). It didn't work and I don't know exactly how but I ended finding someone else having the same problem with the I2C sketch. A person responded saying to download a certain library, switch PIN 9/RST to PIN 5 and a few other things relating to the I2C sketch. Well I switched the pin, loaded the sketch, swiped a tag and ... it read!

    I go into Amiibomb, flash the Uno and select a random dump file. IT WROTE! Tested it on my BOTW Zelda/Switch - it worked!

    Then I learned a few more quirks with Amiibomb - I was using 0.2 and 0.3 randomly trying to figure if it was a problem with one or the other. In the end I ended up doing everything with 0.2 (I believe 0.3 kept giving me 'Timed out' messages, which ruins the tag). On to Quirk 1 - When hitting 'Create Tag', DO NOT hold the tag to the writer. Mine never showed that it was connected or anything until I hit 'Create Tag' at which point an error dialogue would pop up and tell me to take the tag off the writer and put it on again. ONLY AFTER THIS should you place the tag on the writer. If you do it before, it won't read the tag, it won't detect the tag, nothing. I lost about 3 tags doing it this way. Second quirk cost me a few more tags in 'Time out' messages, which didn't seem to occur in 0.2. Third Quirk and this may be common sense or stupidity but you don't need to 'Rub' the tag on the RFID board - this could ruin the tag, not entirely sure. I just noticed the tags didn't really work before then.

    I would recommend anyone download the Arduino IDE and the Addicore RFID Library, add it and then load the example MFRC255. Upload it to the board, then go into the Serial Monitor, select Both on one of the drop downs - think its LNC and RC? I don't have everything hooked up at the moment. The baud rate should be filled in and then just tap a tag on or near the RFID board and see if it reads. Do this first to make sure everything is working before trying to write to them - as I said, for one reason or another you can burn a tag by just trying to write to it and having an error appear - or not even appear!