Hacking [Tools] AmiiBomb

  • Thread starter Ac_K
  • Start date
  • Views 261,023
  • Replies 605
  • Likes 65

cygig

New Member
Newbie
Joined
Feb 4, 2019
Messages
1
Trophies
0
Age
33
XP
38
Country
Singapore
Just discovered this recently. Custom made an acrylic case for the Amiibombuino. I hope this will convinced Ac_K to continue development for Amiibomb.

And..it seems like I cannot post any images as a new member so I shall leave it as an attachment.

--------------------- MERGED ---------------------------

Anyway my experience isn't perfect: I can make amiibos, but I cannot dump amiibo from a tag what was already written to. In fact, Amiibomb would not even recognised any tag that was already written (it keeps asking for the NFC tag as if it is not there), with the exception of blank tags. Strange....
 

Attachments

  • DSC_3224.JPG
    7.2 MB · Views: 250
  • DSC_3226.JPG
    5.8 MB · Views: 198
  • DSC_3230.JPG
    4.6 MB · Views: 177
Last edited by cygig,

JennaScvl

Well-Known Member
Newcomer
Joined
May 1, 2013
Messages
61
Trophies
0
Age
42
XP
248
Country
United States
I had the error communicating a lot of other people had. It said it was waiting for an ntag, I would place my sticker on the antenna, and it'd find the tag, try to write, and be unable to.

I resolved it by using a shorter USB cable to my arduino. It's probably a loss of amperage from cable length problem.
 

Loddurr

New Member
Newbie
Joined
Jun 14, 2019
Messages
2
Trophies
0
Age
32
XP
49
Country
Germany
I don't know how to proceed. I tried Amiibomb, but I can't seem to flash my Arduino Nano: when I have the basic Blink Sketch uploaded, it gets stuck at either "Establishing sync..." or if I have anything else actually uploaded, it gets to "> Unable to establish sync after 20 retries. > Closing serial port..."

I tried to write my NTag 215 with another guide (from konstantin-kelemen on github) - I was actually able to write to two stickers, but my Nintendo Switch doesn't seem to recognize them... no idea if it's because of the stickers, or the procedure used was the issue, but nonetheless, it doesn't work.

I'd love to get it to work with amiibomb. Any pointers? I am able to uploaded sketches properly to my Arduino Nano, but somehow Amiibomb won't sync or connect?

Cheers anyway, going through the whole post now to find anything.
 

Loddurr

New Member
Newbie
Joined
Jun 14, 2019
Messages
2
Trophies
0
Age
32
XP
49
Country
Germany
Okay. I actually managed to flash my Arduino using Powershell and avrdude! I also had to use the hex file from amiibomb alpha 2, or else amiibomb wouldnt communicate with my ntags.

Now,... I was able to successfully write on one NTag, no error messages. I launched BOTW, enabled amiibo and moved the sticker around. Nothing popped up ingame... So I went back to my PC and dumped the NTag into a bin with Amiibomb. It successfully dumped the Link amiibo into a .bin and the database showed the amiibo accordingly.

It doesn't work with my Pro Controller either. At least the issue with flashing my Arduino and writing has been resolved...

E: Oh, and would it matter if I write a decripted amiibo/.bin to a ntag? or has it to be encrypted?

E2: Holy shit, I am actually mentally challenged. You have to actually USE the sheikah slate ingame to get the amiibo to work. But still, it seems like it only worked with the decrypted .bin file I put on the Ntag. Is that the case?

E3: Maybe I should just try more instead. It actually doesn't matter it seems. Even the other Ntags I "wasted" work using a different procedure. Amiibomb is just so much more convenient to be honest, no need to copy/past Hex-code into the Arduino IDE etc. You just have to know "how" to use an amiibo actually... I didn't put the Ntags long enough ontop of my controller. I feel stupid.
 
Last edited by Loddurr,

Pangatkd

New Member
Newbie
Joined
Aug 1, 2019
Messages
3
Trophies
0
Age
38
XP
35
Country
Brazil
I have a problem with the new Amiibos files. Saved to folder and does not appear in Amiibomb.
Can someone help me?
 

Attachments

  • Amiibomb 01.png
    Amiibomb 01.png
    169.9 KB · Views: 136
  • Amiibomb 02.png
    Amiibomb 02.png
    19.5 KB · Views: 122

aussiepats

Member
Newcomer
Joined
Sep 20, 2018
Messages
23
Trophies
0
Age
33
XP
145
Country
Australia
Not sure if this thread is still active. I have connected Everything up. Got some ntag215 stickers type 2. And have the correct amiibo key files and bins. When I go to create NTAG and select the correct port. Once I hit create amiibo rage it just hangs on waiting for NTAG. And then error your tag isn’t probably not a ntag215.
 

Attachments

  • ED4BAE31-1539-4D5A-A0DC-DFFD32CD4E13.png
    ED4BAE31-1539-4D5A-A0DC-DFFD32CD4E13.png
    2 MB · Views: 199
  • 8CFD3150-726B-49A1-883F-7A6C56A83D90.png
    8CFD3150-726B-49A1-883F-7A6C56A83D90.png
    1.5 MB · Views: 195
  • 7EBAC7D0-8C8A-4E88-8F71-5A7BD1E46CD9.png
    7EBAC7D0-8C8A-4E88-8F71-5A7BD1E46CD9.png
    1.9 MB · Views: 163
  • 50AB7CC3-7D5C-4B81-A66B-CB0024DDAC55.png
    50AB7CC3-7D5C-4B81-A66B-CB0024DDAC55.png
    289.2 KB · Views: 184
  • 4DFB0FAE-45D8-429F-8D7E-734D450C5CD2.jpeg
    4DFB0FAE-45D8-429F-8D7E-734D450C5CD2.jpeg
    3.6 MB · Views: 213

aussiepats

Member
Newcomer
Joined
Sep 20, 2018
Messages
23
Trophies
0
Age
33
XP
145
Country
Australia
Not sure if this thread is still active. I have connected Everything up. Got some ntag215 stickers type 2. And have the correct amiibo key files and bins. When I go to create NTAG and select the correct port. Once I hit create amiibo rage it just hangs on waiting for NTAG. And then error your tag isn’t probably not a ntag215.
@Ac_K
 

ZeldaR0cks

New Member
Newbie
Joined
Sep 25, 2019
Messages
1
Trophies
0
Age
46
XP
25
Country
United States
I am trying to backup a real Amiibo and within the first couple of pages of being read I either get a CRC error or a data error. Example: "Page 5 on 135 is readed Error occured: ERROR Data: Error in communication." I upgraded the package to the latest MFRC522 library and now it usually fails at a later page than before. Any advice? Thanks in advance!
 
Last edited by ZeldaR0cks,

FlowLive

Member
Newcomer
Joined
Mar 5, 2020
Messages
13
Trophies
0
Age
42
XP
54
Country
Canada
Just wanted to say that as posted earlier I had to flash firmware from 0.2 and use 0.3 software for flashing of my tags.
Had to sign up, don't know what happened to my account, probably a clean-up at some point...

It would be nice if OP could update this or maybe someone make a sticky with "updated" info.
 

X BattousaiX

Member
Newcomer
Joined
Mar 15, 2013
Messages
11
Trophies
0
Age
32
XP
35
Country
United States
So, after trying to get my arduino up and running... I can't seem to get past this error.

"Waiting for NTAG... Found!

Short UID is: 0463A4521C5C80 Long UID is: 0463A44B521C5C8092

"C:\Users\Desktop\Amiibomb\AmiiBomb_0.3_Alpha_by_Ac_K\Amiibo .bin Dump\Celica.bin" is patched. "C:\Users\Desktop\Amiibomb\AmiiBomb_0.3_Alpha_by_Ac_K\Amiibo .bin Dump\Celica.bin" is send to AmiiBombuino.

Error occured: ERROR Data: A MIFARE PICC responded with NAK."

I have no clue what this means. I'm not knowledgeable enough in the slightest to solve this, and any attempts I made have not worked out for me. I don't understand what to do at all.

If anyone can explain to me what I need to do to overcome this, that'd be really great.


What is teh NAK? The Arduino + RC522 are soldered correctly + wired correctly. The .bins are fine I think.

Been spending the last 4 days on this and I have no clue where to begin.
 

nitrostemp

Well-Known Member
Member
Joined
Mar 15, 2009
Messages
1,563
Trophies
0
Age
31
XP
1,448
Country
So, after trying to get my arduino up and running... I can't seem to get past this error.

"Waiting for NTAG... Found!

Short UID is: 0463A4521C5C80 Long UID is: 0463A44B521C5C8092

"C:\Users\Desktop\Amiibomb\AmiiBomb_0.3_Alpha_by_Ac_K\Amiibo .bin Dump\Celica.bin" is patched. "C:\Users\Desktop\Amiibomb\AmiiBomb_0.3_Alpha_by_Ac_K\Amiibo .bin Dump\Celica.bin" is send to AmiiBombuino.

Error occured: ERROR Data: A MIFARE PICC responded with NAK."

I have no clue what this means. I'm not knowledgeable enough in the slightest to solve this, and any attempts I made have not worked out for me. I don't understand what to do at all.

If anyone can explain to me what I need to do to overcome this, that'd be really great.


What is teh NAK? The Arduino + RC522 are soldered correctly + wired correctly. The .bins are fine I think.

Been spending the last 4 days on this and I have no clue where to begin.

means you probably have the incorrect tag, need a NTAG215
 

X BattousaiX

Member
Newcomer
Joined
Mar 15, 2013
Messages
11
Trophies
0
Age
32
XP
35
Country
United States
means you probably have the incorrect tag, need a NTAG215

I'm pretty sure they are correct?

The other tags I have aren't ntag 215's, as the don't get registered by amiibomb. Both came with the RFID reader, and the tag is identified as a non Ntag, while the other isn't read whatsoever. Meanwhile, Amiibomb does attempt to send the data over to the RFID.

Unless the error "A MIFARE PICC responded with NAK." means the tags aren't compatible, in which case, shit, I screwed myself over with these cards.

In any case, thanks for your help.
 
Last edited by X BattousaiX,

X BattousaiX

Member
Newcomer
Joined
Mar 15, 2013
Messages
11
Trophies
0
Age
32
XP
35
Country
United States

X BattousaiX

Member
Newcomer
Joined
Mar 15, 2013
Messages
11
Trophies
0
Age
32
XP
35
Country
United States

So I went back to ali and looked up what I purchased before.

https://www.aliexpress.com/item/32849615380.html?spm=a2g0s.9042311.0.0.620a4c4dh7dEwK

Turns out they should work, so I'm not going to buy anything for now and just leave this project undone for now.

I'll probably try to get a cheap NFC android phone and use tagmo, OR buy the 3ds NFC reader and use thenaya :/

Thanks a lot for your help regardless nitro
 
General chit-chat
Help Users
    NoobletCheese @ NoobletCheese: ima need to try this https://www.youtube.com/watch?v=I1h2loTN-zM