System Files Corrupted

Discussion in 'Wii - Hacking' started by farfromsubtle, Jan 4, 2009.

  1. farfromsubtle
    OP

    farfromsubtle Member

    Newcomer
    42
    0
    Nov 22, 2008
    Canada
    My escapade started here:

    http://gbatemp.net/index.php?showtopic=117615&st=0

    Long story short, I have used AnyTitle Deleter to wipe out EVERYTHING but my precious Twilight Hack, however, I am still getting "System Files Corrupted" error.

    I have a WiiKey installed, and the 3.3 menu. I can use the TP hack to run stuff from the SD card. Not sure where to go from here... should I update to 3.4 from a game disc?
     


  2. digitydogs

    digitydogs 404 Error: Member Not Found

    Member
    1,352
    0
    Oct 19, 2008
    United States
    Md,US
    You say everything, does this include your IOS's? at any rate doing an update to 3.4 may solve your problem.
     
  3. WiiBlaster

    WiiBlaster GBAtemp Maniac

    Member
    1,189
    0
    Nov 23, 2008
    United States
    IS this a Semi Brick or Full Brick can you still access the Wii Menu, or do you get the System Files Corp on startup?
     
  4. WiiCrazy

    WiiCrazy Be water my friend!

    Member
    2,391
    1
    May 8, 2008
    Istanbul
    Run title lister and share the dump with us so we can see what stuff you have installed and so we can comment on it...

    http://www.tepetaklak.com/data/title_lister.rar
     
  5. farfromsubtle
    OP

    farfromsubtle Member

    Newcomer
    42
    0
    Nov 22, 2008
    Canada
    On start-up I get the health screen, then pressing 'A' brings "The System Files are Corrupt" screen.
     
  6. digitydogs

    digitydogs 404 Error: Member Not Found

    Member
    1,352
    0
    Oct 19, 2008
    United States
    Md,US
    anytitle may prevent it, but many people have managed to do that somehow. Eww full brick..... good luck hopefully wiicrazy has some ideas on that. I've only had semi's so far
     
  7. WiiCrazy

    WiiCrazy Be water my friend!

    Member
    2,391
    1
    May 8, 2008
    Istanbul
    By the way, do not upgrade to 3.4, it will possibly not help since the error you are getting is caused by

    A real corruption in the nand
    or
    A title installed with bad banners / bad content
    or
    Corruption of some data used by system menu...

    Installing a new system menu will not help in any of these cases... Think the semibrick scenario, if you install a new menu it doesn't even overwrite the sysconf file in the system so you got semibrick from cross region updates... there are a bunch of files used by system menu / ioses in the same fashion...
    But of course this one or a real corruption in the nand is the worst case scenarios...
     
  8. farfromsubtle
    OP

    farfromsubtle Member

    Newcomer
    42
    0
    Nov 22, 2008
    Canada
    That wont do much now, since I have wiped out everything. Only things remaining now are the two hidden channels: EULA and Region, the Current IOS, System menu, IOS9 (the original one), and the Opera Channel, which AnyTitle Deleter would not wipe out (just hangs).

    Only save still in the Memory is the TP hack.

    Would forcing an update with a new game via the gamecube controller trick be the next best bet?
     
  9. Joesalad21

    Joesalad21 Advanced Member

    Newcomer
    53
    0
    Oct 19, 2008
    United States
    That happened to me and all I did to fix it was reinstall my current firmware. (I installed 3.2u over 3.2u to fix the files.)

    I used cIOS Wii Downgrader to do this. You can find it here: http://www.gbatemp.net/index.php?showtopic=97347
    but you need to install cIOS rev7 from Waninkoko first in order to use this.

    But before you do this you must realize that I AM NOT RESPONSIBLE if your wii dies on you while downgrading or if your power shuts off or something or any damages for that matter. But I have downgraded many times with success.
     
  10. farfromsubtle
    OP

    farfromsubtle Member

    Newcomer
    42
    0
    Nov 22, 2008
    Canada
    Any other opinions? Should I try this? Note, I have already reloaded 3.2, then went up to 3.3 before using AnyTitle Deleter. Shoudl I go back down to 3.2 now that I have deleted any possible offending wads?
     
  11. WiiCrazy

    WiiCrazy Be water my friend!

    Member
    2,391
    1
    May 8, 2008
    Istanbul
    Still it would be nice to have the full title list of your wii... Title lister lists the versions of the installed content too, and each title's dependency ios... maybe you are missing an ios that some title depends especially for those hidden channels and so on...
     
  12. farfromsubtle
    OP

    farfromsubtle Member

    Newcomer
    42
    0
    Nov 22, 2008
    Canada
    Hmmm, doesn't seem to matter. Running cios downgrader from the twilight autoboot just causes the wii to reboot. Running cios directly from an autoboot disc causes "an error has occured, remove the disc" message to appear.

    Blah!
     
  13. WiiBlaster

    WiiBlaster GBAtemp Maniac

    Member
    1,189
    0
    Nov 23, 2008
    United States
    So you've done removed all the channels installed on your wii? and you've re-install the 3.2?
     
  14. farfromsubtle
    OP

    farfromsubtle Member

    Newcomer
    42
    0
    Nov 22, 2008
    Canada
    Code:
    Found 8 titles:
    1: Title=10001-48414445 (downloaded channel 'HADE') vers: 1.1 (257) FW: IOS34 
    2: Title=10008-48414c45 (hidden? channel 'HALE') vers: 0.2 (2) FW: IOS31 
    3: Title=10008-48414b45 (hidden? channel 'HAKE') vers: 0.2 (2) FW: IOS31 
    4: Title=10000-00555044 (savedata for '.UPD') FW: IOS4 
    5: Title=10000-525a4445 (savedata for 'RZDE') FW: IOS9 
    6: Title=1-9 (IOS9)ÂÂvers: 2.4 (516)
    7: Title=1-1e (IOS30)ÂÂvers: 10.16 (2576)
    8: Title=1-2 (System Menu)ÂÂvers: 1.97 (353) FW: IOS30
     
  15. WiiBlaster

    WiiBlaster GBAtemp Maniac

    Member
    1,189
    0
    Nov 23, 2008
    United States
    now i may be wrong have you tried installing the IOS31 looks like , but them hidden channels look like they require IOS31 may be a stupid idea
     
  16. nutta_nic

    nutta_nic GBAtemp Advanced Fan

    Member
    556
    0
    Oct 25, 2008
    have you tryed anyregion changer its pretty much bad ass
     
  17. WiiCrazy

    WiiCrazy Be water my friend!

    Member
    2,391
    1
    May 8, 2008
    Istanbul
    It seems you deleted to much...

    But another idea, check the log files on your nand using filesystem browser application... you might see something interesting there, for example look at /shared2/test/testlog.txt ... you should see CHECK_NAND_DATA=OK... blah blah on a healthy system...

    CODEFound 8 titles:
    1: Title=10001-48414445 (downloaded channel 'HADE') vers: 1.1 (257) FW: IOS34
     
  18. WiiBlaster

    WiiBlaster GBAtemp Maniac

    Member
    1,189
    0
    Nov 23, 2008
    United States
    i have v10.40 on my 3.2 also and them hidden channels require IOS31, them hidden channels can brick your wii if their not working
     
  19. WiiPower

    WiiPower GBAtemp Guru

    Member
    8,165
    72
    Oct 17, 2008
    Gambia, The
    Why don't you extract all update files form a 3.1 or 3.2 game with wufe and install the files you got with WAD Manager? But you should skip everything which is already on your Wii, especially IOS30 and the system menu(IOS2). Maybe you should wait for others commenting this method, messing around with system files is always dangerous.
     
  20. farfromsubtle
    OP

    farfromsubtle Member

    Newcomer
    42
    0
    Nov 22, 2008
    Canada
    To be honest, I could care less about getting this fixed right now... I am happy just waiting for BootMii. I think I will just burn a few autoboot games and play them for now. [​IMG]