1. mattyxarope

    mattyxarope GBAtemp Fan
    Member

    Joined:
    Jan 15, 2019
    Messages:
    372
    Country:
    United States
    Not sure how, but it doesn't work for me.

    I'm have SX hidden partition emunand, maybe that's it?
     
    Hologram likes this.
  2. Hologram

    Hologram GBAtemp Fan
    Member

    Joined:
    Nov 27, 2020
    Messages:
    335
    Country:
    United States
    Let me load it again and see what it loads. I have files based TX SX OS.

    Edit: Its loading Sysnand even though I have a TX file based partition. I'm sure its just a setting. If you follow my steps yours should also be loading.
     
    Last edited by Hologram, Jan 6, 2021
    mattyxarope likes this.
  3. ombus

    ombus GBAtemp Fan
    Member

    Joined:
    Dec 28, 2015
    Messages:
    496
    Country:
    United States
    No credit ? mmm hohoho
     
  4. mattyxarope

    mattyxarope GBAtemp Fan
    Member

    Joined:
    Jan 15, 2019
    Messages:
    372
    Country:
    United States
    I followed the steps, I didn't change any settings. All downloaded fresh.

    Boot0 error
     
    Hologram likes this.
  5. Hologram

    Hologram GBAtemp Fan
    Member

    Joined:
    Nov 27, 2020
    Messages:
    335
    Country:
    United States
    Last edited by Hologram, Jan 6, 2021
    slaphappygamer likes this.
  6. britain4

    britain4 GBAtemp Fan
    Member

    Joined:
    Jun 16, 2014
    Messages:
    376
    Country:
    I’ve never really had much experience with RR - is that error after a Cleanup from the SXOS bootloader?
     
  7. mattyxarope

    mattyxarope GBAtemp Fan
    Member

    Joined:
    Jan 15, 2019
    Messages:
    372
    Country:
    United States
  8. deejay87

    deejay87 GBAtemp Regular
    Member

    Joined:
    Aug 25, 2019
    Messages:
    125
    Country:
    France
    Question is why RR is working and not ams 0.17.0 /.5.5.2 release
     
    gigigadda likes this.
  9. alucard_xs

    alucard_xs GBAtemp Advanced Fan
    Member

    Joined:
    Oct 31, 2012
    Messages:
    643
    Country:
    Canada
    So now, no more need to wait for SXOS update ? We are not stuck with SX os firmware ? even on Switch lite ?
    We can use Atmos and SX lite chip ?
     
  10. mattyxarope

    mattyxarope GBAtemp Fan
    Member

    Joined:
    Jan 15, 2019
    Messages:
    372
    Country:
    United States
    Correct (well, if you have hidden emunand that still doesn't work)


    You can also downgrade emunand using atmo
     
    alucard_xs likes this.
  11. britain4

    britain4 GBAtemp Fan
    Member

    Joined:
    Jun 16, 2014
    Messages:
    376
    Country:
    Could be hidden emuNAND + Switch Lite issue, I use hidden emuNAND on patched Erista and it’s fine, originally created in SXOS and set up in AMS with the .ini file
     
    mattyxarope likes this.
  12. alucard_xs

    alucard_xs GBAtemp Advanced Fan
    Member

    Joined:
    Oct 31, 2012
    Messages:
    643
    Country:
    Canada
    Cool, I'm gonna wait for some tutos before doing anything with my Emunand, fearing to loose it.
     
  13. mattyxarope

    mattyxarope GBAtemp Fan
    Member

    Joined:
    Jan 15, 2019
    Messages:
    372
    Country:
    United States
    Ok so I figured out what was wrong.

    I have SX Lite hidden partition emunand and used Choi to update my emunand partition. This corrupts the BOOT0/1 on emunand. So in order for Atmo to boot properly (which as of now requires using SX Gear), you have to backup the BOOT0/1 paritions from your sysnand (with the same firmware version) and then restore those to the emunand partition.

    The problem is that I have no idea how to do that, lol.
     
  14. Adran_Marit

    Adran_Marit Walküre's Hacker
    Member

    Joined:
    Oct 3, 2015
    Messages:
    2,983
    Country:
    Australia
    You need to restore a mariko boot file backup - what firmware was it on?
     
  15. mattyxarope

    mattyxarope GBAtemp Fan
    Member

    Joined:
    Jan 15, 2019
    Messages:
    372
    Country:
    United States
    Restored using Hekate from a backup of Boot0/1 Firmware 11.0.0 sysnand to the same firmware for my emunand. Only ever used Choi for emunand.

    I'm beginning to think that the Hekate Boot0/1 restore feature isn't working as intended. I'll have to get my card reader when I can.
     
  16. Adran_Marit

    Adran_Marit Walküre's Hacker
    Member

    Joined:
    Oct 3, 2015
    Messages:
    2,983
    Country:
    Australia
    Choi breaks mariko stuff from what I'm aware
     
    Hologram likes this.
  17. Hologram

    Hologram GBAtemp Fan
    Member

    Joined:
    Nov 27, 2020
    Messages:
    335
    Country:
    United States
    Mariko. Choi works good on emunand and daybreak works good on sysnand.

    I use choi to update my emunands.
    I use daybreak to downgrade my sysnands.
     
  18. HenryMin

    HenryMin GBAtemp Regular
    Member

    Joined:
    Jun 19, 2020
    Messages:
    108
    Country:
    Korea, South
    SXOS has kind of protection for ChoidujourNX on mariko (maybe it's illegal),
    but Atmosphere is open source, so it doesn't have one.
    Choidujour-bricked sysNAND/emuNAND will not work on Atmosphere.
    You should always use Daybreak on atmosphere&mariko.
     
    Adran_Marit, hartleyshc and Hologram like this.
  19. Hologram

    Hologram GBAtemp Fan
    Member

    Joined:
    Nov 27, 2020
    Messages:
    335
    Country:
    United States

    Choi on Mariko works well on emunand V1 patched/V2/Lite. No issues updating just don't downgrade and or touch sysnand.
     
  20. Adran_Marit

    Adran_Marit Walküre's Hacker
    Member

    Joined:
    Oct 3, 2015
    Messages:
    2,983
    Country:
    Australia
    I wouldn't be risking it - especially as ChoidujourNX hasn't been updated to support mariko officially and may never will.
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - firmware, Modchip, dumped