Strangest computer-related thing ever witnessed

ouranogrammi

New Member
OP
Newbie
Joined
Dec 13, 2021
Messages
2
Trophies
0
Age
41
XP
39
Country
Greece
After some long months of inactivity i decided to continue playing Luigi Mansion 3. My switch has been disconnected from power for months.
Tried to charge it a little bit, then connected to my computer, inserted the jig and held vol+ and pushed the power button. I injected Sxloader.bin (through TegraRcmGUI) as usual and i found my self in SXOS select screen (boot customfw / boot fw etc). I selected customFW as usual and all i got was a black screen with battery indication on top left corner. (My SXOS ver is 3.0.4)
I googled a little bit and i saw the "try to rewrite boot.dat on SD card" solution.
I had this problem like 6 months ago and i remembered that, this solution worked then.

So i got the SDcard on to my PC, and before rewriting SXOS 3.0.4 boot.dat file again i did a CRC the boot.dat file on the card and it was matching the CRC of the boot.dat on my SXOS 3.0.4 PC backup folder.
So there was no corruption
Still, I overwrited the file on the card, i booted my SXOS and ...problem gone.

So I don't need any help or support but i can't get my head around the fact that the boot.dat file on the SD was EXACTLY the same as the boot.dat file on my PC but i had to overwrite it to work.

How this is possible?!??!?
 

Chaosta

Well-Known Member
Member
Joined
Sep 18, 2020
Messages
596
Trophies
0
XP
759
Country
United States
After some long months of inactivity i decided to continue playing Luigi Mansion 3. My switch has been disconnected from power for months.
Tried to charge it a little bit, then connected to my computer, inserted the jig and held vol+ and pushed the power button. I injected Sxloader.bin (through TegraRcmGUI) as usual and i found my self in SXOS select screen (boot customfw / boot fw etc). I selected customFW as usual and all i got was a black screen with battery indication on top left corner. (My SXOS ver is 3.0.4)
I googled a little bit and i saw the "try to rewrite boot.dat on SD card" solution.
I had this problem like 6 months ago and i remembered that, this solution worked then.

So i got the SDcard on to my PC, and before rewriting SXOS 3.0.4 boot.dat file again i did a CRC the boot.dat file on the card and it was matching the CRC of the boot.dat on my SXOS 3.0.4 PC backup folder.
So there was no corruption
Still, I overwrited the file on the card, i booted my SXOS and ...problem gone.

So I don't need any help or support but i can't get my head around the fact that the boot.dat file on the SD was EXACTLY the same as the boot.dat file on my PC but i had to overwrite it to work.

How this is possible?!??!?
sd corruption. is it exfat or fat32?
 

JayBae

Well-Known Member
Member
Joined
May 24, 2020
Messages
302
Trophies
0
Age
37
Location
America
XP
377
Country
United States
How this is possible?!??!?

It's a faulty or slightly corrupted SD card, it happens from time to time, The files appear the same, but when you overwrote it with the new file it kinda updates where the data is stored thus avoided the corruption. Least that's my guess anyways.
 

Site & Scene News

Popular threads in this forum

General chit-chat
Help Users
  • No one is chatting at the moment.
    The Real Jdbye @ The Real Jdbye: they could put minigames in it that you play using the pictures you take