So Ubuntu crashed. Any ideas?

Discussion in 'Computer Games and General Discussion' started by swimmeringer, Jan 10, 2009.

Jan 10, 2009
  1. swimmeringer
    OP

    Member swimmeringer GBAtemp Regular

    Joined:
    Jul 15, 2007
    Messages:
    132
    Location:
    Behind You
    Country:
    United States
    SO I was just on my computer (dualbooted xp and ubuntu, with xp as my in-case-anything-happens-to-ubuntu os) minding my own business, when I go and play a game with my friend.

    I return to my computer and find that i cant run any more programs, i can only do stuff with what i've got open (firefox, pidgin).

    I restart my computer and see if that helps.

    It doesn't.

    I get the black screen of death, and I use my pal's laptop to find a fix. I uninstalled compiz, tried loading it again, and the same thing happened. I reinstalled compiz, and rebooted yet again.

    The BSOD is gone. HOWEVER, now just my background shows up and nothing loads at all. No menubars, no second desktop, nothing but my cursor and my background.

    Does ANYONE have any ideas on how to fix this? I've tried changing graphics cards (to fix BSOD... no avail), going into safe mode, etc.

    Before you ask, yes, i can hit Ctrl+alt+F1 to get to the terminal screen. Ubuntu auto-logs me in when it starts.

    Any help would be appreciated. Thank you.
     
  2. Jiggah

    Member Jiggah GBAtemp Maniac

    Joined:
    Nov 9, 2002
    Messages:
    1,223
    Country:
    United States
    Try reinstalling gnome?

    sudo apt-get install gnome
     
  3. swimmeringer
    OP

    Member swimmeringer GBAtemp Regular

    Joined:
    Jul 15, 2007
    Messages:
    132
    Location:
    Behind You
    Country:
    United States
    Didn't work... Same problem still. But it did install ~77 updates i think...
     
  4. Jax

    Member Jax Pip Pip Cheerioink!

    Joined:
    Jul 31, 2006
    Messages:
    4,092
    Location:
    L.A.V.
    Country:
    Portugal
    But Ubuntu can't crash. It's Linux!


    [/sarcasm]
     
  5. Scorpei

    Member Scorpei GBAtemp Maniac

    Joined:
    Aug 21, 2006
    Messages:
    1,295
    Country:
    Netherlands
    Try chaning your xorg.conf to get the vesa drivers back, disable compiz while you're at it as I dunno how well vesa does that [​IMG].

    Sounds like your X server is dead seeing as you can still get a terminal with a fully loaded system (just no 'desktop' right?).
     
  6. TLSpartan

    Member TLSpartan Kills threads

    Joined:
    Oct 20, 2006
    Messages:
    2,053
    Country:
    Australia
    This use to happen to me (One of the various reasons I removed Ubuntu of my system). It just sounds like X is growing to big and crashing (Happened to me in Xubuntu and Ubuntu as well so it is not a GNOME problem). I never found a fix so I just installed Debian.
     
  7. Jiggah

    Member Jiggah GBAtemp Maniac

    Joined:
    Nov 9, 2002
    Messages:
    1,223
    Country:
    United States
    Run:

    sudo dpkg-reconfigure xserver-xorg

    Configure xserver.

    then run:

    sudo /etc/init.d/gdm start
     
  8. swimmeringer
    OP

    Member swimmeringer GBAtemp Regular

    Joined:
    Jul 15, 2007
    Messages:
    132
    Location:
    Behind You
    Country:
    United States
    No dice. Thanks, but I just don't think anyone here can fix it. Reinstalling.

    Thank you very much anyways.
     

Share This Page