SNES + SMW VERY Strange Bug...

Discussion in 'Other Consoles & Oldies' started by StarOfDoom, Jul 5, 2015.

  1. StarOfDoom
    OP

    StarOfDoom GBAtemp Regular

    Member
    218
    24
    Apr 11, 2015
    United States
    Hello! I have been speed running Super Mario World for a while now, so I decided to get off of emulator and buy a console. I got a SNES, did a sfc mod to it (break 2 tabs, allows the SNES to play Japanese SNES games [SFC]), got a Japanese SMW cart, set the whole thing up, and started the game... Only to find something VERY strange. Mario's sprite is messed up.. His body is invisible, his hat is normal, and his face is backward. If I let the main menu intro sequence thing play out, Mario FALLS THROUGH THE GROUND, gets a GAME OVER, and then puts me in control on that stage. This is just the into screen. Not supposed to be able to get there.. If I start the game before I get a game over there, and go into Yoshi's Island 2, the platforms have no collision, and every single sprite is messed up. I'll get a video of it tomorrow. Any help? Anything that could be causing this? :/

    Thanks,
    Star
     
  2. Coto

    Coto GBAtemp Addict

    Member
    2,367
    416
    Jun 4, 2010
    Chile
    to me seems the cart must have a busted line or something (wrong rom fetch/execution) which can cause funny issues with code.
     
  3. StarOfDoom
    OP

    StarOfDoom GBAtemp Regular

    Member
    218
    24
    Apr 11, 2015
    United States
    Do you think I should try to return the cart and buy a new one? Or do you think it could be the SNES itself?
     
  4. Coto

    Coto GBAtemp Addict

    Member
    2,367
    416
    Jun 4, 2010
    Chile
    well i would try the cart on another usa snes console (there's the BIC-melt pen trick to fake a gamebit screwdriver) first
     
  5. StarOfDoom
    OP

    StarOfDoom GBAtemp Regular

    Member
    218
    24
    Apr 11, 2015
    United States
    That's the issue, I don't really have the money to buy another console... I don't want to return, say, the game only to find its the console that is broken or the other way around. :/
     
  6. Lumstar

    Lumstar Princess

    Member
    3,635
    89
    Mar 6, 2006
    United States
    Darling
    Try any other cart. The lamest most horrific sports game if necessary.
     
  7. HaloEffect17

    HaloEffect17 Splatoon Fan

    Member
    1,034
    977
    Jul 1, 2015
    Canada
    Hmmm... how about cleaning the cart connectors with a bit of rubbing alcohol on a Q-tip?
     
  8. endoverend

    endoverend AKA zooksman

    pip Contributor
    GBAtemp Patron
    endoverend is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    2,847
    3,550
    Jun 6, 2013
    United States
    Almost the symptoms of cartridge tilting on an N64. That's definitely a cart issue-- try cleaning it but your cart may just be borked.
     
    HaloEffect17 likes this.
  9. HaloEffect17

    HaloEffect17 Splatoon Fan

    Member
    1,034
    977
    Jul 1, 2015
    Canada
    I remember the time my cartridge copy of Pokemon Silver [GBC] had a Giovanni sprite as a Pokemon in a regular battle with a bunch of gibberish text. I found it hilarious at the time dishing out wing attack on Giovanni! Anyways, I gave it a light clean and then it played properly.
     
  10. endoverend

    endoverend AKA zooksman

    pip Contributor
    GBAtemp Patron
    endoverend is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    2,847
    3,550
    Jun 6, 2013
    United States
    Yeah, cartridges can do some funny things if you mess with them.
     
  11. StarOfDoom
    OP

    StarOfDoom GBAtemp Regular

    Member
    218
    24
    Apr 11, 2015
    United States
    Hey! So I talked to a few SNES "experts" (Some people in the SMW community) and they said it was the console, so I returned the console, got another, and sure enough, everything works perfect! :D