Smash Selector won't load any mods

Discussion in '3DS - Flashcards & Custom Firmwares' started by CGGamer, Feb 19, 2017.

  1. CGGamer
    OP

    CGGamer Member

    Newcomer
    24
    1
    Aug 10, 2016
    United States
    I have an 11.3 N3ds with a9lh, luma, and ntr. I'm trying to use smash selector so I can switch between two different NEOS and Turbo'd. All the Smash Selector settings are configured correctly, and the game boots up, but with no mods. The directory looks like this:

    saltysdMODS/Slot_1/(mod files with the desc.txt file)

    It's also worth noting that I'm trying to run the mods on a sky3ds cart with SSB3ds. I get a "removed sd card error...boot to home menu" error, so I have to select as a cia. After the game boots with smash selector, it makes a regular saltysd folder on root, with all the files of the mod I tried to launch. I just upgraded my luma, and the option for external code loading is replaced with a patched game option, so I just checked that instead
     
  2. bobbio

    bobbio Newbie

    Newcomer
    5
    0
    Feb 21, 2017
    United States
    I made an account just to say this: If you're using the latest version of smash selector, set the option that asks whether you're using a CIA or cartridge to the opposite of what it should be (If you have the CIA put it to cartridge and vice versa)
     
  3. bobbio

    bobbio Newbie

    Newcomer
    5
    0
    Feb 21, 2017
    United States
    Ah sorry, I read your post wrong. Is "Enable region/language emu. and ext. .code" enabled? If not do so in your luma settings (hold select while booting), and do you have the bins in your /luma/code_sections/ ? If not here they are: https://www.dropbox.com/s/z7555wcks1m9n84/codes.zip?dl=1 . It's in the code folder in the zip.

    (I got the link from the original thread for smash selector)

    EDIT: Try not to use a nightly build, I have the latest version of Luma (6.6) and it still has
    "Enable region/language emu. and ext. .code" [​IMG]
    Proof ^
     
    Last edited by bobbio, Feb 21, 2017
  4. Windylacine

    Windylacine GBAtemp Regular

    Member
    254
    62
    Apr 15, 2016
    Anyone else have this problem?

    It's same issue as mine, selecting Enable region/language emu and ext. code doesn't work either.
     
  5. bobbio

    bobbio Newbie

    Newcomer
    5
    0
    Feb 21, 2017
    United States
    For what it's worth I've tested and confirmed that you need to be on a normal version of Luma (Not hourly/nightly), and don't mix mod packs. And if you haven't already get the .bin for your region of smash (all three are provided from the original thread).

    If you've done everything and it still doesn't work just do it the old fashioned way, one mod pack only, by putting the mods in /saltysd/smash .
     
  6. Windylacine

    Windylacine GBAtemp Regular

    Member
    254
    62
    Apr 15, 2016
    That works perfectly fine after realizing I forgot to put code.bin in the code_sections folder inside luma, thanks for the suggestion. ^^
     
  7. Ichiriki

    Ichiriki GBAtemp Regular

    Member
    106
    14
    Dec 2, 2016
    I have changed to normal version, still doesn't work, im going try re-do everthing and let's see if i find a workaround
     
  8. kj1995

    kj1995 Newbie

    Newcomer
    1
    0
    Feb 28, 2017
    United States
    i had some stange problems too, even if i dont have mods turned on, my smash game runs slow and stays that way, even if i have no mod files even on the 3ds, no options turned on the luma boot screen.
     
  9. ApexDevelopment

    ApexDevelopment Newbie

    Newcomer
    1
    0
    Mar 19, 2017
    United States
    Has anyone found a reliable solution to this? I'm still having issues, my sm4sh is stuck on Turbo'd and nothing I do in smash-selector changes it. I had to manually delete my modpack from root/saltysd. I have "Enable region/language emu and ext. code" turned on and all necessary codes in root/luma/code_sections.

    EDIT: Smash doesn't even start now. I get "An error has occued" and my system restarts.

    EDIT2: I've made my own "Smash Selector" type thing that swaps mods by renaming them, it works better than Smash Selector does lmao

    EDIT3: It seems 11.3 broke Smash Selector somehow?
     
    Last edited by ApexDevelopment, Mar 21, 2017