Slight Issue with Univeral Inject Generator

Discussion in '3DS - Homebrew Development and Emulators' started by TheApexTheater, Mar 13, 2016.

  1. TheApexTheater
    OP

    TheApexTheater Member

    Newcomer
    13
    1
    Mar 11, 2016
    United States
    Hi! I'm following Plailect's guide to homebrewing a 3DS, and am currently on Part 4, "Getting the OTP." As you could probably guess in the title, I'm having a small-ish problem with the Universal Inject Generator.

    I followed the guide and got to the point where I have the FBI.cia and hs.app files (the latter of which I got from Decrypt9's "Health and Safety Dump") and have inserted them into the "input" subdirectory of the "Universal-Inject-Generator-Master" folder. Here's where the issue lies: When I double-click the "go.bat" file (and I'm on a Mac, using wine and winebottler to run the file. I've done this before, so I know this manner of running the go.bat file works), I get a small window with the prompt "File Not Found".

    However, when I move the entire directory to the SD card and run "go.bat" from there, I get the FBI_inject_no_banner.app and the FBI_inject_with_banner.app files without any problem... Is this an issue with how I have my directories set up? Or is it a small bug in the Universal-Inject-Generator?

    (To clarify...Attached is the set up on my computer's desktop, which doesn't work. When I move this directory to the SD card and run go.bat, I get the desired files)

    PS: Just for future reference, can I re-use the FBI_inject_with_banner.app file? Or do I have to redo this process of using the Universal Inject Generator each time I want to download sysUpdater?
     

    Attached Files:

    Last edited by TheApexTheater, Mar 13, 2016
  2. Razorzeto

    Razorzeto Darkness can not drive out darkness.

    Member
    182
    216
    Aug 27, 2015
    Currently living in Chile.
    Move hs.app to the main folder wher go.bat it's located and try again.
     
  3. TheApexTheater
    OP

    TheApexTheater Member

    Newcomer
    13
    1
    Mar 11, 2016
    United States
    Just tried this... Sorry, but it doesn't seem to work.
     
  4. TheReturningVoid

    TheReturningVoid 0xAAAAAAAA

    Member
    332
    143
    Oct 2, 2014
    /dev/urandom
    Try running go.bat from the command line.

    Code:
    wine cmd
    go.bat
     
  5. Mistie

    Mistie Legit Furry Trash

    Member
    180
    159
    Jan 20, 2016
    Canada
    Hyrule
    Open the Wine file manager and go to the location of the go.bat file and double click it. Don't use finder. Using the Wine file manager will launch it using wine's DOS prompt. This should make it work properly. There is no way to fix this for ANY .bat application. It's an issue with wine. It's trying to find the cmd program or something and since its wine it doesn't exist.
     
  6. TheApexTheater
    OP

    TheApexTheater Member

    Newcomer
    13
    1
    Mar 11, 2016
    United States
    Alright. Thank you very much!