Should I buy another Acekard?

Discussion in 'Acekard' started by Cinq, May 28, 2010.

May 28, 2010

Should I buy another Acekard? by Cinq at 10:36 PM (947 Views / 0 Likes) 4 replies

  1. Cinq
    OP

    Newcomer Cinq Newbie

    Joined:
    May 28, 2010
    Messages:
    2
    Country:
    United States
    I've had this Acekard 2i for awhile now. Maybe 5-7 months, I'm not sure. I just started to use it now, since I had originally bought it for a friend, but she never picked it up. I just bought a DSi, so I'm on v1.4u on it. I did all the updating and whatnot to get it to work on my 1.4u DSi, and for about a day or two, it worked (more or less, since one several games, it would freeze at a black or white screen, usually during a save or on startup. Also some games would just freeze on the spot.)

    Last night is when things started to irritate me. Whenever I would turn on my DSi, it would show a BLANK cartridge. Not the "There is no cartridge inserted in the slot." It was a straight up blank cartridge. It let me "start" it, but it would just give me the infamous "An error has occured. Please turn the DS power off........" message. I was up all night trying to fix it. The blank cartridge never changed back to the Danny Phantom icon it used to be. I tried the paper trick, sticking a piece of paper under the PCB and all that jazz, all to no success.

    Now, my question is this. Is this a common thing amongst the Acekards? Because for the most part, I've read good things about it, and that it has 100% ROM compatibility. But with my experience, it had about maybe 60% ROM compatibility, since I was experiencing freezing and crashing while playing games. (Some games were Castlevania: Order of Ecclesia, Cooking Mama 3, Rhythm Heaven, Meteos, and a few others.) And other times, it would freeze on the "Loading" screen, after I selected a game to run.

    Do I just have a faulty kit and should order a new one?
     
  2. RupeeClock

    Member RupeeClock Colors 3D Snivy!

    Joined:
    May 15, 2008
    Messages:
    6,307
    Country:
    United Kingdom
    Does it still work in another DS lite?
    If it does you might be able to reflash it.

    It might be worth rebuying a new one though, mine was working great for a good year without doing anything to support the contacts.

    Waaait...60% compatibility? Don't tell me you were using the official firmware!
    If you use an Acekard 2i, you should use AKAIO firmware!
     
  3. Cinq
    OP

    Newcomer Cinq Newbie

    Joined:
    May 28, 2010
    Messages:
    2
    Country:
    United States
    I was using the official firmware for the first few days. But those first few days were when it was actually working. I started using AKAIO last night, and that's where things started to get messed up. I tried the Acekard on my GF's DS Lite, and it's the same thing, a blank cartridge, not empty, but blank. If you start it, the DS Lite will just freeze at a white screen. I'm sure it isn't because I started using AKAIO that it just stopped working, but something wrong with the card itself.

    Even with AKAIO, the first game I played, Meteos, it froze at a black screen when I tried to start a game.
     
  4. RupeeClock

    Member RupeeClock Colors 3D Snivy!

    Joined:
    May 15, 2008
    Messages:
    6,307
    Country:
    United Kingdom
    Did you try putting the official firmware back on there?

    Anyway, it sounds like you might just have to buy a new Acekard, at least they're not that expensive.
     
  5. tk_saturn

    Member tk_saturn GBAtemp Psycho!

    Joined:
    Jan 26, 2010
    Messages:
    3,327
    Country:
    United Kingdom
    The only thing you can do is try to reflash it using my guide http://gbatemp.net/index.php?showtopic=218103#unbrick

    Because you can't boot the Acekard, you'll need another Flashcart. You start the firmware update, then swap the carts as in the guide. It should then rewrite the firmware on your bad cart.

    You will need a DS Lite or DS Phat for this.

    Not much else you can do really. If you are going to buy another Acekard 2i, places such as ShopTemp can preupdate them to 1.4 before shipping.
     

Share This Page