Official Retroarch WiiU (wip.)

Discussion in 'Wii U - Homebrew' started by aliaspider, Nov 6, 2016.

  1. Gunstorm

    Gunstorm Advanced Member

    Newcomer
    2
    Jan 24, 2017
    Brazil
    Guys i need to do some Special configurations to run Quake on retroarch?
    Doom is running fine, but Quake appear a console screen and the game sound seems Crazy in backgound

    https://photos.app.goo.gl/9oxVkDUu4ihWdNPZ7
     
    Last edited by Gunstorm, Mar 8, 2019
  2. FanNintendo

    FanNintendo GBAtemp Regular

    Member
    3
    Apr 16, 2018
    United States
    Got Killer Instinct running but slow wish have overclock like Switch have. KI and KI2 running on Switch okay than Wii U
     
  3. Maxbeta

    Maxbeta GBAtemp Regular

    Member
    4
    Jul 20, 2014
    United States
    Got a USB adapter this weekend called the Gam3gear Xbox360 to Switch Superconverter and amazingly enough it performs WONDERFULLY with Wii U and even more importantly with everything Retroarch I would throw at it. I got it from Amazon for $30 and they have one as well for Playstation controllers.

    Here's a quick look at it https://www.instagram.com/p/Bu0NnWSHA5i/

    I noticed a minuscule tiny bit of lag in the response at first but just changed the polltype to "EARLY" in most cases and after that it just felt like a genuine arcade experience.

    Also it works great will all the Wii U games I tested it with, but sadly no-go on Nintendont or anything on the the vWii side of things. Still, I definitely recommend it.

    Remember if you're planning on getting it, get the one for the Switch which I show on the pic because its basically the Wii U (standard) one updated to (pro) for compatibility with most all
    Wii U games and of course everything Nintendo Switch.

    I'll be getting a Mayflash converter soon too because I def need vWii compatibility.
     
    Last edited by Maxbeta, Mar 11, 2019
    CORE likes this.
  4. RowanDDR

    RowanDDR SNES Lover

    Member
    4
    Apr 13, 2006
    London
    @Aglaophotis How did you get the shaders working? When I apply one the screen just goes black. I'm trying with SNES 9x.
     
  5. the_randomizer

    the_randomizer The Temp's official fox whisperer

    Member
    23
    GBAtemp Patron
    the_randomizer is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Apr 29, 2011
    United States
    Dr. Wahwee's castle
    Maybe the Wii U isn't powerful enough?
     
  6. RowanDDR

    RowanDDR SNES Lover

    Member
    4
    Apr 13, 2006
    London
    The fact that Aglaophotis says he has it working suggests otherwise.
     
  7. the_randomizer

    the_randomizer The Temp's official fox whisperer

    Member
    23
    GBAtemp Patron
    the_randomizer is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Apr 29, 2011
    United States
    Dr. Wahwee's castle
    It was just a guess, who knows why, hopefully when they're compiled with the upcoming WUT toolchain, they'll be easier to test.
     
  8. Aglaophotis

    Aglaophotis GBAtemp Regular

    Member
    3
    Jan 7, 2017
    Germany
    Which shaders did you try? There were some which also gave me a black screen. A good bunch of them doesn't work properly or at all. Some others may cause slowdowns.
    I haven't even tried that many, just the few I wanted to use. For instance, some shaders from the 'retro' folder do work fine.
    Currently I've settled with crt-caligari (from the 'crt' folder) for SNES games. It looks pretty amazing, at least on my 4K tv.
     
  9. RowanDDR

    RowanDDR SNES Lover

    Member
    4
    Apr 13, 2006
    London
    I just tried crt-caligari and same thing here - screen goes black and have to reboot the WiiU. What ROM are you trying with and what SNES9x core?
     
  10. Aglaophotis

    Aglaophotis GBAtemp Regular

    Member
    3
    Jan 7, 2017
    Germany
    Ok that's weird. Sounds like the whole console is crashing if you have to reboot it. Because what I meant is that certain shaders simply gave me a black screen (while the music kept playing) but I could just switch to another shader or turn it off and the picture was back. The console or Retroarch didn't crash.
    I'm using the normal Snes9x core (1.59.2) and it works with any ROM I've tried (Zelda, Yoshi's Island, Street Fighter 2, Mario Kart, Chrono Trigger etc...). It also worked on Nestopia. Normally the ROMs shouldn't even matter if you can run them fine without shaders. In worst case it would just mess up your ingame picture or slow everything down after which you can switch to another one. So to me it sounds like there is some other issue you're having.
    Are you picking the .slangp files when choosing a shader in the menu?
     
  11. Drocles-Drogly

    Drocles-Drogly Newbie

    Newcomer
    1
    Mar 14, 2019
    Denmark
    Ok, so I manage to get some of the slang shaders to work, but the "Save Core Preset" function doesn't seems to work.

    Anyone know how to fix this issue or experiences the same error?
     
    Last edited by Drocles-Drogly, Mar 15, 2019 at 2:03 PM
  12. september796

    september796 GBAtemp Regular

    Member
    3
    May 4, 2015
    Cote d'Ivoire
    is there any way of showing the gamepad's battery status in the retroarch menu? since there's no way to display wii u home menu we can't see it. Also, any way of changing gamepad brightness in retroarch?
     
  13. jesus96

    jesus96 Advanced Member

    Newcomer
    3
    Sep 2, 2015
    Mexico
    FBA is broken? I can't load anything now

    I always get the DSI error
     
  14. FanNintendo

    FanNintendo GBAtemp Regular

    Member
    3
    Apr 16, 2018
    United States
    DSI CORE ON RETROARCH WII U?
     
  15. Mintos

    Mintos Newbie

    Newcomer
    1
    Jul 10, 2018
    United Kingdom
    By following a guide earlier in the thread ive managed to get puae running with retroarch on my wii u, the problem is my controls dont work, if i press y it'll freeze, does anyone know anything i could try?
     
  16. RowanDDR

    RowanDDR SNES Lover

    Member
    4
    Apr 13, 2006
    London
    @Aglaophotis I thought it was easier if I made a video, to show what happens when I enable a shader:

    Does what I'm doing there look right?
     
Loading...