Homebrew Retroarch Dosbox - Looking for a Working Config

Kubba

Well-Known Member
OP
Newcomer
Joined
Nov 4, 2015
Messages
75
Trophies
0
Age
33
XP
132
Country
United States
Hiya,

I've been looking here and there in the forums trying to find out how people have gotten Windows 95\3.11 to run on their machines. I've played around with .conf files and trying to launch Win 3.11 in Retroarch Dosbox versions 1.3.3 to more recent releases. Still no dice. Trying to run anything gives me a kernel panic.

I'm running an N3DS with the latest firmware, latest version of Luma on B9S. I could tell you all about my current Dosbox setup, but I'd rather hear the details of someone else's setup.

Thanks!

Edit: Alright, so I've messed around with Retroarch Dosbox. My tests included .3dsx and .cia builds from 1.3.3 to the latest builds. I've also tried the setup another user made with some batch files. I built a windows 95 image using another (woefully incomplete) guide and edited a batch file and .conf file to mount the windows 95 image. I managed to get the farthest in the 1.6.7 CIA build.

I can get as far as the bootscreen for 95, but I still get the Kernel Panic error. Disappointment, especially after all the time I spent setting up. I did some searching again and came across this post; the first sentence is all that really matters, but I've included the whole thing for posterity:

Retroarch has a known issue with Luma and the way Luma handles crashes. It always crashes for me, regardless of the core I load. Since Luma was updated last (Luma3DS version 8.1.1), Retroarch and NTR CFW are the only homebrew apps still crashing for me.

It's gotten to the point that I prefer the standalone SNES9x and VirtuaNES by bubble2k (god I wish he'd write a Genesis emulator too!) over Retroarch because of a consistent easy to replicate crashes. Basically do this: Load Retroarch, load any core, load any game for that core. You've got a 50/50 chance of actually playing the game and not seeing it crash. If by chance it does load the content and you get to play, it is GOING to crash on Retroarch exit. So, load Retroarch, load core, load content, play for a bit, tap bottom screen, select "Exit Retroarch", CRASH! Everytime. Guaranteed.

Nothing you can do but nag the RA guys to fix it. Since the issue has been present basically forever, I'm not holding my breath. Luma's newest builds got a little more strict on the way it handles crashes (because the CFW devs are depending on people to fix this in their homebrew, where it needs to be fixed), so the issue hasn't been present until Luma3DS build version 8 and beyond.

If you MUST use Retroarch, my suggestion is to continue to use A9LH+Luma3DS 7.1. If you have a NAND backup from this setup, you can use GodMode9 to restore that NAND successfully to remove B9S, restore A9LH, and restore Luma3DS 7.1. I have done this and confirmed with astronautlevel that it works fine. Any games/updates/saves will need to backed up and restored afterwords. Keep in mind that Luma3DS does not support A9LH anymore and you will no longer receive support or updates for Luma3DS. Of course, the safest option is probably to wait until Retroarch fixes the issue. (And they may have in their latest updates, I'm not sure.)

For what it's worth: My experience with PCSX-ReARMed for 3DS has been pretty extensive. I've gotten a lot of games to play fine (~50-60 fps), and a lot more to play tolerably (~30-45 FPS). In all cases, audio must be disabled in RA settings for any game to load properly. Also, BIOS is important. Use a clean BIOS file (preferably SCPH-1001!) you know is good. (Meaning MD5/SHA1 hashes match the official!!!) Other than that, there isn't much else you can do. Not all games are going to play (Final Fantasy games are especially horrible), and those that do are going to suffer badly. You are much better off emulating on any other handheld, including any Android device. (For real, I have an old LG Optimus that runs Android 3.4 and plays PSx almost perfectly on its very tiny screen lol

tl;dr, Retroarch is essentially broken or at least not optimized to run in Luma. Unless the team takes the project out of mothballs, DosBox is always going to have issues.Regardless, I've tried Luma 9.0, 8.1.1, and 8.1 and all return the same stack error. I guess I could try and dig up some older builds of Luma to test them, but they probably won't run on B9S, and I don't think it'd make a difference. Perhaps I could have saved myself all this trouble by looking this up sooner, but I wanted to experiment for myself. For now, it looks like a solution is out of my lowly html-programming hands, unless someone else has any ideas.
 
Last edited by Kubba,

You may also like...

General chit-chat
Help Users
  • No one is chatting at the moment.
  • M4x1mumReZ @ M4x1mumReZ:
    Welcome new user
  • trepp0 @ trepp0:
    Just got the notice that school is being released 2 hours early cause of the winter storm
  • trepp0 @ trepp0:
    lets go
  • Psionic Roshambo @ Psionic Roshambo:
    Better than 3 hours late from a lockdown lol
    +1
  • FAST6191 @ FAST6191:
    While I know you mean in case of someone confusing schooling establishment from shooting establishment (many of the same letters) I am still going to read that as lockdown (also known as lock in) for a pub
  • FAST6191 @ FAST6191:
    where if you were in the club you could be invited to be there as a guest of the landlords after things are supposed to stop being served
  • FAST6191 @ FAST6191:
    Have technically done that in a school but it was the sports centre associated with the school more than the school itself
  • FAST6191 @ FAST6191:
    being drunk in school was either because drunk on playing field or could not be arsed with one particular Thursday afternoon so went and had some beers and played some games instead before returning for an ill advised last lesson/period
  • K3N1 @ K3N1:
    Being drunk and high in school was cool
  • K3N1 @ K3N1:
    It was high school
  • The Real Jdbye @ The Real Jdbye:
    my power cut out twice
  • The Real Jdbye @ The Real Jdbye:
    my pi running octoprint wiped all my plugins and i cba to fix it
  • Psionic Roshambo @ Psionic Roshambo:
    No pi for you lol
  • Sonic Angel Knight @ Sonic Angel Knight:
    Psi, you didn't spell your name right
  • Sonic Angel Knight @ Sonic Angel Knight:
    It's "Psionic" not "PI"
  • Psionic Roshambo @ Psionic Roshambo:
    So R Kelly is probably pissing himself right now
    +1
  • K3N1 @ K3N1:
    R Kelly knows how to piss on himself?
    +1
  • Veho @ Veho:
    Is it better to be pissed off than pissed on?
    ZeroT21 @ ZeroT21: :rofl2: