''Remove the extensions controller from p1's Wii Remote'' with Motion Plus Controller

Discussion in 'Wii - Backup Loaders' started by kingmetal, Aug 6, 2014.

  1. kingmetal
    OP

    kingmetal Newbie

    Newcomer
    1
    0
    Aug 6, 2014
    United States
    Preamble: I'm very new to the community so please excuse this post if it's common knowledge, and certainly excuse my improper use of terminology.

    I'm having trouble with a couple of games, specifically Donkey Kong Country Returns and Kirby Return to Dreamland -- both games are prompting me to remove extensions from my Motion Plus (built-in) controller (the wording is slightly different per game). Kirby actually shows a picture of a Nunchuck, but the wording is generic. I, of course, do not have anything plugged into the controller, and I've tried reconnecting and resyncing the controller with nothing plugged into it.

    My plain Wiimote works fine with these games and detects the state of the Nunchuck properly. Strangely, Mario Kart Wii also seems to be able to tell when the Nunchuck is connected or not (the controller icon changes to a steering wheel on the Wiimote Plus when you remove the Nunchuck).

    Is this a known issue? I've dug around in both WiiFlow and USB Loader GX and can't find any options to force controller type. Here are the relevant technical details about my setup:

    Gamecube compatible Wii (4.3U)
    USB Loader GX 3.0 (I also have WiiFlow 4.2.1)
    d2x-v10-beta52 (IOS Base 56 in slot 249, Base 57 in slot 250)

    If other people are able to use their WiiMote Plus controllers without issue I may just restore from backup and start over. I followed a confusing guide originally and have been playing around and learning -- I am confident that my cIOSes are installed properly (and I've tried launching the games from slot 249 and slot 250 to no avail). Thanks in advance!
     
  2. RCJayce

    RCJayce The Defender Of Tomorrow

    Member
    618
    166
    Aug 11, 2014
    United States
    New York
    Hi! I also have built-In Motion Plus Wiimotes, and those games in particular runs and plays fine in my Black Wii, softmodded vía Pimp my Wii, so i suggest restore a backup and start all again.