[Release] Checkpoint, a fast and simple save manager for 3DS and Switch

Discussion in 'Switch - ROM Hacking, Saves, Translations & Tools' started by EventAssistant, May 14, 2018.

  1. SedRick_M89

    SedRick_M89 Member

    Newcomer
    2
    Jun 14, 2015
    You ever get this working?

    — Posts automatically merged - Please don't double post! —

    Anyone have the solution for this?

    I just backed up the saves from a switch running 8.0.1 firmware on exfat so that I could update it to 8.1.0 and use a newer cfw method with fat32 sd setup.

    Now that it's all setup, the saves aren't showing up in checkpoint so I cant restore them.
    I've used the same profile name as before just in case that would cause an issue.

    Anyone know a fix for this issue?
     
  2. RedHunter

    RedHunter GBAtemp Fan

    Member
    6
    Dec 12, 2014
    Italy
    Is it normal that to make some games appear in the app you have to start the game first so it creates a save and only at that point the app see the game and you can restore it? Mario Tennis for example did this.
    It's annoying because force you also to have tons of backup folders on the pc.
     
  3. TouToTheHouYo

    TouToTheHouYo Member

    Newcomer
    2
    Dec 7, 2018
    United States
    I recently encountered a problem wherein trying to restore an old save for a game it wasn't registering in Checkpoint. This solution may be obvious to some but it was a particular problem I hadn't encountered before: If you delete the save data for a game from your system NAND Checkpoint won't recognize the title ID of the backup save on your SD card and you won't be able to restore it. You'll have to reinstall the game and create new save data. This'll allow Checkpoint to register the game's ID and allow you to restore your backup data.
     
  4. lucthecookie

    lucthecookie Newbie

    Newcomer
    1
    Aug 8, 2019
    United States
    Using checkpoint, I accidentaly restored a backup to the wrong user and lost my save there, and I was thinking if there was a way to backup the original save file from the console memory, or does the restore completely overwrite the original save file, making it impossible to restore with no backup?
     
  5. zaku

    zaku GBAtemp Regular

    Member
    3
    Jun 26, 2018
    Uganda
    3.7.0 doesn't work for me. crashed back to album menu.
     
  6. raxadian

    raxadian GBAtemp Advanced Fan

    Member
    5
    Nov 10, 2018
    Argentina
    Yes.

    That's why you should always backup before replacing a save file.

    Still, maybe you could do some save editing or something. Otherwise, just start the game again.

    I mean, if you really like a game; playing it again from zero is fun.
     
  7. merlin555

    merlin555 GBAtemp Advanced Fan

    Member
    7
    Oct 27, 2014
    Germany
    Same here.
    Crash after pressing.
     
  8. proffk

    proffk GBAtemp Fan

    Member
    4
    Aug 14, 2013
    United States
    Checkpoint 3.7.0 was crashing on me when launching through album. It only works when holding R button and launching through a installed NSW game.
     
    keine likes this.
  9. keine

    keine GBAtemp Fan

    Member
    3
    Aug 29, 2010
    United States
    Holding R from an NSP worked for me on 3.7.0. This worked for me! Thanks. (Using sxos :/)


    Of note. If you are trying to restore, hit the R trigger button after starting the game you want to restore to. I wasn't seeing my backed up saves until I hit the R/L button and selected my new Account.
     
    Last edited by keine, Sep 10, 2019
  10. ber71

    ber71 Member

    Newcomer
    2
    Apr 24, 2019
    Spain
    I was able to backup saves, but I can't get the cheats working in sxos cfw. If that feature is atmosphere centric, that should be written somewhere in the docs to avoid misunderstandings.
     
  11. danver

    danver GBAtemp Regular

    Member
    3
    Sep 16, 2016
    United States
    In a Galaxy far far away
    i cant seem to figure out how in blazes to get the cheats to work on my atmosphere cfw switch i mean i am on the latest version of checkpoint and switch firmware 9.0 but cant find out why the cheats are not activating at all help would be most appreciative
     
  12. dsrules

    dsrules GBAtemp Guru

    Member
    10
    Sep 20, 2005
    I am getting "Please do not run Checkpoint in applet mode" when open checkpoint.nro 3.7.2
    what do that means? never had that before on older versions
     
    Last edited by dsrules, Sep 19, 2019 at 12:58 AM
Loading...