R4 broken?

Discussion in 'R4 DS' started by dragon574444, Dec 25, 2007.

Dec 25, 2007

R4 broken? by dragon574444 at 11:19 PM (2,798 Views / 0 Likes) 6 replies

  1. dragon574444
    OP

    Member dragon574444 GBAtemp Regular

    Joined:
    Dec 25, 2007
    Messages:
    287
    Country:
    United States
    I need some help...I bought an R4 about 2 months ago and I love it. However, I think it may be broken. I recently upgraded my firmware to 1.13, haven't got around to getting 1.14, and I'm having some problems. My R4 no longer boots games, hardware, or multimedia. When I checked on my computer, I noticed a bunch of corrupted files. Their names were...odd....and some files were over 5GB, despite me having only a 1GB micro SD card. This also makes me wonder if it's the SD card. It's a Lexar 1GB, assembled in Taiwan. I tried reverting to older firmware, formatting, and I still cant get it to work. Also, maby I formatted it wrong for the R4? What should the File System and the Allocation Unit Size be? Maby that could do it?

    Sorry, but I really don't know much about the R4. Any help would be appreciated.

    After scanning some of the other topics on the board, I wonder if the USB reader is to blame? So many things could be wrong with it, but I have no idea which is really the problem...

    I think it may be the SD card. I've tried reformatting it again, and it took a LONG time to write just the firmware; over 5 minutes.
     
  2. dragon574444
    OP

    Member dragon574444 GBAtemp Regular

    Joined:
    Dec 25, 2007
    Messages:
    287
    Country:
    United States
    No one has an idea what could be wrong? Even a theory about what's wrong would be nice...
     
  3. James B.

    Member James B. GBAtemp Regular

    Joined:
    Oct 4, 2007
    Messages:
    212
    Location:
    USA
    Country:
    United States
    wow.. definetly your micro SD card.. try formatting FAT32, but I don't know what allocation unit size you need to use. I hate situations like this... [​IMG].
     
  4. Panic101

    Member Panic101 GBAtemp Regular

    Joined:
    May 27, 2007
    Messages:
    109
    Country:
    United States
    Ok when did this event exactly occur give me a play by play of how it came about. Did you do anything out of your usual routine?

    Ask yourselves these questions.

    - Did you use the TF reader that came with the R4?
    - Did you remember to use "safely remove hardware" option after you updated the firmware?
    - Is your USB port faulty?
    - Are the contacts on the MicroSD scratched?

    Umm, you're microSD card though is definetly gone though, use your comp to reformat to FAT 16 since its 1GB card and start over. If that doesnt work use this program, SD Formatter 2.0. If that doesn't work use a Digital Camera or a Phone to reformat. Also, try and see if any other MicroSD cards work with the R4. If I were though I'd try stay away from Taiwan made cards as much as possible. Go for Japan Made ones. Update us~
     
  5. betawind

    Member betawind GBAtemp Regular

    Joined:
    Apr 21, 2007
    Messages:
    192
    Country:
    United States
    I second the notion of using FAT16 on the reformat. If I recall correctly, FAT32 is useless on anything 2gig or less. I may be wrong though [​IMG]
     
  6. dragon574444
    OP

    Member dragon574444 GBAtemp Regular

    Joined:
    Dec 25, 2007
    Messages:
    287
    Country:
    United States
    Thank you for all the responses, and I'm glad it's not the R4 that's broken, Dealextreme just stopped selling them [​IMG]

    I'm going to buy a nice Kingston 2GB micro SD from buy.com for 24.95$ I certainly hope this won't happen again. I'm going to use the SD card reader that comes with the SD card, not the one that comes with the R4, and always use the safely remove hardware option as I have always done in the past.

    Also, my micro SD is now completely corrupt. After reformatting it once more in fat 16, it's pretty much dead. Windows Vista now crashes when I plug it in and try to access it, and Windows XP can't even recognize it.
     
  7. Panic101

    Member Panic101 GBAtemp Regular

    Joined:
    May 27, 2007
    Messages:
    109
    Country:
    United States
    Did you try the program in my post?
     

Share This Page