Question about 1.4.3

Discussion in 'NDS - Flashcarts and Accessories' started by MrMaple, Feb 14, 2012.

Feb 14, 2012

Question about 1.4.3 by MrMaple at 3:54 AM (508 Views / 0 Likes) 6 replies

  1. MrMaple
    OP

    Newcomer MrMaple Member

    Joined:
    Feb 13, 2012
    Messages:
    13
    Country:
    United States
    Hey, again, I'm sorry if this has been answered, but I'm really confused by mixed reviews and guides.

    My DSi is currently on FW 1.4.3 . If I purchase an Acekard 2i, will it still work fine? I keep finding different reviews saying that you need 1.4.1 or you have to update your Flashcart before your DSi.
     
  2. CannonFoddr

    Member CannonFoddr Regular GBATemp Lurker

    Joined:
    Sep 23, 2006
    Messages:
    4,106
    Location:
    Sitting by computer
    Country:
    United Kingdom
    It depends....

    IF you are lucky - the person you buy the card from may already update the Acekard2i already & you won't need to worry - it'll work straight out of the box

    HOWEVER, you MAY get 'old stock' or the shop you buy from don't/won't update the AK2i - in which case YOU will have to update the card yourself

    The only way you can do it yourself is IF...

    1) You own a DSi with 1.4.1 firmware (or less)
    2) You own a DSLite/DSPhat console

    The reason is that to update the AK2i - you need it to be able to run on the system you updating it with to use the updating software for the AK2i

    If the DSi is on anything higher than firmware 1.4.1 - the card will not be able to run (it is 'blocked') so you will not be able to run the AK2i updating software, so in this case you would need to use a DSi with 1.4.1 (which does allow the AK2i to run), or a DSLite/DSPhat
    (which doesn't block any flashcards)

    In your case, you are already on 1.4.3 - so any 'old stock' AK2i will not be able to run, so you will need a DSLite/DSPhat or older DSi to run the card to update it...
    IF you were lucky to have the older firmware - it is recommended to update the AK2i BEFORE you update the DSi firmware - because, as said, if you update the DSi first - you won't be able to run the AK2i to update it

    Hope this clears up the confusion
     
  3. MrMaple
    OP

    Newcomer MrMaple Member

    Joined:
    Feb 13, 2012
    Messages:
    13
    Country:
    United States
    I happen to have a DSPhat also, so I should be okay? I'm kind of confused on something though. Do I need to update the Flashcart in the DSPhat? I can't just update it with a Micro SD?

    I purchased the card off of realhotstuff and it says it comes ready for 1.4.3
     
  4. CannonFoddr

    Member CannonFoddr Regular GBATemp Lurker

    Joined:
    Sep 23, 2006
    Messages:
    4,106
    Location:
    Sitting by computer
    Country:
    United Kingdom
    I think you are getting a little confused (or maybe I misunderstand what you're saying).... but I'll try & make it a little clearer (I hope)
    [Note I've not done a Ak2i update for quite a while, so I'm working from memory]

    The [basic] procedure to update a flashcard firmware, is that you....
    • Download a firmware update for the flashcard (the AK2i) - I think this is usually a *.nds file (although I think some other cards uses *.dat or some other 3-letter file extension)
    • You place the file onto your MicroSD card & put it into the flashcard
    • Put the flashcard into your DS
    • Switch on your DSlite/Phat/DSi (whatever you have) & select the flashcard from the main DS menu (in a similar way of starting the card to run a ROM or homebrew)
    • The flashcard MAY automatically see the update file OR you have to select it to run it like a normal homebrew/ROM etc
    • The Software will run & do what it needs to do to update the flashcard firmware
    • Usually, when successful, you're told to turn off the DS (it might auto-reboot anyway)
    That's it - your flashcard is updated to work on the latest DSi (or 3DS) firmware



    Now perhaps you can see (in the forth step)... that IF your DSi is already on 1.4.3, you will not be able to start/run the flashcard to select the update software, since this particular Nintendo Firmware prevents flashcards from actually running in the first place

    So the alternative way to update the flashcard, is to do the above procedure on a DS that WILL allow the flashcard to run as normal.

    Since the DSLite/DSPhat don't get Nintendo 'firmware updates' then all flashcards that ran on those systems will still run without any problems, allowing you to select the flashcard update file & run it (The same applies if you had a DSi with 1.4 - this firmware didn't block flashcards either)

    NB: just remembered - I think that you have to MAKE SURE you download & run the correct version of firmware update depending on what you were updating the flashcard on (a DSLite/DSPhat or a DSi). I think one had '_DSI' in the title and the other had '_NDS' - not sure though

    You shouldn't have any problems since you've said that the card is already updated to run on 1.4.3.
    It will only be necessary If/When Nintendo brings out another firmware update that blocks Flashcards again
     
  5. MrMaple
    OP

    Newcomer MrMaple Member

    Joined:
    Feb 13, 2012
    Messages:
    13
    Country:
    United States
    Alright, I was just unclear that you had to update your flashcart with your DS. I thought it was all done on your computer through the Micro SD.

    If it comes pre-flashed for 1.4.3, should I still update it to AKAIO 1.8.9?

    Thanks again for the info.
     
  6. Luigi2012SM64DS

    Banned Luigi2012SM64DS G-old member

    Joined:
    Aug 27, 2011
    Messages:
    2,060
    Location:
    Minecrapt
    Country:
    Canada
    akaio is not an update it is a kernel.
    btw only the dstwo can be updated using the micro sd because of its (uncurrent information) amazing team.
     
  7. MrMaple
    OP

    Newcomer MrMaple Member

    Joined:
    Feb 13, 2012
    Messages:
    13
    Country:
    United States
    Oh, well I did not know that. Thanks.
     

Share This Page