PSP 100x hacking help

Discussion in 'PSP - Hacking & Homebrew' started by heartgold, Apr 21, 2011.

  1. heartgold
    OP

    heartgold GBAtemp Psycho!

    Member
    4,342
    1,032
    Sep 11, 2009
    London
    I'm getting a psp 100x model on firmware 2.60. I'm totally new to the psp scene so is it hackable and if so what do I need to do from here.

    Can you advise the best cfw to go with and do I need the pandora battery or can I manage without it?

    Yeah I know people are gonna mention the go read the sticky and I've already have. Just asking for your opinions and incase I might do something wrong. =P

    Also due to only having 32MB ram, does that make it worse are emulating n64 games than other models? Just a bonus if it could.
     
  2. Nujui

    Nujui I need something to do.

    Member
    3,933
    131
    Aug 12, 2010
    United States
    Dreamland.
    Would either suggest getting Prometheus or Gen.

    No you don't need one, but is recommended in case of a brick.

    Emulation does seem to be a bit slower on there, yes.
     
  3. Rydian

    Rydian Resident Furvert™

    Member
    27,883
    8,108
    Feb 4, 2010
    United States
    Cave Entrance, Watching Cyan Write Letters
    6.20 PRO-B4, no pandora.

    Still emulates N64 games, just needs more/longer loading times.
     
  4. heartgold
    OP

    heartgold GBAtemp Psycho!

    Member
    4,342
    1,032
    Sep 11, 2009
    London
    Do I need to update to ofw 6.20 for this? This cfw is not up there in the sticky guide, sorry I'm a bit confused.
     
  5. Rydian

    Rydian Resident Furvert™

    Member
    27,883
    8,108
    Feb 4, 2010
    United States
    Cave Entrance, Watching Cyan Write Letters
    It's not in the sticky because it doesn't have the best PSX compatibility, so lots of people still prefer the older firmwares.

    Yes you need to be on 6.20 to use it.
    There's a thread about the 6.x CFWs here.
     
  6. heartgold
    OP

    heartgold GBAtemp Psycho!

    Member
    4,342
    1,032
    Sep 11, 2009
    London
    What about pro b5?

    What does 6.x cfw offer over the older ones?
     
  7. Rydian

    Rydian Resident Furvert™

    Member
    27,883
    8,108
    Feb 4, 2010
    United States
    Cave Entrance, Watching Cyan Write Letters
    Yes, use B5 now that it's been fixed.

    The 6.x firmwares offer compatibility with newer games and plugins and homebrews.
     
  8. heartgold
    OP

    heartgold GBAtemp Psycho!

    Member
    4,342
    1,032
    Sep 11, 2009
    London
    Okay thanks.

    Should i apply the permanent patch and what does that mean?
     
  9. Rydian

    Rydian Resident Furvert™

    Member
    27,883
    8,108
    Feb 4, 2010
    United States
    Cave Entrance, Watching Cyan Write Letters
    The permanent patch turns the 6.20 temporary CFW into a permanent CFW.
     
  10. heartgold
    OP

    heartgold GBAtemp Psycho!

    Member
    4,342
    1,032
    Sep 11, 2009
    London
    Can you change to another cfw with permanent?
     
  11. Rydian

    Rydian Resident Furvert™

    Member
    27,883
    8,108
    Feb 4, 2010
    United States
    Cave Entrance, Watching Cyan Write Letters
    Yes, running hellcat's recovery flasher you can install an earlier OFW and from then move onto another CFW.
     
  12. heartgold
    OP

    heartgold GBAtemp Psycho!

    Member
    4,342
    1,032
    Sep 11, 2009
    London
    Thanks for your help! :]
     
  13. CrazySka

    CrazySka The Original Ska

    Member
    374
    170
    Oct 24, 2002
    United States
    MD, USA
    I didn't know this so which is the best CFW to be running? I also have a psps 1000
     
  14. Rydian

    Rydian Resident Furvert™

    Member
    27,883
    8,108
    Feb 4, 2010
    United States
    Cave Entrance, Watching Cyan Write Letters
    5.x has better PSX and plugin compatibility.

    6.2 has better PSP game compatibility.
     
  15. xist

    xist ΚΑΤΑ ΤΟΝ ΔΑΙΜΟΝΑ ΕΑΥΤΟΥ

    Member
    5,861
    863
    Jul 14, 2008
    6.2 has better NATIVE compatibility. 5.xx can play everything with patching whereas 6.xx can't use plugins or lots of PSX games no matter what.
     
  16. Rydian

    Rydian Resident Furvert™

    Member
    27,883
    8,108
    Feb 4, 2010
    United States
    Cave Entrance, Watching Cyan Write Letters
    DJ Max Portable 3 works on a 5.x?
     
  17. xist

    xist ΚΑΤΑ ΤΟΝ ΔΑΙΜΟΝΑ ΕΑΥΤΟΥ

    Member
    5,861
    863
    Jul 14, 2008
    (Sorry i've just noticed your reply...)

    Yes DJMP 3 works fine on 5.xx when a simple patch is applied. Well M33 at least; i'm unsure if the GEN prx's cause issues.