Problems with a custom firmware

Discussion in 'PSP - Hacking & Homebrew' started by XavierRD, Feb 19, 2016.

  1. XavierRD
    OP

    XavierRD Newbie

    Newcomer
    1
    0
    Feb 19, 2016
    Mexico
    I don't know if this kind of specific help thread is against the rules, but I wasn't able to find anything so here I come.

    A PSP 1010 recently came into my possession. It seems it's already got a custom firmware installed, 6.20 TN-C. I wanted to use it primarily to run emulators, but I've run into problems. The first emulator I tried, NesterJ 1.13 worked like a charm, so I assumed that I wouldn't have problems with most homebrew, but it seems it was rather the exception. I've tried for example to run different versions of SNES9x TYLmecm and SNES9x Euphoria, all to no avail and got the same results with gpSP Kai 3.4. They all say "The game cannot be started. The data is corrupt" when I try to run them.

    Looking a bit further in the internet, I found that TN-C doesn't seem to be a really reliable or current firmware to begin with, so I started to look into that. I found that it may be easier to use 5.03 or Custom Firmware M33/PRO, but the information I've found about downgrading/changing the firmware is lacking at best, full of broken links and really old tutorials. So I guessed that it would be the best to come where there are people knowledgeable on this matters and ask for specific help on this case.

    So, what do you think I should do? Why wouldn't I be able to run the emulators? Should I change to another firmware? Is the change made more difficult by the fact that I've already got another CFW installed?

    Thank you!