Preloader v0.30 Installer / Removal Tool

Discussion in 'Wii - Hacking' started by phpgeek, Oct 13, 2009.

  1. phpgeek
    OP

    phpgeek GBAtemp Regular

    Member
    1
    Feb 15, 2009
    That is correct, as I removed this to fix SDHC support properly. USB 1.1/2.0 support will be implemented in rev 5.


    Finally, if I have not responded to any issues directly, don't worry about it, I have read all the feedback in this thread and appreciate all your constructive posts. These posts are all taken on board and considered as the development cycle progresses.


    /phpgeek
     
  2. lightyear

    lightyear GBAtemp Regular

    Member
    1
    Mar 5, 2009
    United States

    DOL loading is working for me....did no one hear me about that? I even posted my youtube video proving that it works!! All I did was copy the dol I wanted to load from my apps folder so it's got a twin in both the root folder & the apps folder. In my case, it was USB loader GX's boot.dol (I left it boot.dol....don't know if that matters) Then I installed the app with preloader, selected to autoboot installed dol, and when I restart USB loader GX opens up...every time!! If I hit the home button (even while playing a game) and select system menu, it returns to USB loader GX...it literally becomes the system menu.

    I still have full access to HBC, disk loading, USB loading, navigating the SD card, USB loader options, etc, etc, etc....the only way to get to the Wii system menu now is for me to change autoboot back to system menu. Even if I click on system menu in preloader it loads USB loader as long as it's set to autoboot the file.
     
  3. lightyear

    lightyear GBAtemp Regular

    Member
    1
    Mar 5, 2009
    United States
  4. mgrimmenator

    mgrimmenator GBAtemp Regular

    Member
    1
    Sep 12, 2009
    United States
    Just knowing that your looking into all of this and there is going to be changes in future releases is good enough for me. Thanks for your dedication. I know it can sound like we are bashing you guys sometimes in our impatience to get what we want so fast. We just have to be patient and wait for you guys to do what you do. Keep up the great work! Can't wait for rev5 and so on.
     
  5. laurozza

    laurozza GBAtemp Fan

    Member
    1
    Sep 17, 2008
    Italy
    This is exactly my same problem http://gbatemp.net/index.php?s=&showto...t&p=2336576
     
  6. piratesmack

    piratesmack GBAtemp Advanced Fan

    Member
    2
    Mar 28, 2009
    United States
    $(pwd)
    Thanks, phpgeek, my SDHC card works with r4
     
  7. lightyear

    lightyear GBAtemp Regular

    Member
    1
    Mar 5, 2009
    United States
    What problem??? I'm happy about being able to autoboot USB GX [​IMG]
     
  8. illinialex24

    illinialex24 GBAtemp Advanced Fan

    Member
    1
    May 26, 2009
    United States
    The Midwest
    Can you please upload to somewhere else besides than Rapidshare as well??
     
  9. ether2802

    ether2802 we have the techno...!!

    Former Staff
    3
    Oct 14, 2007
    Mexico
    Pto. Vallarta

    Thanks for answering Mr. phpgeek, I'll uninstall and then install back again r4 to see if that fixes the problem, just to be sure we are talking about the same issue:

    the Wii restart like if you had just turned ON the console everytime you exit a channel, instead of just resets it.

    and what does it means:
    reinstalling preloader using the IOS249 method
    ...?? [​IMG]
     
  10. phpgeek
    OP

    phpgeek GBAtemp Regular

    Member
    1
    Feb 15, 2009
    It means hold down b when you install/uninstall, see first post.


    /phpgeek
     
  11. Terrus

    Terrus Newbie

    Newcomer
    2
    Jan 9, 2004
    Gambia, The
    Got a quick question, sorry if it has been asked before.

    Today I visited a friend of mine and we softmodded his Wii (new V4.0E), we basically followed this guide: http://docs.google.com/Doc?id=dfwvk5sg_60chp4jqf6#

    (Basically we did the steps 1. and 2. but updated PreLoader because we used the newest HBC Version and wanted to be able to access it from PreLoader for Brick protection)

    1. Installed HBC via Bannerbomb
    2. Installed Bootmii as IOS (no boot2 available) [​IMG]
    3. Installed Trucha Bug and cIOSRev14
    4. Installed Preloader, we tried to install 0.30 directly but had to install 0.29 first (as stated in the first post this version is only capable of updating? I'm new to this so bear with me please [​IMG] )
    5. We tried to DOP-IOS the IOSes 60, 36 and 21 afterwards, but then the system menu was gone (ES_Diverfiy failed message and bootup straight to PreLoader, so PreLoader saved our asses)

    Now the tutorial above states to reinstall PreLoader if this happens, we tried that but without luck. So we had to change the system menu IOS to 249 (from 60) to get it working again, but now system settings crash the Wii.

    Is this due to a missing install step in this version? If so, will it come in a future release? Because if this is the case we won't touch the system until a new version of PreLoader with the necessary functions comes out, otherwise we consider using a created NAND Backup. [​IMG]
     
  12. ether2802

    ether2802 we have the techno...!!

    Former Staff
    3
    Oct 14, 2007
    Mexico
    Pto. Vallarta
    Didn't worked, same problem, I held it down all the way after I pressed "LOAD" the app, till the installer kicked me back to the HBC, and nothing seemed different when I tryed holding "B" down and when I didn't, is that OK..?? I mean does anything extra needs to happen if you hold "B" down...?? [​IMG]
     
  13. D34DL1N3R

    D34DL1N3R Nephilim

    Member
    7
    Dec 6, 2008
    United States
    You're not understanding. No one is saying the program dol doesn't work. We're saying the forwarder dol doesn't work.
     
  14. lightyear

    lightyear GBAtemp Regular

    Member
    1
    Mar 5, 2009
    United States
    Code:
    http://www.megaupload.com/?d=3U197C2E
    This is the forwarder .dol that I've been using...all the files needed for USB loader are in ere except config [​IMG]

    Just extract to the root SD folder.

    Install boot.dol on the root with preloader, then set 'installed file' to autoboot. My wii autoboots the installed .dol file for me every time [​IMG] The video I posted proves this.
     
  15. razorback78

    razorback78 GBAtemp Maniac

    Member
    2
    Aug 3, 2009
    i have installed this preloader using 249 as per phpgeek told in the instructions. when the preloader installer is already booted up (all the blah, blah's and warning stuff on the screen), that's the time i hold the b button then press the + button to install... [​IMG]
     
  16. D34DL1N3R

    D34DL1N3R Nephilim

    Member
    7
    Dec 6, 2008
    United States
    I'm sorry to tell you that the boot.dol file in the root of your package is not a forwarder.
    It's the exact same program dol that you have in the apps/usbloader_gx folder.

    If you use an actual forwarder I'm sure you'll see that it doesn't work.
     
  17. lightyear

    lightyear GBAtemp Regular

    Member
    1
    Mar 5, 2009
    United States
    Ok, then so be it....it still autoboots the .dol....so what's the difference if it's a forwarder or the full app? Who cares? All I know is I've got USB GX autobooting & with that I can make my own custom themes & convert music to .ogg & play it in there as well...now I'm just waiting for the coders to release a shuffle music feature so I can listen to my whole music collection from the SD card without having to select one song @ a time. [​IMG]

    My point is this: who cares what .dol it loads....it still loads just like it should [​IMG] This is proof enough in my eyes to say it's not an issue with preloader, but rather the other .dol files you're all loading.
     
  18. wrettcaughn

    wrettcaughn GBAtemp Psycho!

    Member
    8
    Mar 14, 2009
    United States
    It is most definitely a preloader issue and has been known for quite some time... If you've noticed, the forwarder dol loads fine from HBC and via the forwarder channel. This is proof enough in my eyes (and those of the coders) that preloader is currently not capable of loading all dols. It has to do with entrypoints and crucial memory being overwritten.

    You're welcome to continue using your current boot.dol file to AUTOBOOT as long as you're fine with reinstalling it in preloader every single time you want to update to a new revision of the app.

    There will not be a shuffle music option anytime soon. The average person is inside the loader for about 10 seconds at a time so it would be pointless to implement such a feature. The coders are currently in bugfix mode so don't expect many new features (other than the possibility of improved homebrew and channel loading) for a while.
     
  19. lightyear

    lightyear GBAtemp Regular

    Member
    1
    Mar 5, 2009
    United States
    Ok, yeah....you are right there. The other day when v799 came out I had to copy a new .dol to the root folder...but this is just minor to me. A simple 200k file copy is the least of my worries if I've got everything else loading properly. I can load from disk & USB region-free, 100% of the time, I can create my own custom themes from scratch so that the whole loader looks like I want it to, I can string together 5-6 songs & play them as one file in background music, and I still have 100% full access to my SD card & HBC....I mean let's face it....this completely changes Wii homebrew. We don't have to stare at Nintendo's ugly-ass system any anymore....nor do we even have to use it!!! You can load all your games up without having to even touch Nintendo's installed first-party software....that in itself is absolutely a game-changer if you ask me [​IMG] And I'm happy with it where it is. I just can't see why everyone is complaining about something so small as having to use full wads, rather than being able to use forwarders for everything....It's not like HBC isn't accessible through USB GX if you really need it.
     
  20. ether2802

    ether2802 we have the techno...!!

    Former Staff
    3
    Oct 14, 2007
    Mexico
    Pto. Vallarta
    OK I did that too and still same issue, would the problem be because I'm on 4.1...?? [​IMG]
     
Quick Reply
Draft saved Draft deleted
Loading...