Pokemon Fire Red problem on the GBA Emu

Discussion in 'Supercard' started by Korbra, Jul 26, 2011.

  1. Korbra
    OP

    Korbra Newbie

    Newcomer
    8
    0
    Jul 11, 2011
    United States
    Okay so I've got the Official DSTwo plugin GBA Emulator and I'm trying to play Pokemon Fire Red. When you first start it up, it says "The 1M sub-circuit board is not installed". One site was talking about my exact problem on a different emulator and said to change the save type to flash 128k and it should work. So I did more searching and found another message board that linked to the game_config.txt and said it should fix the problem. Well I already have the latest game_config.txt in the root of my minisd and checked to make sure that FireRed was listed with a 128k save. No effect. A couple of forums mentioned save patches but if you scroll down, people replied to the thread saying the patch didn't work. Finally, I saw that some people ignore the message and use save states to get through the game but then when they get to the Elite 4 it restarts so I don't want to do that. Anyways, any help is appreciated.

    edit: This is my exact problem except I'm obviously not using the VBA or whatever he is using, I'm using the GBA Emu on the DSTwo.
    http://www.youtube.com/watch?v=7fczh_1qrAY

    edit2: I've done some more messing around. LeafGreen opens and saves without any of the error messages. It has no problem making a 128k .sav. The game_config.txt stuff is exactly the same for both games, so I don't know what the deal is. For some reason firered always has the sub-circuit board message and attempts to make a 64k .sav. I tried renaming the leafgreen sav as a firered just to see what would happen and that didn't do anything either.
     
  2. Terminator02

    Terminator02 ヽ( 。 ヮ゚)ノ

    Member
    4,517
    309
    Apr 10, 2010
    United States
    Somewhere near monkat
    surprised no one has answered this yet, it's simple:

    First, you need to download v1.21 of NDSGBA and extract the files to the root of your microsd card (an older version, so don't update it). Then, download game_config.txt and put that txt file in your microsd's NDSGBA folder.

    they should both work fine
     
  3. voice-echoed

    voice-echoed Member

    Newcomer
    24
    1
    Feb 2, 2012
    Canada
    Toronto, Ontario
    I followed your steps sand it didin`t fix anything..... I put the game config.txt in the root of my ndsgba folder and started up fire red and still have the same problem....???
     
  4. jurassicplayer

    jurassicplayer Completionist Themer

    Member
    4,355
    505
    Mar 7, 2009
    United States
    Pantsuland
    Are you using the right version of NDSGBA?
     
  5. goncalodoom

    goncalodoom GBAtemp Fan

    Member
    353
    9
    Sep 12, 2009
    portugal
    Just download fire red again,the rom may be corrupted
     
  6. Ryota Sakurai

    Ryota Sakurai Newbie

    Newcomer
    3
    0
    Jul 14, 2015
    United States
    Does the game_config.txt work for iSmart MM?
     
  7. MAXLEMPIRA

    MAXLEMPIRA Legends are Made from True Stories...

    Member
    856
    163
    Jun 24, 2012
    Mexico
    Kanto <- Hyrule -> Unova
    deleting de .sav already created?
    Hey, talking about this... I can't find any answer to this from very long time... I have Pokemon RojoFuego (Pokemon FireRed Spanish) and I'm trying to run it on VBAGX but it says that the game is broken and can't save... working on others emulator... have anyone found how to fix this?
     
    Last edited by MAXLEMPIRA, Aug 15, 2015
  8. dwtyre

    dwtyre Newbie

    Newcomer
    1
    0
    Jan 3, 2017
    United States
    having the exact same problem. has anyone found a solution?
     
  9. how_do_i_do_that

    how_do_i_do_that Blue Wizard is about to die.

    Member
    4,919
    256
    May 16, 2008
    Antarctica
    You have insufficient posts to view location.
    If you didn't do anything to the rom and this is how it was when you downloaded it, it means you got a dirty rom that was incorrectly patched.

    ---

    If your using the emulator, you need to likely change the settings. Someone already posted how above.
     
    Last edited by how_do_i_do_that, Jan 3, 2017