PLEASE HELP ME!!!

Discussion in 'R4 DS' started by Regulon, Jun 14, 2011.

Jun 14, 2011

PLEASE HELP ME!!! by Regulon at 12:08 PM (977 Views / 0 Likes) 5 replies

  1. Regulon
    OP

    Newcomer Regulon Member

    Joined:
    Mar 5, 2011
    Messages:
    15
    Country:
    United States
    Is there any way to downgrade this? I'm using a DSi and I accidentally updated mine to vers 1.4.2U (IDIOT!!!) I have a R4i V1.45 Revolution - www.ndsiLL.net
    And now it's messed up and I can't play anymore... OH GOD PLEASE HELP ME! [​IMG]
     
  2. Ron457x2

    Member Ron457x2 GBAtemp Regular

    Joined:
    May 21, 2011
    Messages:
    131
    Location:
    FL, Miami
    Country:
    United States
    Get a better flashcard...or wait for the team to update. Thats what EVERYONE WOULD SAY if you post this kind of help.
    Not to be rude, but its true.
     
  3. molh394

    Member molh394 GBAtemp Regular

    Joined:
    Dec 13, 2004
    Messages:
    209
    Country:
    Singapore
    No, you cannot downgrade your DSi.

    Edit: Yeah, the only solution currently is what Ron457x2 says above. If ndsiLL.net releases a 1.4.2 update you can still borrow a DS lite/phat and use that to update the flashcart, but so far it hasn't.
     
  4. Regulon
    OP

    Newcomer Regulon Member

    Joined:
    Mar 5, 2011
    Messages:
    15
    Country:
    United States
    Say it ain't so... After only a year of gaming my DSi finally died.. I guess it's just time to move on, I just wish i finished Okamiden... [​IMG]
     
  5. molh394

    Member molh394 GBAtemp Regular

    Joined:
    Dec 13, 2004
    Messages:
    209
    Country:
    Singapore
    Nope. Neither your DSi nor your flashcart is "dead". Both are in complete working order. They are just incompatible now.

    If you don't want to buy a new and better flashcart you will have to take a hiatus on Okamiden and so on, of course, but meanwhile don't junk them yet. If your flashcart maker's team is not dead they will release a v1.4.2 update sooner or later, and assuming that you don't go and update your DSi again it will then be able to work (if the team *is* dead then there is no reason to stick with a cart with such terrible support, I guess).


    Edit: Unflashable? Oh well, looks like it will only ever work on old DSis and DS phat/lites now. Best to go looking for an Acekard if you want to continue playing your DSi, it's only at most US$15 and is reliable and consistently updated.
     
  6. Buleste

    Member Buleste Old Fart

    Joined:
    Dec 19, 2010
    Messages:
    852
    Country:
    United Kingdom
    Don't bother waiting for a firmware update for your card as the http://www.ndsill.net/ is one of the many clones that cannot patch it's firmware.

    Keep your SDHC card, buy a better flashcard (preferably one that can update it's firmware such as the AK 2i, SCDS2, iSMM. R4ids.cn etc. etc. etc. (before you buy a card check it's website to see if they have released firmware patches)) and transfer your save data across when your new flashcard arrives.
     

Share This Page