Hacking Patched Switch 4.1.0 running higher fw games

onibaku

Lurker
OP
Member
Joined
Aug 15, 2007
Messages
320
Trophies
0
XP
1,881
Country
Sweden
So I bought a brand new switch and its on 4.1.0, its patched though but i got it new for a good price at an outlet! From what Im reading it seems to be possible to run games requiring higher firmwares using Tinfoil and Goldleaf, though they have their limitations. I know theres also support for cfw up to i think firmware 7 though its not released yet. I really want to play DQ XI, Witcher and Divinity 2.

Considering all the information available and a lot of it hasnt been updated I just wanted to make sure that Tinfoil and Goldleaf are indeed the best way to remove the firmware requirement or is there any other method I should look into that I possibly missed? I havent installed cfw on it yet cause im not sure i will if it will prevent me from playing newer games (which i assume it probably does already)
 

masagrator

The patches guy
Member
Joined
Oct 14, 2018
Messages
5,233
Trophies
2
XP
9,416
Country
Poland
It can be ignored, but SDK will eventually require something that your FW is not supporting.

You can make emuMMC with PegaScape, which can be updated to any FW you want that supports Atmosphere (and at this moment it supports all up to 9.0.1).

--------------------- MERGED ---------------------------

https://pegascape.sdsetup.com/
 
  • Like
Reactions: onibaku

Legendaykai

Well-Known Member
Member
Joined
Aug 15, 2008
Messages
97
Trophies
0
XP
178
Country
United States
not really a fan of modding the switch so early in it's life the 3ds, wii, wii and previous generations i understand but personally i think they only modded it to get bragging rights

but fair play to you if that's what you want.
 

Lacius

Well-Known Member
Member
Joined
May 11, 2008
Messages
18,100
Trophies
2
XP
18,242
Country
United States
As said above, your solution is to create an emuMMC/emuNAND that you can update. While your sysNAND will stay on 4.1.0, your emuNAND can be updated to whatever you want. Make sure you are certain you're on your emuNAND before updating it with ChoiDujourNX. If you accidentally update your sysNAND, you can no longer hack your Switch.
 
  • Like
Reactions: onibaku

onibaku

Lurker
OP
Member
Joined
Aug 15, 2007
Messages
320
Trophies
0
XP
1,881
Country
Sweden
It can be ignored, but SDK will eventually require something that your FW is not supporting.

You can make emuMMC with PegaScape, which can be updated to any FW you want that supports Atmosphere (and at this moment it supports all up to 9.0.1).

--------------------- MERGED ---------------------------

https://pegascape.sdsetup.com/

Ah right yeah I read about that, I was a little confused by that, so I can basically play anything up to 9.0.1 using this method? So I wouldnt need to use Tinfoil and Goldleaf then I assume? I shall look into it more!
 

The Real Jdbye

*is birb*
Member
Joined
Mar 17, 2010
Messages
22,116
Trophies
3
Location
Space
XP
11,452
Country
Norway
As said above, your solution is to create an emuMMC/emuNAND that you can update. While your sysNAND will stay on 4.1.0, your emuNAND can be updated to whatever you want. Make sure you are certain you're on your emuNAND before updating it with ChoiDujourNX. If you accidentally update your sysNAND, you can no longer hack your Switch.
Additionally he can make a second clean emuNAND for online use if he wants. Not gonna be 100% guaranteed safe from a ban, but pretty close.
 
  • Like
Reactions: onibaku and Lacius

Lacius

Well-Known Member
Member
Joined
May 11, 2008
Messages
18,100
Trophies
2
XP
18,242
Country
United States
Ah right yeah I read about that, I was a little confused by that, so I can basically play anything up to 9.0.1 using this method? So I wouldnt need to use Tinfoil and Goldleaf then I assume? I shall look into it more!
Yes, if you're using an emuNAND on 9.0.1, you can play newer games with it.
 
  • Like
Reactions: onibaku

Legendaykai

Well-Known Member
Member
Joined
Aug 15, 2008
Messages
97
Trophies
0
XP
178
Country
United States
I'm neither I'm simply saying, hacking a console so early in it's life is stupid. OK the switch is pretty limited with what it can do what with themes and a virtual console but that's what the older systems are for. I don't see why hacking it to pirate games and not support the developers is considered fine among people like you. You just can't seem to grasp that doing something so stupid so early in it's life while impressive to some while to others (developers) can be seen as damaging to them this is also the reason why the nes classic stopped production to slow down pirates which also made scalpers grab every one and jack the price of the system.
 
General chit-chat
Help Users
    Psionic Roshambo @ Psionic Roshambo: So it looks like Florida is going to get pounded by Ian lol