Okay to update firmware?

Discussion in 'Supercard' started by Jen, Oct 26, 2010.

  1. Jen
    OP

    Jen Newbie

    Newcomer
    2
    0
    Oct 26, 2010
    United States
    I just got a DSi XL and it says it is running Firmware 1.4U. I have the Supercard DStwo that's set up for 1.4.1, so am I okay to update my firmware on my DS? I just want to make sure that no new firmware has come out since 1.4.1 that'll eff up my card.

    Thanks!
     
  2. pichon64

    pichon64 GBAtemp Fan

    Member
    321
    0
    Nov 21, 2009
    Uruguay
    No new firmware out. But... do you really want to update your DSi? It's just a useless update, aimed to block flash cards...

    Just my 2 cents.
     
  3. Issac

    Issac I

    Global Moderator
    GBAtemp Patron
    Issac is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    5,363
    2,641
    Apr 10, 2004
    Sweden
    Sweden
    I'm pretty sure You can update... I'm not 100% sure though, so Someone else should confirm it... but if I recall correctly You'll be fine [​IMG]
     
  4. Jen
    OP

    Jen Newbie

    Newcomer
    2
    0
    Oct 26, 2010
    United States
    I just wanted to see what all was in the shop (I've played with it on Wii, but it's been a while), and in order to use it it is griping at me to update my firmware =/
     
  5. Terminator02

    Terminator02 ヽ( 。 ヮ゚)ノ

    Member
    4,517
    309
    Apr 10, 2010
    United States
    Somewhere near monkat
    if your card is in this list then you're fine and can update
     
  6. nl255

    nl255 GBAtemp Addict

    Member
    2,599
    367
    Apr 9, 2004
    Yes, 1.4.1 is the latest as of October 26, 2010.
     
  7. Presto99

    Presto99 You slammin, bro?

    Member
    913
    60
    Feb 24, 2010
    United States
    Skyworld
    you need the update for the shop, and it's not useless cause the shop will have Cave Story soon!
     
  8. Lilith Valentine

    Lilith Valentine GBATemp's Wolfdog™ ☠️Grunt☠️

    Member
    20,199
    21,560
    Sep 13, 2009
    Antarctica
    Between insane and insecure
    No anyone with a flashcard, it's useless
    And if you have a supercard two, go right ahead and update it since the supercard two can already work with the latest update.
     
  9. Rydian

    Rydian Resident Furvert™

    Member
    27,883
    8,112
    Feb 4, 2010
    United States
    Cave Entrance, Watching Cyan Write Letters
    Not if you want Cave Story.
     
  10. Zaertix

    Zaertix GBAtemp Advanced Fan

    Member
    565
    78
    Oct 20, 2009
    United States
    USA
    You can update your firmware I promise.
     
  11. zeno16

    zeno16 Advanced Member

    Newcomer
    55
    0
    Mar 15, 2009
    Yeah, no problemo on updating the DSi with sdtwo, best card I've had. [​IMG]

    P.S For me the update seemed useless, no good games in there.
     
  12. Lilith Valentine

    Lilith Valentine GBATemp's Wolfdog™ ☠️Grunt☠️

    Member
    20,199
    21,560
    Sep 13, 2009
    Antarctica
    Between insane and insecure
    I do love Cave Story [​IMG]
    But I am talking about anyone with a cheapo flashcard like a shitty R4 Clone that can't be upgraded. To a wise flashcard user like Acekard and Supercard users, it's fine to update as lone as they have updated their cards to begin with.