Nintendont can't read my Smash 4 GC adapter for melee

Discussion in 'Wii U - Hacking & Backup Loaders' started by Ultra7, Aug 27, 2016.

  1. Ultra7
    OP

    Ultra7 Newbie

    Newcomer
    3
    0
    Aug 27, 2016
    So I recently installed homebrew on the virtual wii part of my Wii U. I'm trying to get melee running via nintendont and I'm struggling with probably the last step which is getting the controls and the game actually running.

    The program seems to not recognize my adapter and then proceeds to shutdown. I'm entirely unsure of what to do and toggling various settings or replacing the ini file doesn't seem to work. I don't understand what it wants. I found the ini for the official usb to gc controller adapter and dropped it into the SD card but it stills says its not compatible.

    As far as I know everything is up to date as I added it all yesterday/today. Can anyone help?

    BTW - using a mac to setup all of this. Incase SD/controller.ini is supposed to not be where I think it is i.e simply placing it into the SD card
     
  2. pedro702

    pedro702 GBAtemp Guru

    Member
    6,338
    1,989
    Mar 3, 2014
    Portugal
    first off remove all usb devices from your wiiu what are you using to run nintendont games? usb/sd?

    also take a picture of your nintendont settings.
     
  3. Ultra7
    OP

    Ultra7 Newbie

    Newcomer
    3
    0
    Aug 27, 2016
    I'm using a SD card to load nintedont. The only USB device im using is the GC adapter for smash.
    Settings:
    IMG_0518.JPG

    Error:
    IMG_0519.JPG
     
  4. Ferrox

    Ferrox Member

    Newcomer
    17
    3
    Sep 16, 2015
    That's a really old version of Nintendont which probably doesn't have support for the adapter. Try updating it to a newer version.
     
  5. pedro702

    pedro702 GBAtemp Guru

    Member
    6,338
    1,989
    Mar 3, 2014
    Portugal
    that version is like 2 years old lol get the latest nintendont version 422 also debug option should be OFF

    you can get the latest nintendont dol here

    https://github.com/FIX94/Nintendont/raw/1ac0fdf55fae3f21cc7c49c5b9fb42fb55235958/loader/loader.dol

    rename it to boot.dol and replace it on your nintendont folder, hid option is now gone and its set automaticaly no need for controller inis.
     
    Last edited by pedro702, Aug 27, 2016
  6. Ultra7
    OP

    Ultra7 Newbie

    Newcomer
    3
    0
    Aug 27, 2016
    It works!!! I guess the smash thread is old. Thank you so much! .....and wow melee is so hard lol